Unity8 won't install properly

Bug #1477720 reported by Jared on 2015-07-23
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity8 Desktop Preview in LXC
Status tracked in Development
Development
High
Christopher Townsend
unity8-lxc (Ubuntu)
High
Christopher Townsend

Bug Description

Trying to install Unity8 via the terminal, and it messes up after a short while.

dpkg: warning: ignoring request to remove ubuntu-standard which isn't installed
dpkg: warning: ignoring request to remove systemd-sysv which isn't installed

This repeats over until it finally gives up, or I cancel the program.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8-lxc (Ubuntu):
status: New → Confirmed
Paul Olav Tvete (paul-tvete) wrote :

It looks like this can be worked around by Ctrl-C followed by

sudo unity8-lxc-setup --rebuild-all

(It may be necessary to also do: sudo unity8-lxc-setup --update-lxc)

Gerry Boland (gerboland) wrote :

I've heard reports that this seems to work around it:
sudo unity8-lxc-setup --rebuild-all

Jared (jyqq91) wrote :

I tried to rebuild the Unity8, and also tried updating. Neither seems to fix the issue. All that happens is that when I try to login with the LXC, the screen blacks out with random text. It might help to mention that I'm running Ubuntu Kylin 15.04.

pavel bursa (bursap) wrote :

Ubuntu 15.10, in VirtualBox -
dpkg: warning: ignoring request to remove ubuntu-standard which isn't installed
dpkg: warning: ignoring request to remove systemd-sysv which isn't installed

unity8-lxc-setup nor unity8-lxc-setup --rebuild-all did not work

option --update-lxc or --test xx gives : unity8-lxc-sertup: error: Unable to start the container...

minple (fminple) wrote :

This error exist on my laptop. Hoping it will fix soon

Serbulent (serbulentu) wrote :

I can confirm same issue on 14.04.3 as;

unity8-lxc-setup nor unity8-lxc-setup --rebuild-all did not work

option --update-lxc gives error: Unable to start the container...

Pavel (psdcoder) wrote :

The same repetitive messages in ubuntu 15.10 in vmware.
--rebuil-all doesn't work for me.
And on --update-lxc i also have error: Unable to start the container...

Christopher Townsend (townsend) wrote :

Hey All,

Sorry to take so long to address this:(

Part of this problem is the the Ubuntu Next ISO has been very out of date for a long time as it's no longer being developed. unity8-lxc currently using this ISO for installing the Unity 8 session on the system.

That said, I have to rethink how to make an updated Unity 8 LXC and deploy that. I have some ideas, so I'll be working on this now.

Changed in unity8-preview-lxc:
status: New → Confirmed
importance: Undecided → High
Changed in unity8-lxc (Ubuntu):
importance: Undecided → High
Changed in unity8-preview-lxc:
assignee: nobody → Christopher Townsend (townsend)
Changed in unity8-lxc (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in unity8-preview-lxc:
status: Confirmed → In Progress
Changed in unity8-lxc (Ubuntu):
status: Confirmed → In Progress
Changed in unity8-preview-lxc:
status: In Progress → Fix Committed
Changed in unity8-preview-lxc:
milestone: none → 1.0.4

Just tested it & works for me now! Thanks!

I ran:
```
sudo unity8-lxc-setup --destroy
sudo unity8-lxc-setup
```

sazwqa (sazwqa) wrote :

Hi,

Noticed a bug:

"/var/lib/lxc/unity8-lxc/rootfs"

This folder didn't exist on my system (Ubuntu 15.04) and the script kept crashing:

Traceback (most recent call last):
  File "/usr/bin/unity8-lxc-setup", line 134, in <module>
    with open(os.path.join(rootfs_path, "etc", "hostname"), "w+") as fd:
FileNotFoundError: [Errno 2] No such file or directory: '/var/lib/lxc/unity8-lxc/rootfs/etc/hostname'

So I went ahead and created this folder "rootfs" and it's now working.

sazwqa (sazwqa) wrote :

Ok, here's what I see:

Creating the new unity8-lxc container...
Using image from local cache
Unpacking the rootfs

---
You just created an Ubuntu container (release=wily, arch=amd64, variant=default)

To enable sshd, run: apt-get install openssh-server

For security reason, container images ship without user accounts
and without a root password.

Use lxc-attach or chroot directly into the rootfs to set a root password
or create user accounts.
Configuring the Unity8 LXC...
Starting the container
Not able to connect to the network.

Changed in unity8-preview-lxc:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8-lxc - 1.0.5+16.04.20151027-0ubuntu1

---------------
unity8-lxc (1.0.5+16.04.20151027-0ubuntu1) xenial; urgency=medium

  [ Chris Townsend ]
  * Bump version to 1.0.5.
  * Rework unity8-lxc-setup to download the latest Ubuntu release LXC and
    install a Unity 8 desktop session metapackage insteaf using the now
    deprecated Ubuntu Desktop Next ISO image. (LP: #1477720)
  * Many fixes for systemd based containers.
  * Changed some command line options to only have '--rebuild'.

  [ Marius Gripsgard ]
  * Bind mount the hosts locale inside the container. (LP: #1466035)

  [ CI Train Bot ]
  * No-change rebuild.

 -- Christopher Townsend <email address hidden> Tue, 27 Oct 2015 18:50:12 +0000

Changed in unity8-lxc (Ubuntu):
status: In Progress → Fix Released
Tim (perceptualchaos3) wrote :

I get the same error as @sazwqa running setup on v.1.0.5

Setting up unity8-lxc (1.0.5-0~79~201510271722~ubuntu14.04.1) ...
**** Please run 'sudo unity8-lxc-setup' to setup the Unity8 LXC ****

Brett Jackson (brettjackson) wrote :

I have the same error as @sazwqa and @perceptualchaos3 also.

I'm running on Ubuntu 14.04 and unity8-lxc version 1.0.5-0~79~201510271722~ubuntu14.04.1.

Is there any work around? I'm certain I can connect to the network.

It's most likely an LXC issue which can be very difficult to figure out.

Could you please do the following?

- apt-cache policy lxc
- Start the unity8-lxc container by hand and attach the output:
  'sudo lxc-start -n unity8-lxc --logfile=start_unity8-lxc.out --logpriority=DEBUG"

Thanks!

Changed in unity8-preview-lxc:
status: In Progress → Fix Committed
Florian W. (florian-will) wrote :

I also get this when running sudo unity8-lxc-setup --rebuild:
> Starting the container
> Not able to connect to the network.

When trying to log into the unity8 lxc session afterwards, I get this in unity-system-compositor.log (probably expected?):
0
130
lxc_container: cgmanager.c: lxc_cgmanager_enter: 694 call to cgmanager_move_pid_abs_sync failed: invalid request
lxc_container: cgmanager.c: cgm_attach: 1324 Failed to enter group /lxc/unity8-lxc/init.scope
lxc_container: attach.c: lxc_attach: 831 error communicating with child process
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]

This is the output you requested:

$ sudo lxc-start -n unity8-lxc --logfile=/tmp/start_unity8-lxc.out --logpriority=DEBUG
lxc-start: lxc_start.c: main: 279 Container is already running.
$ sudo lxc-stop -n unity8-lxc # this takes quite long, maybe a minute
$ sudo lxc-start -n unity8-lxc --logfile=/tmp/start_unity8-lxc.out --logpriority=DEBUG
$

The file start_unity8-lxc.out is attached to this comment.

Florian W. (florian-will) wrote :

I should probably add that I'm still on Trusty, kernel 4.2, and an older mesa/Xorg stack.

This looks to be related to a security consideration done here:
https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1476662

Removing the lines to mount /etc/localtime and /etc/timezone allows the container to start successfully. Still getting thrown out to the login screen though when trying to start from gdm3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers