[regression] Dash keeps repainting unnecessarily

Reported by Michal Hruby on 2012-04-13
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Precise
High
Andrea Azzarone

Bug Description

SRU testcase.

1. install unity from precise-proposed
2. make sure the dash is responsive and fast.

With Unity 5.10, if the Dash is opened it keep redrawing over and over again. This is visible as a somewhat sluggish (slower to respond) Dash experience when open.

This seems to originate in r2248 and is solved by the attached patch which will be uploaded via 'precise-proposed' as soon as possible as release of Ubuntu 12.04 LTS.

If this is cleared for distributing as a SRU (Stable Release Update) in Ubuntu 12.04 LTS then this would then be available as an immediate upgrade for most users.

Related branches

lp:~andyrock/unity/fix-980924
Merged into lp:unity at revision 2303
Gord Allott (community): Approve on 2012-04-18
Marco Trevisan (Treviño): Approve on 2012-04-18
Michal Hruby (mhr3) on 2012-04-13
Changed in unity:
milestone: none → 5.12.0
Neil Rodgers (neilr1971) wrote :

Are the side affects of this a very sluggish dash? If so this might be what I'm experiencing and I'll mark myself as affected. Every since the unity update to 5.10, my dash has been awfully slow and sluggish to the point that the mouse movement is affected too. If I disable either the "active" or "static" blur it performs as usual.

Changed in unity:
status: New → Confirmed
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Medium
status: Confirmed → In Progress
Gord Allott (gordallott) on 2012-04-17
Changed in unity:
importance: Medium → High
Changed in unity:
status: In Progress → Fix Committed
Tim Penhey (thumper) wrote :

Neil, yes I have been told that this could well explain the sluggish nature of the dash.

Changed in unity (Ubuntu):
status: New → Fix Committed
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
importance: Undecided → High
Paul Sladen (sladen) on 2012-04-25
description: updated
description: updated
Omer Akram (om26er) on 2012-04-26
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released

Hello Michal, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Junior_sampa (juniorperes-ig) wrote :

In tried with the proposed repo and even after the update, the behaviour is the same.

The processor cannot reduce the load for less than 40%. Checked with top in terminal.

it show the compiz usage (pulses) all the time.

GdH (georgdh) wrote :

I had this problem too so i tried that proposed upgrade and it works great on my system - fglrx, HD4870.

nuttzo33 (slucas1979) wrote :

If i open top in a terminal and click on the dash and move my mouse around the icons compiz goes over 50% cpu.I have the latest updates from propsed and it hasn't solved it for me.

Andrea Azzarone (andyrock) wrote :

@shayne
Because if you have the terminal bahind the dash, redrawing it is necessary :)

nuttzo33 (slucas1979) wrote :

ok i turned off sync to vblank and that seemed to have done the trick.

Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Alex Burfee (joop-wow) wrote :

How was this fixed? I'm still having problems. I just have to bring the dash down and the CPU usage goes very high without performing any search or navigation through it .

Daniel van Vugt (vanvugt) wrote :

Alex,

The fix was:
    https://code.launchpad.net/~andyrock/unity/fix-980924/+merge/102200

If you still have problems then please log a new bug using this command:
    ubuntu-bug unity

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers