Auto-hide Unity Launcher will not reveal when mouse pushed to left side in VirtualBox or VMware

Bug #971018 reported by Lumenary on 2012-04-01
314
This bug affects 67 people
Affects Status Importance Assigned to Milestone
Unity
Opinion
High
Unassigned
libxfixes (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu Precise 12.04 Beta 2 AMD64 DVD:

I am running Ubuntu Precise 12.04 Beta 2 in a VirtualBox 4.1.8 session. VirtualBox Guest Additions have been installed via "jockey-gtk" from the Ubuntu Precise repository, and Unity is running in 3D mode with Compiz.

When the Unity Launcher is set to "autohide," the Launcher will never reveal when the mouse pointer is moved to the left edge of the screen. It does not matter how much "pressure" is applied; the Launcher never appears.

I have tried the following VirtualBox window "form-factors," all with the same result (the Launcher never appears):

-- VirtualBox session running in a non-maximized window
-- VirtualBox session running in a maximized window
-- VirtualBox session running full-screen

I have attached a screen capture (OGV) with Ubuntu Precise running in a maximized VirtualBox window.

Note: This Bug may be related to the following other Bugs reported on LaunchPad:

-- Bug 965643: Unity 5.8: auto-hide using mouse reveals launcher inconsistently
-- -- https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/965643

-- Bug 923749: New "push mouse offscreen" feature really difficult to get
-- -- https://bugs.launchpad.net/unity/+bug/923749

-- Bug 937792: Left launcher does not revel when in autohide mode on multi-monitor setups
-- -- https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/937792

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
ApportVersion: 2.0-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Sun Apr 1 14:46:23 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Lumenary (nx-kadams) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Peter Magnusson (kmpm) wrote :

I am having the exact same issue but in vmware workstation.
Same in both unity-2d and unity sessions.

Wu En Feng (wuen32) wrote :

I have the same issue with VirtualBox and Intel Sandy Bridge HD2000 GPU

Martin Soto (soto255) wrote :

From what I see, disabling mouse integration in VirtualBox makes the autoreveal work again. My impresión is that VirtualBox stops sending mouse events to the host system as soon as the mouse cursor hits the border, and that breaks the "preasure" effect. With mouse integration disabled, all mouse events go to the virtual machine anyway, so autoreveal works.

The downside, at least here, is that you don't see the mouse pointer any more when mouse integration is disabled, so this is not really a work around, but may be a clue of where the problem is originating.

Just want to say that this behavior is happening to me as well. Worked fine in virtual box, on the same VM instance in 11.04. I upgraded the instance to 12.04 and this bug was revealed. So this is clearly a 12.04 bug that is not capturing the mouse events correctly from the VM for some reason.

Philippe Gauvin (marcusketchup) wrote :

Agreed with Matthiew Marcus, it works fine in 11.10, but buggy in 12.04 LTS

Dan Halbert (dhalbert) on 2012-05-25
summary: - Auto-hidden Unity Launcher will not reveal when mouse pushed to left
- side in VirtualBox
+ Auto-hide Unity Launcher will not reveal when mouse pushed to left side
+ in VirtualBox or VMware
Omer Akram (om26er) on 2012-05-25
affects: unity (Ubuntu) → unity
affects: compiz-core → compiz
Changed in compiz:
status: New → Confirmed
Lateralus (faithnomoread) wrote :

Just adding another name to the list of people with this problem. I am running Ubuntu 12.10 in VMware Workstation 8 in Windows 7 Ultimate 64 bit.

"My impresión is that VirtualBox stops sending mouse events to the host system as soon as the mouse cursor hits the border, and that breaks the "preasure" effect. With mouse integration disabled, all mouse events go to the virtual machine anyway, so autoreveal works."

It seems this could be related to the bug: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/938758

Marco Parillo (marco-parillo) wrote :

What I find interesting is that Xubuntu "Launcher" at the bottom (it has been a long time, but I think it is set to auto-hide by default) and the Kubuntu Panel (which I set to autohide) seem to work fine for me in VMWare, but not the Ubuntu Unity Launcher.

The way they works is very different: the kubuntu panel as the old unity launcher was using the mouse pointer position, now we use the Xorg Xfixes' pointer barrier feature that probably is not supported by these virtual machines drivers.

So I think the issue should be fixed at xorg level, more than in unity.

Changed in compiz:
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in xorg (Ubuntu):
status: New → Confirmed
Changed in libxfixes (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → High
no longer affects: compiz
Phil Buckler (buck2825) wrote :

I just did an in place upgrade from 12.04 to 12.10 installed on my physical machine, Dell E6500. Same problem.

Christian Sprauer (csprauer) wrote :

Same problem here with Mac Book Air OS Lion Host and Virtual Box & Ubuntu 12.04.1

Andrew Palmer (apalmer) wrote :

Just wanted to add that I too have this bug however I have one thing extra that is not apparent in the video above. When I click the option in settings to enable Autohide the bar disappears but leaves a background behind.
I have added a screenshot of this. As you can see when I drag a window into the area where the bar appears it is sent behind where the hidden launcher is usually displayed.

Ubuntu 12.10 fully patched. Also was happening before installing any updates.
Virtual Box: 4.2.6
Windows 7 x64

Hate to just add another comment confirming the above.

I have just constructed a new 12.04.1 LTS 64 bit machine, mainly because my attempts to upgrade from my much loved 10.04 LTS were so buggy.

The details of my system are as follows

Ubuntu 12.04.01 guest
Vmware Player 5.0.1 build-894247
Vista Service Pack 2 host
Dell Studio XPS 435MT

The new 12.04.1 machine works well and responds quicker than 10.04 which is good.

However when I switch on autohide for the Launcher, I cannot reveal it again with the mouse. I should add that I have no shadows, just no response at all.

The keyboard shortcuts all work perfectly and it will reveal when "alt F1" is pressed (or <alt> for search and the <super> key for the whole menu).

I have installed the CompizConfig Settings Manager and changed all the sensitivity settings with no result.

My assumption is that this is a 12.04.1 issue as I had no similar issues with autohide of toolbars or any other mouse behaviour at with edge of the desktop with Vmware in any previous version of Ubuntu.

As this bug seems to have affected a number of users for over 8 months, I was just wondering whether anyone was trying to address it.

Thanks

Rael Gugelmin Cunha (rael-gc) wrote :

The problem with Virtual Machines appears to be in the way the launcher (when hidden) is displayed on 12.04 and higher. On 12.04, behaviour has changed. We have now to press the pointer "out of the screen" in order to display it.

Which is a problem when "mouse integration" is active in the virtual machine.

LJ (the-mr-lj-88) wrote :

the same issue occurs with a touchscreen. The pressure to reveal the launcher equals a mouse movement over the screen-edge but this is impossible with a touchscreen or (vm window) of the some size as the screen. There should be an option to reveal the launcher by just hitting the edge - like the edge-gestures in compiz that work so far.

Stephen M. Webb (bregma) wrote :

The touchscreen gesture for revealing a hidden launcher is a 4-finger swipe. It's been available and documented since at least 12.04 Using a single-finger edge swipe is not physically possible with a touchscreen on a large selection of hardware or in windowed virtual machines.

i can confirm the problems reported above on Ubuntu 13.10 for x86_64 with roughly the latest updates via the apt repositorys. its running in virtual box 4.3.2 on a Windows 8.1 host. (telling the host to run it was a bios activation of VMs, the selection of Ubuntu _64_ in the box profile and enabling of some more advanced features of the box.)

there are two cases i observed on my own:
1) when running in virtual box with 3D enabled and the mouse integration on then the side-bar never will open on a mouse gesture.
2) when running the same with integration off it works but the mouse pointer has vanished.

these are probably two distinct problems rendering either option as not really useable.
for my impression case #1 is the more important one as thats the standard way most people will run the box, even if #2 as well is a definite major issue for operating the GUI.

_both_ issues shall be fixed!
the first might need an option (or automatism = tri states for the option) for changing the side bar opening meachnism behaviour.
the second i just dont know as i have no clue for what makes the mouse pointer disappear.

BTW - how is auto-hide as an option itsel controlled? cant find it in the settings. (settings are so slim that i had to install and run gnome tweaks to at least beeing able to change font sizes to fit them to my screen dimensions...) but i would need it to work-around and test a bit more.

PS: no idea how a "4-finger swipe" is defined. Using a simple mouse style laptop touch pad for years and only having activated vertical scroller for it since then. no having that available does again stopping me from testing the mentioned work around. (i tend to not likeing finger acrobatics as the touch here is quite limited in size.)

found hint on auto-hide:
http://askubuntu.com/questions/9865/how-can-i-configure-unitys-launcher-auto-hide-behavior
thus went for compiz settings manager...

found things like work around keystrokes noted there... <Alt/Super>, *** <Alt>F1 ***, <Alt><Tab>, <Alt><Shift><Tab>, ...
(*** => does show the launcher to you even in such a setup)

setting opacity to 1 and hide to never did me a good job for now.
other options like icon size do sound interesting but are not part of the work around for the topic here.

I want to add that this problematic behavior exists with Parallels Desktop virtualization software as well.

This is running Ubuntu 13.10 with latest updates in full screen on a Apple MacBook Pro with OS X 10.9.1 and Parallels Desktop 9.0.24172 (latest update as of writing).

I at least can press the command key and bring up the launcher search window which gives me access to the launcher, but the auto-hide reveal with mouse on left edge of screen function doesn't work.

Sasa Paporovic (melchiaros) wrote :

Also appears with Ubutnu14.04 64bit in VirtualBox 4.3.10. Adding tag for trusty.

tags: added: trusty

It has a moderate impact on a core package.

Changed in libxfixes (Ubuntu):
importance: Undecided → Medium
Changed in xorg (Ubuntu):
importance: Undecided → Medium
Michał Szwejkowski (pustka) wrote :

Still present on Ubuntu 14.10 VBox 4.3.18

Andrea Azzarone (azzar1) on 2014-12-03
Changed in libxfixes (Ubuntu):
status: Confirmed → Incomplete
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Seth Johnson (sethj) wrote :

This isn't really a bug in Unity. If you turn off mouse pointer integration (under the "Machine" menu) to prevent the host from stealing the focus everything works like a charm. This means that with pointer integration enabled and auto hide turned on when the mouse reaches the edge of the screen Vbox/VMWare decide to give focus to the host, not the guest. There isn't really much Unity can do about that.

As a workaround you can use: Don't hide the launcher, disable mouse pointer integration, use <super> to access the launcher, or <alt>+<f1>.

Will Cooke (willcooke) wrote :

As part of the big bug clear up for 16.04 this bug is being marked as Opinion. While this bug is affecting you, and potentially others, we do not consider it a priority for work and so it won't get fixed by us. Other developers are free to pick this up and work on it. Sorry that we can't offer you a fix at this time.

Changed in unity:
status: Confirmed → Opinion
Changed in unity (Ubuntu):
status: Confirmed → Opinion
Chris Cheney (ccheney) wrote :

This is still happening on 16.10 as expected due to the previous setting of 'Opinion' the only way to work around this issue on VMWare Workstation is to change the setting under Edit->Preferences->Input Optimize mouse for games: Always. Disabling "Automatically grab and ungrab the mouse cursor." does not fix the issue.

There probably should be an option for auto-hide to unhide on being near the edge, it could be settable just in unity-tweak-tool...

Tuxedo Joe (tuxedojoe) wrote :

I've found that setting:

- Reveal location: Left side
- Reveal sensitivity: Highest

works pretty good. Sometimes you'll have to move the cursor twice to the side/bottom though.

tags: removed: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions