Left launcher does not revel when in autohide mode on multi-monitor setups

Bug #937792 reported by Pete Graner on 2012-02-21
100
This bug affects 29 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Chris Halse Rogers

Bug Description

After this mornings (21 Feb) updates, I found that the left launcher will not reveal when it is set to autohide ON thru the Settings->Appearance->Behavior application. This was working fine before the update.

Pete Graner (pgraner) wrote :
Sebastien Bacher (seb128) wrote :

Reassigning to nvidia, Jason (DBO) said yesterday than they current drivers try to handle mouse events in some ways that they shouldn't (it's not the business of graphic drivers to handle input) which breaks the barrier code

affects: gnome-control-center (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Pete Graner (pgraner) on 2012-02-21
description: updated
Sebastien Bacher (seb128) wrote :

Jason, could you describe the issue, I probably did a non accurate job at summarizing the issue ;-)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

This is actually a core server problem; I'm testing a patch to fix it now.

affects: nvidia-graphics-drivers (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.11.4-0ubuntu4

---------------
xorg-server (2:1.11.4-0ubuntu4) precise; urgency=low

  * debian/patches/500_pointer_barrier_thresholds.diff:
    - Make the velocity calculation more robust on screen edges. Fixes reveal
      behaviour on nVidia 295.20 driver, which now clamps the pointer to the
      visible screen area. (LP: #937792)
 -- Christopher James Halse Rogers <email address hidden> Tue, 21 Feb 2012 17:04:41 +1100

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Edward Donovan (edward.donovan) wrote :

This bug is, chronologically, a dupe of #935766. Being earlier, that one got more users attached to it, but this one had the attention of the right people. So someone who knows the policies and practices better can pick which one to dupe, or what to do. I haven't marked #935766 closed yet, I was giving it a day or so for more users to report back happy.

Bryce Harrington (bryce) wrote :

I don't think there is a formal rule about it. Generally I dupe to whichever one has the better information. Sometimes the newer bug is better since it's tested against more recent bits, or because the reporter is more active, or something. All else being equal I'll default to the chronologically first, but really the only rule of thumb is do whatever is most likely to get the bug solved soonest. :-)

Dàrent (animaletdesequia) wrote :

The problem reappears with nvidia-current 304.51

quequotion (quequotion) wrote :

Same as Dàrent, launcher will not reveal with nvidia-current 304.51; also this is not only a multi-monitor problem.

Fr-coord (fr-coor) wrote :

I experience this bug in Precise amd64 fully updated, but only when using nvidia-current, whether the 295.40 or the latest 304.51.

kyleabaker (kyleabaker) wrote :

Those of you who've recently seen this bug, please add your feedback on the following bug report...
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1060511

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers