Progress bar in Unity launcher does not start on the left (there's a small gap)

Bug #968680 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-03-29
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Christopher Townsend
unity (Ubuntu)
Low
Christopher Townsend
Raring
Low
Unassigned

Bug Description

Open nautilus
Drag a very large file from one place to another in order to trigger a file copy dialog which will take some time
Observe a progress bar in the nautilus icon in the launcher
Use the 'appearance' dialog to adjust the size of the launcher.
Observe that anything below the default size there is a gap between the start of the losenge and the start of the progress bar.

See attached pictures.

Small.png - 32 pixel width - most prominent
medium.png - 39 pixel width - slightly prominent
large.png - 48 pixel width - default, no issue.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0+bzr2188ubuntu0+677 [origin: LP-PPA-unity-team-staging]
Uname: Linux 3.3.0-030300rc5-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Thu Mar 29 23:22:07 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120203)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) on 2012-04-02
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
summary: - progress bars in launcher inconsistent with different sized launcher
+ Progress bar in Unity launcher does not start on the left (there's a
+ small gap)
Changed in unity:
milestone: none → 7.0.0
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Stephen M. Webb (bregma) on 2013-04-25
Changed in unity:
milestone: 7.0.1 → 7.1.0
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)
Christopher Townsend (townsend) wrote :

This is due to the offset for the progress bar fill not working as intended. The current way it is being done, it does not scale at all when the icon size is being changed. While debugging this, I also noticed very large icons, ie, size 54, also is incorrect in that the progress bar fill starts too far to the left.

I have figured out what the scaling ratio is (0.125) and will being proposing a merge soon.

Christopher Townsend (townsend) wrote :

Adding a screenshot of this fixed for small icons in the Launcher.

Christopher Townsend (townsend) wrote :

Adding a screenshot of this fixed for large icons in the Launcher.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released
Izidor Matušov (izidor) wrote :

Stephen> Is there any way how to upgrade to the version which fixes this bug from standard Ubuntu 13.04?

Izidor Matušov asks:
> Stephen> Is there any way how to upgrade to the version which fixes this
> bug from standard Ubuntu 13.04?

This bug has already been nominated to be backported to Ubuntu 13.04. Now that it's been released in the development
version of Ubuntu, someone needs to propose merging the change to the 7.0 branch of Unity and complete the SRU paperwork.

Changed in unity (Ubuntu Raring):
importance: Undecided → Low
status: New → Triaged
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Raring):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers