Missing context menus for Qt apps after minimizing the window

Bug #929712 reported by klakier on 2012-02-09
136
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Unassigned
5.0
Fix Released
Medium
Unassigned
6.0
Fix Released
Medium
Albert Astals Cid
7.0
Fix Released
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]

Context menus disappear for Qt applications.

[Test Case]

1. Start Clementine
2. Minimize / Maximize Clementine multiple times (not close)
3. Try right click

What is the expected output?

The right click menu appers within Clementine.

What do you see instead?

Nothing. Right click = left click

[Regression Potential]

Code touches minimized windows behavior, but regression potential should be low, and code has been living in Ubuntu 12.10.

Related branches

klakier (insane-vx) on 2012-02-09
description: updated
description: updated
description: updated
klakier (insane-vx) on 2012-02-09
description: updated
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/929712/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
klakier (insane-vx) on 2012-02-09
affects: ubuntu → compiz (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
klakier (insane-vx) wrote :

Seems to affect Precise alpha2 too.

klakier (insane-vx) on 2012-02-27
description: updated
Davide (dspinell) wrote :

I confirm the bug in my system (Ubuntu 11.10 64bit), the problem appears with texmaker and mathematica. It does not affect unity 2d (qt based)

klakier (insane-vx) wrote :

Is there any progress planned on this bug? It still affects Precise beta 2...

klakier (insane-vx) wrote :

I managed to narrow it down to Unity being the main cause of the issue. Compiz with Gnome Classic is not affected. The problem exists only when Unity plugin is active in Compiz.

klakier (insane-vx) wrote :

I believe this problem may not be exactly the same as the one it is set to duplicate. This involves context (right-click) menus, not global menu, in fact affected applications may not even use global menu at all (e.g. Skype or QtCreator from official QtSDK). Also the fix released for #775278 does not correct anything reported here and I didn't notice the probem described in #775278 myself as I don't usually minimize apps to tray.

klakier (insane-vx) wrote :

The bug made it to final Precise...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-04-30
Changed in compiz-core:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
no longer affects: qt4-x11 (Ubuntu)
affects: unity (Ubuntu) → unity
Changed in unity:
importance: Undecided → Medium
description: updated
Changed in compiz-core:
status: New → Confirmed
Changed in unity:
milestone: none → 5.14.0
Jussi Lind (jussi-lind) wrote :

I reported 872977 (it's about broken QComboBox) already 6 months ago and now its marked as a duplicate of this context menu bug. However, now that I tried I can see the context menus in Qt Creator after minimizing it, but for example the build target selection in the lower left corner gets broken.

klakier (insane-vx) wrote :

@ Jussi: Try the context menu in the file list on the left, clicking the same file or folder. Context menu in the text editor of Qt Creator seems somehow unaffected - maybe it is recreated every time. I also noticed that the bug affects dropdown lists, just completely forgot to mention it :/

Changed in compiz:
importance: Undecided → Medium
status: New → Confirmed
Davide (dspinell) wrote :

Compiz was just updated but this bug seems to persist.

Changed in unity:
milestone: 5.14.0 → 5.16.0
Leks13 (leks-13) wrote :

I have a similar problem with disappearing menus after minimization in QT-apps(VLC, Psi+ etc).

Davide (dspinell) wrote :

After updating to Unity 5.16 the bug is still there

theghost (theghost) wrote :

Here too. This issue still exists in Unity 5.16.

klakier (insane-vx) wrote :

Looks like the bug will be preventing us from happily using Unity for some more time, cause nobody is working on it...

Albert Astals Cid (aacid) wrote :

Giving it a try

Changed in unity:
assignee: nobody → Albert Astals Cid (aacid)
Changed in unity:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Triaged
Changed in unity:
status: Triaged → In Progress
milestone: 5.16.0 → 5.18.0
Omer Akram (om26er) on 2012-10-03
Changed in unity:
status: In Progress → Fix Committed
no longer affects: compiz (Ubuntu)
no longer affects: compiz-core
no longer affects: compiz
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Changed in unity:
milestone: 5.18.0 → 7.0.0
Lisa Schmidt (boxnotify) wrote :

It's not only affecting the context menus. Also the dropdown menus of menu bar. The bug is still there in Ubuntu 12.04. When will we have the updates in the PPA?

Dixon Xavier (dixoncx) wrote :

Affects unity 5.16.0 in Ubuntu 12.04 x86_64.

Affects unity 5.16.0 in Ubuntu 12.04.1 LTS 32-bit
Dropdown menus of qtcreator menu bar disappear randomly after some time

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Precise):
status: New → Confirmed

Hello klakier, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.18.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Seems fixed, I cannot break the right-click menu anymore.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.18.0-0ubuntu1

---------------
unity (5.18.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher: start the drag icon request from the original mouse-down
      position. (LP: #858540)
    - Ignore transient unmmaped windows on minimize/unminimize
      (LP: #929712)
    - Fixes alt+tab losing focus when alt+tabing to quickly due to ubus
      being to slow to send a message (LP: #1035628)
    - If no icon is found then use the default one. This will cause all
      blank icons to be a '?' icon (LP: #886778)
    - Use GMountOperation in g_volume_mount. GMountOperation provides a
      mechanism for interacting with the use. (LP: #713432)
    - Do not reuse the menu entries if their order changes (LP: #1062283)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes. This avoids to get "?" icons. (LP: #772986)
    - Use linear filtering to draw icons (when needed). (LP: #1036231)
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 14:17:04 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity:
assignee: Albert Astals Cid (aacid) → nobody
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers