Launcher shows on the primary monitor instead of the left most monitor

Reported by Jason Smith on 2011-09-23
76
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Unity
High
Jason Smith
unity (Ubuntu)
High
Jason Smith

Bug Description

The launcher needs to lock to the left most screen due to design limitations

Jason Smith (jassmith) on 2011-09-23
Changed in unity:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jason Smith (jassmith)
milestone: none → 4.18.0
Jason Smith (jassmith) on 2011-09-24
Changed in unity (Ubuntu):
status: New → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → High
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Tal Liron (emblem-parade) wrote :

I'm glad to see that bugs are being fixed, but the bug I originally opened (which was marked as a duplicate of this) was just made worse.

My multi-monitor setup is such that it's very inconvenient to do any work on the leftmost monitor. It's true that I had issues with having the launcher on the monitor on the right, but at least I could easily access it! With the launcher on the leftmost monitor, there's simply no way I can use comfortably use Unity.

Brandon Frohs (bfrohs) wrote :

I agree with Tal Liron (emblem-parade). I would rather put up with not being able to keep the launcher open, and any other bugs associated with the design limitation, than be forced to have the launcher on the left most screen. And, if this isn't possible, some serious thought should be put into the layout of Unity to see if there is a better way to place things on the screen.

While I appreciate that the bug is being fixed with good readiness, I agree with the critics on the design choices. This solution is respecting the 80/20 rule, making most of the people happy with the quickest fix, but we really need to think about these design limitation, since Unity is going to be the default environment for most of us.
I mean, every dock in the world is movable around the desktop (at least the corners), why shouldn't Unity's do the same, to make power users happy? I agree with the default setup anyway, it's great for the wide screens we have nowadays.
Keep up the good work ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers