unmaximizable windows still show orange glow but fail to maximize

Bug #827560 reported by Alex Launi on 2011-08-16
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz Main Plugins
Low
Daniel van Vugt
Unity
Fix Released
Low
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Low
Sam Spilsbury
Oneiric
Low
Sam Spilsbury
unity (Ubuntu)
Low
Sam Spilsbury
Oneiric
Undecided
Unassigned

Bug Description

when i drag a window that can't be maximized to the side (such as gcalctool) or top, I see the orange glowing box telling me it's going to maximize, but when I release, it just moves the window to the top left corner. Should not show preview box.

Alex Launi (alexlauni) on 2011-08-16
Changed in unity:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.8.0
Alex Launi (alexlauni) on 2011-08-16
tags: added: bitesize
Omer Akram (om26er) wrote :

bringing in compiz task from the duplicate bug.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Omer Akram (om26er) on 2011-09-16
tags: added: regression-release
Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: 4.8.0 → 4.18.0
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Jason Smith (jassmith) on 2011-09-29
Changed in unity:
status: Triaged → Fix Committed
Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2011-10-10
Changed in unity (Ubuntu):
status: Fix Released → Invalid

Hello Alex, or anyone else affected,

Accepted compiz-plugins-main into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Ngassam Nkwenga (cyrildz) wrote :

Fixed here, at least not reproductible since I was not aware of this bug

I'm on the proposed Repository

Martin Pitt (pitti) on 2011-10-11
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu4

---------------
compiz-plugins-main (1:0.9.6-0ubuntu4) oneiric-proposed; urgency=low

  * debian/patches/fix-872161.patch:
    - When grabbing a window to demaximize it after dragging it up,
      sometimes the position will not be where you expect it to be
      (LP: #872161)

compiz-plugins-main (1:0.9.6-0ubuntu3) oneiric-proposed; urgency=low

  * Cherry-pick upstream fixes:
    - unmaximizable windows still show orange glow but fail to maximize
      (LP: #827560)
    - compiz crashed with SIGSEGV in CompWindow::serverBorderRect()
      (LP: #834585)
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - Windows get corrupted sometimes when semi-maximizing them (LP: #865177)
    - Windows like gnome-terminal have awkward space around them after being
      semi-maximized (LP: #865179)
    - Grid plugin behaviour random (LP: #862260)
    - Don't apply snapping to maximized windows (LP: #862261)
    - snap movements can cause infinite loops in window movements (LP: #860646)
    - it is possible to see a window in it's pre-animation state during unmap
      animations (LP: #864476)
    - Rendering glitches when resuming from expo mode (LP: #868121)
 -- Didier Roche <email address hidden> Wed, 12 Oct 2011 10:49:59 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

This fix is missing upstream still. More info: bug 910698

Changed in compiz-grid-plugin:
status: New → Triaged
importance: Undecided → Low
Changed in compiz-grid-plugin:
status: Triaged → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-grid-plugin:
status: In Progress → Fix Committed
affects: compiz-grid-plugin → compiz-plugins-main
Changed in compiz-plugins-main:
milestone: none → 0.9.7.0
Changed in compiz-plugins-main:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Invalid → Fix Released
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers