Unity update broke screen rotation

Bug #776875 reported by Mark Shaw
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Unassigned
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After the latest Unity update, rotating the screen causes a big black bar to appear which applications can't be seen over. (See screenshot)

Does not occur Ubuntu classic, does not occur on original 11.04.

Happens on my thinkpad X61 Tablet with Intel graphics.

Revision history for this message
Mark Shaw (notmarkshaw) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue could be due to the patch on bug #753971

Revision history for this message
Daniel Manrique (roadmr) wrote :

Mark:

Can you confirm whether the problem occurs when rotating the screen 180 degrees? (upside down). I was able to duplicate this problem but only on left or right rotations.

Revision history for this message
Brian Murray (brian-murray) wrote :

I reported this as bug 733594 and as far as I know the big black bar always appeared throughout Natty's development process.

Revision history for this message
Mark Shaw (notmarkshaw) wrote :

Daniel: Yup, exactly like you say, the problem only occurs on left or right rotations but not upside-down (180 degree) rotations.

The reason I put that it's a regression is because this does not occur on a 11.04 live CD or new install.

Revision history for this message
Mark Shaw (notmarkshaw) wrote :

Also downgrading to the previous version fixes it in the sense that now if a black bar appears it goes away when dragging applications near it:
sudo apt-get install unity=3.8.10-0ubuntu2 unity-common=3.8.10-0ubuntu2

Revision history for this message
Nikolay Kukushkin (n-kukushkin) wrote :

This problem also occurs in unity 3.8.12 (not in classic mode) when connecting an external monitor in full resolution, in single or dual monitor mode (does not affect mirrored screens). In either case, the only visible area corresponds to the size of the original laptop screen (see attachment). Downgrading to unity 3.8.10 also solves the problem (the black area is still there, but disappears on mouse click).

Revision history for this message
Rodrick Yu (rodrickyu) wrote :

I've had this problem occur after an update like everyone else. In the black bar area, unity things like the side bar and the top menu bar can draw in the area but nothing else can.

The downgrade as noted by Mark fixed it in the same way for me as well.

Revision history for this message
Rodrick Yu (rodrickyu) wrote :

Downgrading to 3.8.10 reintroduced a bug where Xournal's xinput based pen input is offset by some weird amount, so I've reverted back to 3.8.12. As a different workaround for this bug I rotate the screen, logout, then log back in for left or right rotations. This results in a black bar on the right side on normal and upside-down rotations, which I once again fix by logging out and logging back in.

Steve Magoun (smagoun)
Changed in oem-priority:
status: New → Confirmed
Steve Magoun (smagoun)
Changed in oem-priority:
importance: Undecided → Medium
Revision history for this message
Victor Tuson Palau (vtuson) wrote :
Revision history for this message
Rodrick Yu (rodrickyu) wrote :

@Victor

That bug was mentioned in comment #2. I agree with Sebastien that the bug might be a result of the patch for that bug. More specifically, it might be due to the patch for bug #795454 that bug #753971 refers to.

Revision history for this message
Mark Shaw (notmarkshaw) wrote :

This seems to be completely fixed in Unity 3.8.16 (natty-proposed). :-)

Changed in oem-priority:
status: Confirmed → Fix Released
Mark Shaw (notmarkshaw)
Changed in unity:
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers