Display garbled when connecting external displays

Bug #753971 reported by Daniel Manrique on 2011-04-07
420
This bug affects 78 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Jay Taoko
unity (Ubuntu)
High
Canonical Desktop Experience Team
Natty
Critical
Canonical Desktop Experience Team

Bug Description

This bug tracks different issues impacting systems on the target certification list when running the Unity shell environment in Ubuntu 11.04

The complete list of problems covers:
1. resolution or orientation change in a single monitor setup (Bug #795454)
2. plugging or unplugging an external monitor (Bug #795458)
3. panel disappearing (Bug #795459)

The different issues can occur depending on the GPU brand and driver version used, among the list of recommended configurations:
* for Intel cards, the default opensource driver shipped in Ubuntu
* for Nvidia cards, the default closed-source driver shipped in Ubuntu
* for ATI cards supported by the fglrx driver, the fglrx driver shipped in Ubuntu 11.04
* for ATI cards not supported by the fglrx driver, the radeon driver shipped in Ubuntu 11.04

The original issue with resolution changes has been fixed the 27th of April - https://bugs.launchpad.net/ubuntu/+source/unity/+bug/753971/comments/19

The affected systems include:

Sony VGN-Z540
Dell Inspiron 1545
Dell Vostro 3300
Dell Vostro 3500
Dell Vostro 3700 (2 affected systems)
Dell Latitude 2110
Dell Latitude 13
Dell Vostro 3400
Dell Vostro V13 (2 affected systems)
Toshiba Tecra R700
HP ProBook 6550b
Toshiba Tecra R850 (Intel)
Toshiba Tecra R850 (ATI)
Acer Aspire One
Dell Mini 10
Lenovo Thinkpad x220
Lenovo Thinkpad T420s

Daniel Manrique (roadmr) wrote :
Daniel Manrique (roadmr) wrote :

Affected systems include:

Sony VGN-Z540
Dell Inspiron 1545
Dell Vostro 3300
Dell Vostro 3500
Dell Vostro 3700 (2 affected systems)
Dell Latitude 2110
Dell Latitude 13
Dell Vostro 3400
Dell Vostro V13 (2 affected systems)
Toshiba Tecra R700
HP ProBook 6550b
Toshiba Tecra R850 (Intel)
Toshiba Tecra R850 (ATI)
Acer Aspire One
Dell Mini 10

If needed, I can upload configuration data and debugging output from these systems too. Don't hesitate to let me know, these systems are used primarily for testing so we're available to provide any needed information.

bugbot (bugbot) on 2011-04-08
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Daniel Manrique (roadmr) on 2011-04-08
tags: added: blocks-hwcert
Daniel Manrique (roadmr) on 2011-04-11
tags: added: regression
Ara Pulido (ara) wrote :

This is affecting quite a lot of systems in our labs. Can you guys have a look to it?

Changed in xorg-server (Ubuntu):
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I was able to recreate this using the steps provided, however only when running Unity. When I was running the Classic Desktop there was no corruption. You indicated that this only happened on systems. Are they all running unity like the one this bug was reported from?

Changed in xorg-server (Ubuntu Natty):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Thanks, here's diagnostics that would be helpful:

a. For all systems (both working and non-working) please tabulate the following:

  * Does it exhibit the issue, or no
  * What is the PCI ID of the graphics card. I.e.: output of ` lspci -vvnn | grep 'VGA ' `
  * What video driver is in use. (Look in /var/log/Xorg.0.log, it'll be like "...(II) RADEON(0)...", etc.

b. On one of the affected systems, test whether the issue can be reproduced in Classic Desktop (no effects). Like Brian indicated, compiz has its own logic for supporting multihead and resolution/rotation changes, and can exhibit bugs particular to it that don't affect X in general outside compiz.

c. On one of the affected systems, do the same test but instead of using the gnome-display-properties applet, use the xrandr command line tool. See man xrandr for some examples of how this tool is used. If the issue can be reproduced using xrandr it rules out the possibility of the bug being in gnome-display-properties.

d. Please tell me when you first started noticing this behavior. Had you been running this same test previously without this failure, or have the systems been doing this as long as you've been running the test? Knowing this can help in pinpointing when the regression was introduced.

Fwiw, I tested on my own dell mini 10v (both with and without Unity; last updated last week) but did not reproduce the bug.

Brian Murray (brian-murray) wrote :

Bryce - I suspect this is the same bug as 733594.

Daniel Manrique (roadmr) wrote :

Hi Brian and Bryce, thanks so much for looking at this problem.

Here's what I found (using Bryce's letters):

c. The problem still appears if I use xrandr to switch to another resolution (say 1024x768) and then back to the default (1366x768). So apparently no problem with gnome-display-properties.

b. (and as per Brian's suggestion) If I use any of the Ubuntu classic sessions (either effects or no effects), the problem does NOT appear, so this would appear to affect only systems running Unity.

d. We only noticed it when we tested beta1, where we ran the full suite of manual tests with visual confirmation. The only thing I can say for sure is that it didn't happen on Maverick :)

a. I did these verifications on the Dell 1545 where the original bug report was generated. It uses the radeon driver and has this card:
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series] [1002:9552] (prog-if 00 [VGA controller])

I also tested on the HP ProBook 6550b, with the intel driver (Arrandale chipset), lspci says:
VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])

I'll get working on the table for point "a" and post it back as soon as I have it.

Thanks for your help!

Daniel Manrique (roadmr) wrote :

Bryce, I completed the table with the systems we tested, I'm indicating whether it's affected by the problem or not, I'm also noting the model number, the driver as obtained from Xorg.log, and the VGA card as identified by lspci. It's in HTML because it was too unwieldy to be handled in text-only format.

http://people.canonical.com/~roadmr/garbled.html

I had some trouble reinstalling some of the systems to verify, so some are marked as "could not connect". They are the minority though.

I noticed one thing, all the systems that are marked as "not" affected in the sheet, are the ones that couldn't run Unity (they show a dialog asking to go into classical mode).

Let me know if you need anything else, thanks for your help!

On Wed, Apr 13, 2011 at 09:40:30PM -0000, Daniel Manrique wrote:
> Bryce, I completed the table with the systems we tested, I'm indicating
> whether it's affected by the problem or not, I'm also noting the model
> number, the driver as obtained from Xorg.log, and the VGA card as
> identified by lspci. It's in HTML because it was too unwieldy to be
> handled in text-only format.
>
> http://people.canonical.com/~roadmr/garbled.html
>
> I had some trouble reinstalling some of the systems to verify, so some
> are marked as "could not connect". They are the minority though.
>
> I noticed one thing, all the systems that are marked as "not" affected
> in the sheet, are the ones that couldn't run Unity (they show a dialog
> asking to go into classical mode).
>
> Let me know if you need anything else, thanks for your help!

Thanks, this is a great list!

If it were an X bug, I would expect to see the yes/no to fall along
chipset family lines, and certainly be specific to just one video
driver.

Given that the correlation crosses both chip families as well as
drivers, and as you point out is reproducing only on systems that run
unity, and not on ones that don't, it is suggesting perhaps this is not
an X bug but rather compiz/unity.

Compiz has its own internal logic for handling XRANDR events such as
multi-monitor and rotation, which we've seen bugged previously; this
could be another instance of such a bug. I will forward this to the
unity team. Thanks again for all your excellent testing work!

affects: xorg-server (Ubuntu Natty) → unity (Ubuntu Natty)

And like Brian points out, it could be a dupe of or related to bug 733594.

Didier Roche (didrocks) on 2011-04-14
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu Natty):
assignee: Canonical Platform QA Team (canonical-platform-qa) → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-11.04
Sebastien Bacher (seb128) wrote :

is that still an issue in the current version?

Kate, that bug affects one user and has no duplicate, is there any reason it should be a natty blocker? there are quite some other issues still on the dx list

Daniel Manrique (roadmr) wrote :

@Sebastien:

I just re-tested this with the daily image from 2011-04-18 and the issue is still present.

Also, comment #3 has a list of affected systems, there are quite a few, and these are in Canonical's Hardware Certification lab, so it's highly likely that the problem is present in the field.

Thanks for looking into this!

Sebastien Bacher (seb128) wrote :

ok, sorry I just received the comment by email once dx with assigned to the bug and didn't read the backlog, I can't confirm there using an external monitor on a latitude system with an intel card, are those config all using similar graphical chipsets?

Didier Roche (didrocks) on 2011-04-18
Changed in unity:
importance: Undecided → High
milestone: none → 3.8.12
Daniel Manrique (roadmr) wrote :

Hi,

The reasons for marking this as a certification blocker are three-fold:

1- This is a blocker for laptops and netbooks where plugging it to an external display is a common use case.
2- Although the workaround is simple, it's also not very obvious, and it's bound to leave users quite confused as to what to do / dissatisfied with the quality of the OS.
3- Per Certification policy, bugs that affect systems for which enablement work has been done (as is the case here) are marked as blocks-hwcert. Also, regressions (also the case) are marked as such. So systems here are of the highest priority to get this problem looked at, from the Hardware Certification point of view.

@Sebastien: Affected systems are using Intel, NVidia and ATI/AMD chipsets. See comment #9 for a link to a table with some specs and comments on affected systems. So far all affected systems are running Unity; those that start a Classic session don't seem to be affected.

Daniel Manrique (roadmr) wrote :

We have located a desktop system that's affected by this problem, with an ATI Radeon card. This system is set up in one of Canonical's hardware testing labs, and so is available for testing, and it can be accessed via a networked KVM so testers can have an actual, live view of the system's display. This could be useful for someone knowledgeable to reproduce and diagnose the problem on a live system.

If you think this could be of use, please contact me so I can coordinate giving you access to this system.

Thanks!

Neil J. Patel (njpatel) on 2011-04-21
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
David Barth (dbarth) wrote :

We have assigned an engineer to look at a solution for the problem.

This bug didn't have a critical status attached to it, which means that I haven't considered that a release blocker so far.

I understand that the problem has since then been re-confirmed as being a high priority bug, but not a release blocker by the release team. And an SRU priority.

Thanks for providing the particular hardware where we can expect to reproduce the problem.

Jay Taoko (jaytaoko) wrote :

Unity relies on Compiz to handle resolution changes and as you may have noticed, Unity resizes itself correctly. As for the scrambled display, there need to be tighter synchronization between the driver, X and Compiz/Unity to ensure smooth and clean transitions between modes.
We a have a similar issue with the NVidia driver after a Resume (preceded by a Suspend). In this particular case, this is known to be a driver bug.

Pete Graner (pgraner) on 2011-04-25
Changed in unity (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Jay Taoko (jaytaoko) wrote :

A fix has been pushed in Unity rev 1181. This should fix the bug on Intel and ATI GPUs (open source driver). However there are still issues with NVidia GPUs; this is an issue with the NVidia driver that should be addressed separately.

Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Committed

On Tue, Apr 26, 2011 at 10:35:31PM -0000, Jay Taoko wrote:
> A fix has been pushed in Unity rev 1181. This should fix the bug on
> Intel and ATI GPUs (open source driver). However there are still issues
> with NVidia GPUs; this is an issue with the NVidia driver that should be
> addressed separately.

Jay, can you elaborate? Was it a fix or a workaround? I.e. is there
more X work needed?

@Bryce
I should have mentioned that what is fixed is the single monitor version of the problem. I cannot currently test on a multi-monitor setting.

What we have is a fix. We were able to isolate a few synchronization issues between the display, compiz and the rendering that were causing problems. On Intel and ATI (with the open source driver), it does not seems that more work is needed in X. Yet I would like to hear from the certification team to get their update on the matter in order to be certain of that.

As for the issues that are still present with NVidia GPUs, I believe we will have to take them to the driver developers.

Didier Roche (didrocks) on 2011-04-27
Changed in unity:
status: Fix Committed → Fix Released
David Barth (dbarth) wrote :

@Daniel: can you confirm that the bug is fixed, using the test packages soon to be available in: https://launchpad.net/~unity/+archive/ppa

Didier Roche (didrocks) on 2011-04-27
description: updated

Accepted unity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Hi all,

Apologies for the delay testing this.

First, without upgrading, I reproduced the bug by changing resolution to 800x600, waiting 5 seconds, and switching back up to 1366x768. With the OLD version of Unity, the bug still occurs as reported.

Then I used the ppa to upgrade unity and libnux to these versions:

ii libnux-0.9-0 0.9.48-0ubuntu1~ppa1
ii libnux-0.9-common 0.9.48-0ubuntu1~ppa1
ii unity 3.8.12-0ubuntu1~ppa1

I used the same procedure to try and reproduce the bug on four upgraded systems (Dell Inspiron 1545, Toshiba Tecra R700, HP ProBook 6550b and Sony Vaio VGN-Z540).

On all the systems, the desktop and application windows restore correctly when coming to the original 1366x768 resolution. The only issue I could observe was that the top panel/menu bar doesn't restore; it's transparent, I can see a horizontal line delimiting its position but the background is visible where the panel should be.

The panel is very easy to restore; basically moving any window, moving the pointer to where the panel should be, or even pressing certain keys (such as PrtScrn when I tried to get a screenshot) restores the panel.

I'm attaching a picture of the "invisible" panel so you can see what I mean.

Thanks so much to everyone involved for the work you've done on this problem!

Daniel Manrique (roadmr) wrote :

This update is particularly in response to JayTaoko's comment #21 regarding the fact that the fix was not tested on a multi-monitor setup.

The original problem was observed also when plugging in an external display to the laptops. I tested this and here are the results.

I first checked the original bug, by using the old version of Unity (3.8.10). I plug in an external screen, and when the system detects it, we observe the same garbling as originally described. This can be "cleaned up" by dragging windows around or for instance, by maximizing (F11) and then restoring a terminal window.

I then upgraded to the PPA unity (3.8.12-0ubuntu1~ppa1). I plugged in the external display. When the system detects it I see screen corruption that's different from what I originally observed :( And up to a point, it's probably worse than the original problem, as this can't be easily worked around in any way I could find.

Picture "a" shows the main display with a garbled/noisy area at the top. Notice that the top panel and Unity are correctly drawn. However, the garbling/noise completely covers any app windows that are in that region on the screen; it doesn't disappear even when dragging stuff around it.

Picture "b" shows the external display with the same noise all over. The panel is visible at the top (pic is a bit dark, check top right corner). Windows that are launched are not visible because the "noise" covers them.

If I press Super-A to launch the Unity dash, it appears correctly! see picture "c", and also notice the "black" area where the original noise/garbling used to be. However, other than the dash, that area of the screen is still "dead" and doesn't show any application windows or desktop background.

Picture "d" shows the screen incorrectly restored after I dismiss the dash; a portion of it is still visible in the "dead" portion.

During all this, the external display evolves to what's shown in picture "e". Panel still visible at the top, app windows still covered by garbly/dead portion of the screen.

The system shown here is the Inspiron 1545, however, I observed this on all 4 systems I used to validate this configuration, as mentioned on my previous report. The only difference is that the noise "pattern" in the dead area of the screen varies, on some systems it's just a dark area, on others it's a repeating pattern, and on the 1545 what appears to be random noise.

David Barth (dbarth) wrote :

Thanks for the quick feedback Daniel. I guess the next step is for Jay to try to analyze the problem directly at the office, to see what's wrong with the different elements.

Eric Appleman (erappleman) wrote :

This is indeed the bug that was affecting me earlier this week.

I'll see if the update in natty-proposed fixes the issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.12-0ubuntu1

---------------
unity (3.8.12-0ubuntu1) natty-proposed; urgency=low

  * New upstream release.
    - Display garbled upon restoring original resolution or connecting external
      displays (LP: #753971)
    - migrate_favorites.py crashed with NameError in __main__: name 'GError' is
      not defined (LP: #759744)
    - compiz crashed with SIGSEGV in PlacesHomeView::Refresh() (LP: #762120)
    - launcher loses focus (LP: #763883)
  * debian/patches/01_add_scp_to_systray.patch:
    - Whitelist systray to system-config-printer (LP: #771562)
 -- Didier Roche <email address hidden> Wed, 27 Apr 2011 11:04:17 +0200

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Alberto Milone (albertomilone) wrote :

I couldn't reproduce the problem with unity 3.8.10-0ubuntu2 but now I can with 3.8.12-0ubuntu1. When I enable my external display with the following commands, I see a number of artifacts, presumably from chromium , even though chromium is not in use:

xrandr --output DVI-0 --primary
xrandr --output HDMI-0 --right-of DVI-0 --auto
xrandr --output HDMI-0 --set underscan off

If I drag a window to the external screen, the window is not visible and seems to be just a rectangle filled with artifacts.

If I downgrade unity to the previous release everything is fine and I can use the external screen:
sudo apt-get install unity=3.8.10-0ubuntu2 unity-common=3.8.10-0ubuntu2

Alberto Milone (albertomilone) wrote :

This is what I see when I first enable the external output

Alberto Milone (albertomilone) wrote :

A click on the background alters the artifact

Changed in unity (Ubuntu Natty):
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Alberto Milone (albertomilone) wrote :

Further clicks on the background cause the attached change

Alberto Milone (albertomilone) wrote :

Pressing the super key to get the dash to show up on the first screen, causes the right side of the screen to be updated and some of the corruption goes away

Note: this is with the open source radeon driver

Alberto Milone (albertomilone) wrote :

Reverting the following commit solved the problem here:
http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/1181

Sebastien Bacher (seb128) wrote :

bug #776875 might be due to this fix

Brian Murray (brian-murray) wrote :

Using unity version 3.8.12-0ubuntu1 from natty-updates I still experience this bug (blank / black spot in desktop) when rotating my display.

tags: added: verification-failed
removed: verification-needed

I've seen corruption after rotating or resizing the desktop with both fglrx and the radeon driver on all my test systems. The corruption goes away once the affected elements on the screen are redrawn in response to user actions such as opening menus or moving windows. I suspect this is the same underlying problem. Please let me know if you'd like me to file a separate bug report.

franco_bez (franco-bez) wrote :

Confirm the bug here on an Acer Travelmate 6292 (Santa Rosa Platform) with Intel GMA using unity version 3.8.12-0ubuntu1.

Toggle through the Display States with the FN -Key (here FN-F5) really weird things happen.

The Top-Panel is OK, then there is a black area some 50 Pixel high then the Rest of the screen is OK again.
Opening an indicator menu I can only the the lower part of it, as the upper part is "below" the black area.
The only way to get the normal screen back is to log out and log in again.

lspci

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)

LagartoFlojo (lagartoflojo) wrote :

I am affected by this also. I can confirm that reverting to Unity 3.8.10-0ubuntu2 fixes the problem.

PBraga (pls-braga) wrote :

Hello,

I hope this can provide more info to help you.
If I can help in any way - like providing more info from tests - just let me know.

I have a lenovo x201 with intel graphics card.
I use an external display at work.

I had Ubuntu 10.10 and the external display was working in an acceptable way (I had to align the external display with the internal by the upper boundary, or I would have problems).

I did the upgrade for 11.04 this weekend (I had some other issues that I was hopping to be fixed with this upgrade).

With 11.04 the two-display solution seems to just don't work.

***** Unity ****
Package: unity
Version: 3.8.12-0ubuntu1

****** PCI of graphics card ****
plbraga@plbraga-ThinkPad-X201:~$ lspci -vvnn | grep 'VGA '
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
plbraga@plbraga-ThinkPad-X201:~$

****** Driver (/var/log/Xorg.0.log) ****
[ 2218.382] (II) intel(0): EDID vendor "LEN", prod id 16401
[ 2218.382] (II) intel(0): Printing DDC gathered Modelines:
[ 2218.382] (II) intel(0): Modeline "1280x800"x0.0 69.30 1280 1304 1336 1408 800 804 808 820 +hsync +vsync (49.2 kHz)
[ 2218.382] (II) intel(0): Modeline "1280x800"x0.0 57.79 1280 1304 1336 1408 800 804 808 820 +hsync +vsync (41.0 kHz)
[ 2218.739] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled

Didier Roche (didrocks) on 2011-05-09
Changed in unity:
milestone: 3.8.12 → 3.8.14
status: Fix Released → Confirmed
Cudesnik (cudesnik) wrote :

change:
Code:
cvt 1280 1024 60

xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync

xrandr --addmode VGA-0 1280x1024_60.00

xrandr --output VGA-0 --mode 1280x1024_60.00

http://www.imagepost.ru/?v=zdskvaaennronsxqkhhkgpmlatdojx.png

Tony Espy (awe) wrote :

I think this bug is also biting me.

I installed the final 11.04 on my Thinkpad 410s ( Arrandale / Intel(R) Core(TM) i5 M 520 w/UMA graphics ), and my external monitors both at home and in the office worked just fine as extended desktops. Since I bought it, this has been the first Ubuntu laptop I've had that I could just plug the external monitor in, and it just *worked*.

I updated the system the following Monday after the final release, and my external monitor support broke. I get a visible top panel on my external monitor, and a blank desktop. If I drag a window from my builtin LCD to the external monitor, it's not visible. I tried fooling around with the Monitors settings application to no avail ( and sometimes Compiz crashes ).

I tried backing down the xserver-xorg-video-intel package from 2:2.14.0-4ubuntu7.1 to 2:2.14.0-4ubuntu7,
and it made no difference.

When I backed down from Unity 3.8.12-0ubuntu1 to 3.8.10-0ubuntu2, my external monitor started working again.

Please let me know if there's any additional information I can provide.

David Barth (dbarth) wrote :

Hmm, the window is /invisible/ when you drag it onto the external monitor, but can you "see" it's there by typing something or popping up a context menu for example, ie something that would reveal the window is positioned properly, but just not visible or at the right order in the stack?

Aaron Peromsik (aperomsik) wrote :

@Tony Espy, thanks for posting that workaround, downgrading worked for me too on my Dell 1545.

Tony Espy (awe) wrote :

@David

A few updates... I updated back to 3.8.12 and ran a few more tests...

1. If my external monitor is connected before I login, everything seems to work OK. It's only if I plug in the external monitor while already logged in that the problems occur.

2. When I plugin the monitor while logged in, I usually get a black border immediately below the panel on my laptop screen. As mentioned above, the external monitor displays the top panel, and the entire screen below the panel is black ( i.e. no background displayed ). If I drag a window to the external monitor, the cursor responds as it should ( i.e. it's a hand while dragging, changes to a cursor is I position where I think the main body of a terminal window is, changes to a pointer if I move the cursor beyond where I think the window's borders should be ). The menu bar seems to work OK as well. I tried typing in an xterm window and it had no effect ( i.e. the window stayed invisible ). I also tried to launch a properties dialog, and it too is invisible.

David Young (dove-young) wrote :

I am using Ubuntu 11.04 Natty on Lenove Thinkpad T400. The video chip is Intel GM45. I have the same problem when connect to external monitor. And since I need to move between workplace and meeting rooms frequently, it becomes even bad for me.

Screenshot.png
http://www.flickr.com/photos/doveyoungibm/5760572596/in/photostream
You can see that when I connect the cable to a external monitor, then start Monitor Preference, the 'Laptop' lable is already displayed somewhere below the top-left corner.

Screenshot-1.png
http://www.flickr.com/photos/doveyoungibm/5760572728/in/photostream
When I enabled the external display which is a Lenevo Group Limited 20", then the screen on the external monitor will display in black with only a top panel.

Screenshot-2.png
http://www.flickr.com/photos/doveyoungibm/5760029553/in/photostream
Now the only way to have them work is to choose 'Same image in all monitors' .

But anyway, the external monitors as well as barcos in our meeting rooms worked fine with Ubuntu 10.10 Maverick

David Young (dove-young) wrote :

My unity version is 3.8.12

<email address hidden>$ unity --version
unity 3.8.12

LagartoFlojo (lagartoflojo) wrote :

David, for now try downgrading to unity 3.8.10 as described in comment #34.

Jacobus (jacobusreyneke) wrote :

This also affects Lenovo G550 with Intel 4500 graphics chipset.

David Barth (dbarth) on 2011-05-31
Changed in unity:
milestone: 3.8.14 → 3.8.16

I dont know how to report or diagnose, but i think it can be related to this bug: Every time my screen got blanked, almost all times i get garbage on screen. System works well, and even killing everything (Except X) and running unity --replace, i cant get my screen back. If i plug a external monitor to my notebook and reload / kill / unity and open metacity, screens back (Messed up), but i can work again. Ive a image of one of this crash (But the displayed image changes: A brightly white when wakeup from blanking and fades to this image after a time).

UPDATE: I cant get again my screen back if i press CRT/LCD button to cycle again to LCD only and force resolution change. Maybe something with this?

Ara Pulido (ara) on 2011-06-08
description: updated
Victor Tuson Palau (vtuson) wrote :

x220 seems to be also affected by this. I walked Chris Kenyon on how to do the work around and seems to have improve the problem a lot

description: updated
Victor Tuson Palau (vtuson) wrote :

can we bump this bug to critical? with 35 people affected and 17 systems , it seems odd it is not the highest possible priority

Ara Pulido (ara) wrote :

This is the most important bug blocking certification, and it affects a lot of systems.
It would definitely have more me toos (although it already has 36), but not everybody uses external monitors on a daily basis.
But this is critical to fix in Natty, as it will affect a lot of people trying it for the first time when trying to do a presentation.

Changed in unity (Ubuntu Natty):
importance: High → Critical
status: Confirmed → Triaged
David Barth (dbarth) on 2011-06-10
summary: - Display garbled upon restoring original resolution or connecting
- external displays
+ Display garbled when connecting external displays
David Barth (dbarth) on 2011-06-10
description: updated
Ara Pulido (ara) on 2011-06-10
description: updated
Dahaniel (dm-protzkeule) wrote :

On a Lenovo Edge 13" (Intel Version) I have major problems with external displays, which was very embarrasing during a presentation.

When I switch to the external display only, top bar shows up perfectly but the rest of the content is only shown in a window of the size of the prvious resolution (the laptop resolution)

when I use the external display in extended desktop mode, the top bar is shown but the rest of the desktop remains black

when giving the same output to both screen, everything semmed to work fine in the beginning, but in the fullscreen presentation, grafical artefacts appeared where the top bar is located

only thing taht worked so far was to switch to external display only and then restart gdm.

Very annoying and a total showstopper, you can't use natty for professional presentations at all which is very bad I think...

danny-j (endlichdimensional) wrote :

Switched to 11.04 a.k.a. the »NUTTY narwhal« a few days ago. So there is nothing installed except the available updates and pidgin.

And I agree with Dahaniel: this bug is a total showstopper
it renders natty useless for use with mobile hardware.

My hardware is a SamsungN130/intelGMA945/2GBRAM -- like nearly all common netbooks out there in the wild.
Display is garbled when changing resolutions and when connecting anything via VGA.

Since not all of my friends have a launchpad account: this bug affects at least +7 more people.

Daniel Manrique (roadmr) wrote :

I tested Unity 3.8.16 from proposed on all the originally-reported systems. A detailed list of those systems with hardware and driver info is here:

http://people.canonical.com/~roadmr/garbled.html

The results of my testing are here:

https://spreadsheets.google.com/spreadsheet/ccc?key=0AlmtiYJQtHMOdEpWV2otQXQzTHRkajIwRGtCX19maGc&hl=en_US&authkey=CLXGhNkP

I did 5 test cases on each system:

- Resolution change and restore to original
- Rotation to right and restore to original
- Plugin an external display, verify that both displays are OK without corruption
- Rotate built-in display with external connected
- Rotate external display

Save for a couple of systems with some artifacting when rotating the internal display with an external connected (sounds like an unlikely use case), and a few others with different and unrelated bugs, most everything is working correctly now:

- Panel and desktop rebuild correctly in every case.
- External monitor works correctly.

I'll document and file the additional bugs separately, but it looks to me like the most critical issues reported in this bug and the three sub-bugs listed in the description are taken care of in Unity. Importantly, resolution changes, rotation and external monitors are now usable and work as any end-user would expect.

Please let me know if any more testing or information is needed.

Thanks!

Aaron Peromsik (aperomsik) wrote :

Might be useful to throw in some hibernate/resume test cases. I installed 3.8.16 on my Inspiron 1545. Based on my impressions so far I am afraid I will probably be bumping back down to 3.8.10 in the near future.

I have from time to time had the screen remain completely black on resume. I can switch to a virtual terminal, log in, and run "sudo service restart gdm" and then I get noise as if gdm is restarting but the screen remains black. That behavior was occasional with 3.8.10 and may have something to do with resuming with the external monitor in a different plugged/unplugged state from when the system entered hibernation. However on 3.8.16 I could see the screen blanking out the same why while hibernation was starting... and it resumed to that unhappy state. So far it's just one data point but I am not encouraged.

That said, the plug/unplug behavior does seem somewhat better with 3.8.16.

Aaron Peromsik (aperomsik) wrote :

A dozen brief hibernate/resume exercises later, I have the distinct impression that the only problematic case is hibernating with the external display connected and then trying to resume without it. Perhaps that is specific enough to want its own bug report?

Aaron: I think you are correct - A new bug would be a good idea.

Ben Romer (bromer) wrote :

Updated today and this seems to have *partially* fixed my screen corruption problem. Now I can enable and disable the external monitor successfully, but if I disable the laptop panel with the external monitor enabled, they both go black and recovering requires killing X.

I like to play games in full screen on my external monitor and there is no other way to direct some of them to the second screen other than disabling the laptop panel.

This is on my Vaio EB11FX, using the HDMI display, by the way.

Same behavior as described in #66.

Besides I could not set primary display via the Monitor Preferences. I tried to order the monitors in every way but unity dock is staying on the the laptop lcd.
In some configuration the external monitor is having corrupted screen - color is invalid or monitor show a message resolution is not supported but the resolution and refresh rate are set properly

And even if my laptop lcd - LVDS1 - is closed - during startup or closing later - X is always starting on the internal lcd. I see that xrandr can see LVSD1 as connected even if the display is closed.

With xrand commands the config can be correct.
I can execute the following in my case and then everything is fine:
#########################################################
#!/bin/bash

off=$(xrandr|grep "\ connected"|grep LVDS1|head -1|awk '{print $1}')
output=$(xrandr|grep "\ connected"|grep -v LVDS1|head -1|awk '{print $1}')
if [ -n "$output" ]
then
 xrandr --output $output --primary
 if [ -n "$off" ]
 then
  xrandr --output $off --off
 fi
fi
#########################################################

SW:
ii unity 3.8.16-0ubuntu1~natty1 Interface designed for efficiency of space and interaction.
HW:
HP ProBook 6450p
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
model name : Intel(R) Core(TM) i3 CPU M 380 @ 2.53GHz

Avery (docaltmed) wrote :

You can add Asus EeePC 1001 to the list. Plugging in an external monitor creates either (a) a secondary monitor displaying only a top panel, (b) a secondary monitor displaying nothing with blocks of black on the primary (netbook) screen. Changing resolution makes no difference. Having the external monitor plugged in at login makes no difference. Acheiving result (a) or result (b) appears to be independent of operator behavior, i.e., it is random.

I'll second Ben Romer's observation. It seems to have gotten better, but it's a long way from smooth functioning.

I hope I won't come across as unhelpful (by not providing specific details), but a testing routine should be pretty simple:

* Plug & unplug the external monitor & make sure everything still works

* Suspend & then wake up with the external monitor plugged in & make sure everything still works

* Restart the Ubuntu system with the external monitor plugged in & make sure everything still works

* Suspend & then wake up with the laptop lid closed & the external monitor plugged in & make sure everything still works

* Restart the Ubuntu system with the external monitor plugged in & the lid laptop closed & make sure everything still works

* In the above points, try opening the lid when the system is running (if it was closed)

Currently, all of the above points will cause major problems, sometimes to the point of requiring a reboot.

Rogan Creswick (creswick) wrote :

Adding to Andreic's comment:

 * Vertical orientations often seem overlooked, specifically, the unity top bar is drawn over top of full-screen windows on the lower display. (This hides all the tabs in chrome, for example.)

 * Windows show up in wildly unpredictable locations when adding/removing monitors. (often spanning across screens, or completely inaccessible.)

I update to 11.04 from 10.10 on 2 Dell laptop, Inspiron and Vostro. Everything work fines but after closing and restarting the computers 2-3 time, I can't boot, the system give me a message that my graphic card is not reconize and I have to install manually which is impossible from console or recovery. I had to come back to 10.10. I did the update on both computer twice with the same result everytime.

David Barth (dbarth) wrote :

Based on #62, I will mark this bug closed. The certification issue is resolved and the rest of the issues will be tracked in separate bugs, mostly driver related problems that are outside of the Unity scope.

For reporters of other problems, or people suggesting adding suspend/hibernate cycles in the test case, I recommend tracking these long term reliability issues separately as well. Not all of that is Unity specific and it's becoming increasingly difficult to track the various threads in this report. Besides, I want a clear signal in this bug that DX and Jay solved the original problem for good.

Thanks

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Released
Rogan Creswick (creswick) wrote :

So, has this fix been deployed?

I updated after David Barth's comment and still frequently have display issues when docking my X201. Screenshot attached - generally after docking I experience the strange garbled top-half of my screen on both heads untill I manage to run the display manager, at which point either: (a) things just start working as expected (b) compiz/gnome-power-manage/some-other-critical-thing crashes or (c) the screen goes mostly black with a ~1px border of flashing bright colorful pixels on the left/top edges and the computer becomes unusable and I have to hard-restart.

I still have major issues with this myself. They closed the ticket, but where are all those tickets tracking the "remaining" issues? Or do they hope we'll open new tickets again in a constant battle with them? I don't want to appear negative or anything, but I'm just disappointed. What should I state in those new tickets when the problem is as simple as "plug in monitor" -> "crash & burn"? I suspect they lack resources and would want to get rid of the bugs asap just so they can add NEW functionality. Perhaps someone should forward this to the people in charge and tell them they're not improving usability at all by creating ambitious projects like Unity while the rest of the code base is deteriorating.

Download full text (3.8 KiB)

We're getting mixed signals from users. Some users are running custom
code, some aren't, there are many different hardware combinations and
combinations of compiz and unity packages at play here, some people
are saying that they get this issue, some aren't.

What David is trying to say here is that people reporting the same bug
and over and over is confusing internally and messing up our
priorities. DX is accountable to a huge number of groups and we need
to have a straight story here. This is especially the case with this
one, where we're tracking what seems to be a number of larger issues
manifesting with the same symptoms - it becomes very difficult to
track what's helping and what's not on one single bug report where
some people are saying "fixed" and others are saying "not fixed". This
has run on effects, such as fixes that might be helping one of the
core problems that is manifesting as this issue being reverted because
we think that it isn't working because some people are saying that it
isn't fixed because there are still unrelated underlying issues
manifesting in the same symptoms.

On Fri, Jul 22, 2011 at 7:53 AM, andreic <email address hidden> wrote:
> I still have major issues with this myself. They closed the ticket, but
> where are all those tickets tracking the "remaining" issues? Or do they
> hope we'll open new tickets again in a constant battle with them? I
> don't want to appear negative or anything, but I'm just disappointed.
> What should I state in those new tickets when the problem is as simple
> as "plug in monitor" -> "crash & burn"? I suspect they lack resources
> and would want to get rid of the bugs asap just so they can add NEW
> functionality. Perhaps someone should forward this to the people in
> charge and tell them they're not improving usability at all by creating
> ambitious projects like Unity while the rest of the code base is
> deteriorating.
>
> --
> You received this bug notification because you are a member of Canonical
> Desktop Experience Team, which is a bug assignee.
> https://bugs.launchpad.net/bugs/753971
>
> Title:
>  Display garbled when connecting external displays
>
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
> Status in “unity” source package in Natty:
>  Fix Released
>
> Bug description:
>  This bug tracks different issues impacting systems on the target
>  certification list when running the Unity shell environment in Ubuntu
>  11.04
>
>  The complete list of problems covers:
>  1. resolution or orientation change in a single monitor setup (Bug #795454)
>  2. plugging or unplugging an external monitor (Bug #795458)
>  3. panel disappearing (Bug #795459)
>
>  The different issues can occur depending on the GPU brand and driver version used, among the list of recommended configurations:
>  * for Intel cards, the default opensource driver shipped in Ubuntu
>  * for Nvidia cards, the default closed-source driver shipped in Ubuntu
>  * for ATI cards supported by the fglrx driver, the fglrx driver shipped in Ubuntu 11.04
>  * for ATI cards not supported by the fglrx driver, the radeon driver shipped in Ubuntu 11.04
>
>  The original issue with r...

Read more...

Rogan Creswick (creswick) wrote :

Sam, that's all well and good (and an inherent part of software development...), however; If you folks feel the need to close the bug for internal bookkeeping / organization / spring cleaning / warm fuzzies / whatever-you-want, then it would be damned spiffy if you could also take a moment to spin off some other bugs for the similar issues that are reported here that have not been fixed.

It's sure not clear to me that the issues I'm having are unrelated to the screen corruption problems that have been reported as fixed, so if I go create a bug it's likely to be closed as a duplicate of this one, since I don't know how my problems are different.

Daniel Manrique (roadmr) wrote :

Hi Rogan,

I understand your frustration with the bug process and am sorry that it seems arbitrary and possibly unfair to you. However I'd like to ask for your understanding too, in that the Ubuntu project has limited resources, and the process is in place to make sure those resources are used as efficiently as possible. Thus rather than trying to keep track of all the people still having display related problems that *sound* similar to this one in this report, which is cumbersome, it would really help if, once verified that this fix doesn't help your (and others') particular problem, you could file a separate report, this enables bug triagers to work more efficiently (keep in mind most triagers are volunteers), and developers to better target and try to solve bugs that are more focused.

This is also the reason why we ask that you, the users, file the bug reports, instead of having a developer or triager trying to spin off all the remaining bugs, which would require creating them, subscribing each affected person, and then asking them to provide information via the apport tool. If you'd be kind enough to create the report yourself running apport (something the triager will ask for anyway), you'd be helping streamline the process, and it would be a great help to the project as a whole.

From reading your description, your issues sound more driver or kernel-related than Unity-related (which is what this bug was about). Thus, it would really be more helpful if you would create a new report, which will contain hardware-specific information (that's one thing about *this* bug: it was NOT hardware-specific, I tested it on a lot of systems from different makes and models, that's why it was filed with such a broad list of machines, and eventually fixed exclusively in Unity).

When you do that, I suggest you mention, in your report's description, that you've followed progress on this bug (give the number) and the posted solution didn't work for you. Then the triager will be sure to *not* close it as a dupe of this one. I can assure you that triagers *do* read the bug reports and we won't just summarily dismiss it because it sounds somewhat similar to something else.

Thanks for your understanding and please let me know if you have other concerns.

---
Daniel Manrique
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Rogan (and anyone else having this problem):

Just to follow up on what Daniel said, the best thing to do will be to:

1.) Run 'lspci | grep VGA' in the terminal and note it's result
2.) Run 'ubuntu-bug unity' - make sure to tell the bug reporting wizard the problem is graphical
3.) In the summary of the bug put '[<output of lspci | grep VGA>] Display garbled when connecting external display'
4.) In the description make a note of what happens *exactly*. Try and include a screenshot (PrntScn key) if you can - and state that you have all updates (the triager should see this anyway) and that you looked at this bug but it didn't fix your problem.

I can assure you your bug is not going to be rejected or marked as a duplicate if you follow these steps UNLESS someone else with the *exact* same video card has reported a bug with the same description.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Rogan Creswick (creswick) wrote :

Thanks Brendan & Daniel. I've created #814721 per Brendan's suggestion.

Uwe (gandalf.the.grey) wrote :

Thanks Brendan, too. I have createtd #833168.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers