Launcher - launcher should remember unpinned launcher item placement

Reported by Spike Burch on 2011-04-28
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Currently, when one opens an application that is not pinned to the launcher, it is placed at the bottom of the application launcher items, right above the workspace switcher. This presents a problem for those of us who like to organize our launchers by category, yet use applications that do not require pinning (being available through other resources such as the messaging menu, for example)
The desired behavior is that the launcher remember the placement of all items, pinned or not.

Note that If a user moves a launcher icon it is automatically pinned, see bug https://bugs.launchpad.net/ayatana-design/+bug/808587

Desired solution

- If a user explicitly chooses to then unpin a launcher icon they have moved, the placement of the Launcher icon should be remembered the next time it is launched.

Omer Akram (om26er) on 2011-06-15
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Changed in unity:
status: New → Incomplete
tags: added: needs-design
John Lea (johnlea) on 2011-06-15
tags: added: udo
removed: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
status: New → Fix Committed
importance: Undecided → Medium
importance: Medium → High
Neil J. Patel (njpatel) on 2011-06-30
Changed in unity:
importance: Undecided → Wishlist
status: Incomplete → Opinion
Didier Roche (didrocks) on 2011-07-05
Changed in unity (Ubuntu):
status: Incomplete → Opinion
Omer Akram (om26er) on 2011-09-21
Changed in unity:
importance: Wishlist → Medium
Changed in unity (Ubuntu):
importance: Wishlist → Medium
Changed in unity:
status: Opinion → Triaged
Changed in unity (Ubuntu):
status: Opinion → Triaged
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
manny (estelar57) wrote :

very useful.

i have movie player (totem) and other apps pinned to the launcher just so it remembers its position when opened.

but my launcher is cluttered because of this.

This fix will greatly help, thanks.

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Christian Giordano (nuthinking) wrote :

Wouldn't it be difficult to preserve a useful and predictable order with icons coming and going?

Yes. I think the better description is that Unity should pin the
location of launchers that get moved.

Mark

@sabdfl; yes, we also have bug https://bugs.launchpad.net/ayatana-design/+bug/808587 open, so that if a Launcher icon is moved it is automatically pinned, however if a user explicitly chooses to then unpin the launcher icon, it's placement is still remembered the next time it is launched.

description: updated
Christian Giordano (nuthinking) wrote :

@john, personally I don't think unpinned positions should be remembered. Transient applications should be grouped at the bottom.

Transient applications should not be grouped at the bottom when the user specifically moves the launcher somewhere else.

John Lea (johnlea) on 2011-12-05
summary: - unity launcher should remember unpinned launcher item placement
+ Launcher - launcher should remember unpinned launcher item placement
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-09
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
John Lea (johnlea) on 2013-02-07
description: updated
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints