Launcher - Unity should automatically select Keep In Launcher for icons that are sorted

Reported by kyleabaker on 2011-07-11
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

Bug:
After opening an application, sorting it in the launcher and then closing the application the icon disappears.

Solution:
After opening an application, it should be understood that sorting it means you want to keep it in the launcher. This option should be automatically checked after drag/dropping an icon that isn't already sent to stay. Note that if a user then chooses the option to un-pin the app icon from the Launcher, it position should still be remembered next time the app is started, see bug https://bugs.launchpad.net/ayatana-design/+bug/772517

Why this solution is better:
Typically, when a user sorts an icon it shows intent to keep the icon displayed among the others. This would also save the user one manual step of clicking "Keep in launcher" when they expect that to be the behavior of sorting.

Related branches

lp:~3v1n0/unity/stick-launcher-icon-on-drag
Merged into lp:unity at revision 2822
Nick Dedekind: Approve on 2012-10-10
jenkins: Pending (continuous-integration) requested 2012-10-10
Changed in unity (Ubuntu):
status: New → Confirmed
Eylem (eylemkoca) wrote :

Completely agree. Sorting the icon, especially if the icon is placed among the "resident" Launcher icons, indicates intent to keep it.

Omer Akram (om26er) wrote :

IIRC this was indeed the case at one stage of Unity development. maybe 10.10

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Omer Akram (om26er) wrote :

kyleabaker, when reporting a bug it is really helpful to state a problem and proposing the solution and how it will be a better choice than the current behavior.

kyleabaker (kyleabaker) on 2011-10-30
description: updated
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

Yes, I think this is an interesting proposal. We should test whether
users are more surprised if it sticks, or disappears, when they close
the app.

Mark

John Lea (johnlea) on 2011-11-03
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
description: updated

With fixing this bug I believe it now enables us to bring back the upper accordion mode as well. Since launchers won't have the fixed position always which break the original argument to remove the upper accordion of the launcher.

Tim Penhey (thumper) on 2011-12-05
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
importance: Undecided → Low
John Lea (johnlea) on 2012-10-09
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: none → 7.0.0
tags: added: udr
removed: udp
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Redmar (redmar) wrote :

Awesome, I can't wait to see this function in ubuntu. A big thanks to everyone who worked on this feature!

John Lea (johnlea) on 2012-10-16
summary: - Unity should automatically select Keep In Launcher for icons that are
- sorted
+ Launcher - Unity should automatically select Keep In Launcher for icons
+ that are sorted
Didier Roche (didrocks) on 2012-12-11
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers