Menu bar - there should be a very quick and subtle fade out/in effect when a user shifts from one menu to another or closes a menu

Reported by John Lea on 2011-04-20
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Low
Unassigned
unity-2d
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

In the Top Bar there should be a very quick and subtle fade out/in effect when a user shifts from one menu to another or closes a menu.

If the user closes a menu there should be a very fast fade out effect.
If the user switches from one menu to another there should be very fast simultaneous fade in and fade out effects on each of the menus.

John Lea (johnlea) on 2011-04-20
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udo
Changed in ayatana-design:
importance: Undecided → Low
status: New → Fix Committed
Alex Launi (alexlauni) on 2011-05-05
Changed in unity:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → ux-backlog-2
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-06-06
Changed in unity:
milestone: ux-backlog-2 → backlog
assignee: Neil J. Patel (njpatel) → Unity Community Hackers (unity-community-hackers)
Jorge O. Castro (jorge) on 2011-06-06
tags: added: backlog
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Low
Didier Roche (didrocks) on 2011-07-20
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Someone please explain better how this bug describes something different to the current behaviour already in unity.

I suspect you mean that we want to NOT expose menus when scrubbing quickly, and only want to show the menu under the mouse when it stops? I accidentally created a fix for that recently, but discarded it because it changed the visible behaviour of unity too much. I thought no one would want it :)

Omer Akram (om26er) wrote :

I think there is a little fade already for Unity atleast

Changed in unity-2d (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Andrea Azzarone (andyrock) wrote :

Maybe we can use compiz animation plugin to fix this bug...

@John Can you provide the duration of the fade in/out effect?

John Lea (johnlea) wrote :

@andyrock; no more than 100ms Perhaps less; experiment and see how it feels.

Andrea Azzarone (andyrock) wrote :

@John

Using compiz animation plugin you can set the timeout fade id/out effect :)

John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2012-07-22
Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → nobody
John Lea (johnlea) on 2012-10-15
Changed in unity:
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
no longer affects: unity-2d (Ubuntu)
summary: - Top bar menus - there should be a very quick and subtle fade out/in
- effect when a user shifts from one menu to another or closes a menu
+ Menu bar - there should be a very quick and subtle fade out/in effect
+ when a user shifts from one menu to another or closes a menu
Andrea Azzarone (andyrock) wrote :

There is already a fade animation for menus. Marking as invalid.

Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in unity:
milestone: backlog → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers