Notification of instant messages is not visible enough

Reported by Charline Poirier on 2011-04-18
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Notification needs to attract more attention when a message arrives. In user testing, participants were not able to see that a new message had been sent to them.

----------------------------------------------
Desired solution:

- Messaging indicator (envelop icon in top bar) should pulse when a new message is delivered

tags: added: nattytesting
description: updated
John Lea (johnlea) on 2011-04-18
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udo
Changed in ayatana-design:
importance: Undecided → Medium
status: New → Fix Committed
Matthew Paul Thomas (mpt) wrote :

Four interface elements changed when someone mentioned the test participant's name in XChat Gnome: (1) the Ubuntu button went blue, (2) the XChat Gnome launcher icon got an emblem, (3) the envelope icon went blue, and (4) a notification bubble appeared. I counted 2/6 participants noticing any of these changes. (Though maybe others were sent the notification, and even I didn't see it!:-) Of those two, one of them noticed the launcher item emblem a while after the message arrived, when the launcher next became visible. The other saw and commented on the notification bubble, and then commented on the blue Ubuntu button and envelope. I don't know whether he would have looked for and noticed the other changes without the notification bubble appearing first.

The position and size of the messaging menu makes it most suitable for *non-urgent* notification of, and access to, new messages, with e-mail as the main use case. It has never been intended as the only, or even the primary, notification of urgent messages like those in a chat program. So I don't think it's reasonable to request that it start pulsing to better cater for urgent messages. If it did, people would likely turn it off altogether.

What alternative solutions did you consider, and how did they compare? For example, here are six possible solutions that don't involve the messaging menu at all. Probably there are others:
1. Change the launcher so that an item bounces or spins whenever it gets an emblem, and whenever the emblem changes.
2. Change the launcher so that an item bounces or spins when a window requests attention.
3. Change the Notify OSD bubble appearance, including making the bubbles subtly animated.
4. Make the launcher visible by default, so that emblems are more noticable.
5. Change the color of launcher emblems, to make them more noticable.
6. Add an option to XChat Gnome, on by default, to play a pleasant sound whenever your name is mentioned.

Jason Smith (jassmith) on 2011-05-05
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)
milestone: none → alpha2
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Triaged
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-06-06
Changed in indicator-messages:
assignee: nobody → Unity Community Hackers (unity-community-hackers)
milestone: none → 0.3.12
Changed in unity:
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in indicator-messages:
status: New → Confirmed
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.2.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
summary: - Notification of message is not visible enough. Some testing
- paryticipants did not notice when they received a message.
+ Notification of instant messages is not visible enough
François Tissandier (baloo) wrote :

As my bug was marked as a duplicate of this one, let me just add a remark :

it's not just about making the enveloppe blink. For a non-first message in Empathy, the enveloppe is not even changing ! If you don't have the dash visible, you simply just can't see that you got a message. And even if you see the dash, the indicator for a new message in Empathy is hard to notice.

Furthermore, the enveloppe is changing with every new email. So it would be more coherent to make the enveloppe change also for every message. Otherwise the user will simply not understand what's going on.

Omer Akram (om26er) on 2011-12-13
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in indicator-messages:
importance: Undecided → Medium
Changed in indicator-messages (Ubuntu):
importance: Undecided → Medium
Changed in indicator-messages:
status: Confirmed → Triaged
Changed in indicator-messages (Ubuntu):
status: Confirmed → Triaged
Ted Gould (ted) on 2012-03-05
Changed in indicator-messages:
milestone: 0.3.12 → none
importance: Medium → Wishlist
Changed in indicator-messages (Ubuntu):
importance: Medium → Wishlist
John Lea (johnlea) on 2012-04-20
Changed in indicator-messages:
assignee: Unity Community Hackers (unity-community-hackers) → nobody
description: updated
Matthew Paul Thomas (mpt) wrote :

For the reasons given in my previous comment, I believe this is a bug not in the messaging menu, but primarily in the Launcher. So I'm moving it to Unity.

Of the six suggestions I proposed, #2 and #4 have been implemented so far. That might have been enough to fix the problem by itself. Regardless, I look forward to seeing the other four suggestions implemented too.

affects: indicator-messages → unity
affects: indicator-messages (Ubuntu) → unity (Ubuntu)
John Lea (johnlea) on 2012-09-05
Changed in unity:
importance: Wishlist → Medium
Changed in unity (Ubuntu):
importance: Wishlist → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints