Twinkle systray notification icon rendered outside panel in unity

Reported by komputes on 2011-04-17
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
twinkle (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: twinkle

Twinkle systray notification icon rendered outside panel in unity.

Workaround for enabling systray in unity below should (but does not) work.
---
$ sudo apt-get install dconf-tools

Once the installation is completed, type 'dconf-editor' in either the Alt+F2 launcher, or the Terminal to start the DConf Editor.

In the DConf Editor, go to: desktop --> unity --> panel

Change the systray-whitelist key from the default to ['all']

This will re-enable the Notification Area icons back in the Unity panel. Note that you may need to log out and back in to be sure the change is properly applied.
---
ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: twinkle 1:1.4.2-2build2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sun Apr 17 12:57:31 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: twinkle
UpgradeStatus: Upgraded to natty on 2011-04-17 (0 days ago)

komputes (komputes) wrote :
komputes (komputes) on 2011-04-19
description: updated
komputes (komputes) on 2011-04-23
description: updated
Alex Launi (alexlauni) wrote :

This happens whether or not you whitelist twinkle. This is twinkle doing something wrong, not unity.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in twinkle (Ubuntu):
status: New → Confirmed
Stefan (stefan-satzenhofer) wrote :

For me the white-list 'all' value worked in unity, but didn't in unity 2d. That is because of a bug in the white-list behaviour - https://bugs.launchpad.net/ubuntu/+source/unity-2d/+bug/847525. The whitelist -entry 'ALL' doesn't work in unity 2d.

As I white-listed Twinkle by its own (Desktop - Unity - Panel- systray-whitelist: ['JavaEmbeddedFrame', 'Wine', 'scp-dbus-service', 'Update-notifier', 'Twinkle'] it worked for me.

Jonathan Thomas (echidnaman) wrote :

Twinkle has been removed from the archives since it is unmaintained and depends on Qt3. As such, no further improvements or bugfixes will be made to this software.

Changed in twinkle (Ubuntu):
status: Confirmed → Won't Fix
komputes (komputes) wrote :

Hi Jonathan, I would like to object to the decision to remove twinkle from the archives. Even though it has been 3 years since the last release, I would like to inform you that this is a solid piece of software. It is well written and I use it daily. I would ask for a reconsideration. Could you point me to the reference which states this program is being removed from Ubuntu archives?

Changed in twinkle (Ubuntu):
status: Won't Fix → Confirmed
kapetr (kapetr) wrote :

I fully agree with David.
Twinkle is most powerful SIP client which support all SIP features. Great logs, NAPTR support, ...
I have try almost any SIP client in Linux and Twinkle has no competition.

It has only one disadvantage - id does not support call recording. That is the only one reason, why I must use SFLphone.
Unfortunately :-(

kapetr (kapetr) wrote :

BTW: set com.canonical.Unity.Panel systray-whitelist "..." works in Ubuntu 12.04 64b

kapetr (kapetr) wrote :

... WHY DOES NOT LAUNCHPAD SUPPORT POST EDITING !!!!! >>>>:-c

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'cryptkeeper', 'sflphone-client-gnome', 'twinkle']"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers