[panel] systray whitelist does not support '[all]' value that should allow all applications to show

Bug #847525 reported by Rocko on 2011-09-12
128
This bug affects 27 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Ryan Smith-Roberts
Baltix
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

unity-2d is not displaying any systray icons at all (see attached screenshot - pidgin and skype should be showing).

The value of my com.canonical.Unity.Panel / systray-whitelist key is '[all]', and the normal unity sometimes shows the icons (but not always).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-2d 4.6.1-0ubuntu1
Uname: Linux 3.1.0-rc5-git-20110909.1107 x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Mon Sep 12 11:06:40 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
PackageArchitecture: all
SourcePackage: unity-2d
UpgradeStatus: Upgraded to oneiric on 2011-09-06 (6 days ago)

Related branches

Rocko (rockorequin) wrote :
summary: - unity-2d does not display systray icons (eg skype)
+ [panel] systray whitelist does not support '[all]' value that should
+ allow all applications to show
Changed in unity-2d:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Alexander Gudulin (sagod) wrote :

I tried to run 'volti' - didn't work.

Bill Filler (bfiller) wrote :

I think this bug description should change. I appears that systray whitelist is not honored regardless of the value (i.e. not just 'all' not working). There seems to be no way to get any systray icons to appear. I've added skype and xchat to gconf and it does not work.

I would argue this bug is High/Critical as having no systray support is quite bad.

Bill Filler (bfiller) wrote :

seems I'm wrong. just 'all' is broken. If I add 'Skype' and 'Xchat' these seem to work, but are case sensitive.

Alberto Mardegan (mardy) on 2011-10-07
tags: added: bitesize
Rocko (rockorequin) wrote :

It kind of works if I add Skype to the whitelist, but the icon is only displayed occasionally and I'm not sure what makes it appear and disappear. When it isn't showing in the systray, I can't restore skype back to the front.

The icon often disappears if I move the mouse over the global menu bar, so perhaps drawing the window title is responsible for making it disappear.

Michał Sawicz (saviq) on 2011-10-17
Changed in unity-2d:
assignee: nobody → Ryan Smith-Roberts (rsmithroberts)
status: Confirmed → Fix Committed
Sergio Callegari (callegar) wrote :

Is the fix available in some form (updates, ppa, etc?)

I am compelled to use unity-2d (my laptop supports unity, but I cannot have 20% cpu when idle) and this is a real showstopper for me.

It might be available as a package in precise, but I haven't checked.

I will make a PPA for it as soon as I get home.

On 10/27/2011 09:43 AM, Sergio Callegari wrote:
> Is the fix available in some form (updates, ppa, etc?)
>
> I am compelled to use unity-2d (my laptop supports unity, but I cannot
> have 20% cpu when idle) and this is a real showstopper for me.
>

Gerry Boland (gerboland) wrote :

The fix will be in the PPA of daily builds:
https://launchpad.net/~unity-2d-team/+archive/unity-2d-daily
You can get it there.

Rocko (rockorequin) wrote :

It shouldn't be a showstopper, since it works if you put each application name in. It just doesn't support using the single word 'all'.

Reinis Ivanovs (dabas) wrote :

Of course, disgusting bugs eating up the user's time are not critical, because, after all, there exists some obscure bug report. Try googling for this page and see how long it takes to sift through all the misdirection…

Doug McMahon (mc3man) wrote :

The problem with this 'fix' is it works best when the unity systray-whitelist is set to 'all'. It really should accept specific white-listed apps like unity does & not require the 'all' parameter.
A couple of examples of where specific fails & 'all' works, sure there are others
audacious
wicd

Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers