UIFe: Unity Dash button does not give adequate feedback

Reported by Nathan Moos on 2011-04-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
High
Marco Biscaro
unity-2d
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

I've been using Unity, and one thing that I noticed is that the button to bring up the Dash does not appear "pressed" when the Dash is up. In Maverick's U2D repository, whenever the Dash is open, the button appears "pressed". This makes it obvious how to turn the Dash "off", unlike the experience on Natty right now.

Good catch.

 status confirmed

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Changed in unity-2d:
status: New → Fix Released

What about this? See attached images.

Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Nathan Moos (nathan-moos) wrote :

I say that's exactly what I'd want in Ubuntu, but I think we need Mark's opinion.

Didier Roche (didrocks) wrote :

Yeah, requesting design to have a look :)

Otherwise, very nice work Marco!

Changed in unity:
status: In Progress → Incomplete
Changed in unity (Ubuntu):
status: In Progress → Incomplete
summary: - Unity Dash button does not give adequate feedback
+ UIFe: Unity Dash button does not give adequate feedback

Could someone of design team take a look on this?

Actually, at moment, the big freaking button is not a button: it's a part of panel that, when clicked, opens the dash (maybe we could call it 'bfpoftod' - big freaking part of panel that opens dash - instead of 'bfb' :-P).

The clicked state will turn it more like a button and I think this is important to ship in natty.

Please consider this.

Mark Shuttleworth (sabdfl) wrote :

+1, this is a bug. My apologies for not seeing the correspondence sooner. If it's possible to fix in Natty, I think it's a low-risk change which clarifies the behaviour substantially.

Should be bfb behave then like an indicator (orange background when open)? I am not sure the button is the right metaphor, also because as described here sounds more like a toggle button.

Yes, there are definite problems, I'm just going on the basis that "some
state indication" is better than none.

Otto Greenslade (otto-chaotic) wrote :

I did some work on this over the last few cycles which does seem to have been omitted now. Our previous solution only worked successfully under Ambiance - inverting the panel gradient vertically over the BFB Button to give the illusion of a press and make the surface appear concave. Now that we support theming this won't have any effect other than in Ambiance/Radiance. Could we use Marco's tinting but aim to solve the omission above and combine the two?

Paul Sladen (sladen) wrote :

If this is being solved in code, please bare in mind that the solution for:

  bug #532309 ("Light-themes: gnome-panel background does not scale beyond 24 pixels")

will likely result in the panel-background being expanded vertical with a flat colour before the gradient. Simply turning the input texture up-side-down without taking note of the transformation geometry may not result in the desired concave look. A simply overlay as proposed by Marco in comment #4 shouldn't have a problem with this.

Didier Roche (didrocks) wrote :

@Marco: do you want to have a try on that?

Changed in ayatana-design:
status: New → Fix Committed
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged

Yep! I'll take a look on this.

Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress

Considering Paul's comment, I've done the following change:

For Ambiance or Radiance themes: load the background panel upside-down and draw it.
For other themes: just draw the translucent overlay (RGBA: 100%, 100%, 100%, 30%).

Please see the last attached screenshot.

Paul Sladen (sladen) wrote :

nb. any fix for this needs to take account/be parallel to bug #748676 ("UIFe: Unity Dash button does not give adequate feedback").

@Paul: I think you've commented in the wrong bug report.

Didier Roche (didrocks) on 2011-04-18
Changed in unity:
status: In Progress → Fix Committed
milestone: none → 3.8.10
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
status: In Progress → Fix Committed
Otto Greenslade (otto-chaotic) wrote :

@Marco - Good job, thanks - it looks great :)

@ Paul - I have been discussing this with Cimi, we're using a PNG at the moment but maybe we could be using a vector-based asset that would allow for scaling.

Thanks guys!

Paul Sladen (sladen) wrote :

Otto: I don't think the problem is the asset itself (gradients tend to scale fairly well), but a problem of how to tell the theme engine to scale to match the panel height.

Cimi: do you know if Murrine can (currently) do the scaling, or is the best approach still to just enlarge the pixmap to 128 with a solid fill below pixel 25?

Didier Roche (didrocks) wrote :

Thanks *you* Marco :)
See my comment on the merge request about my additional (small) commit ;)

Andrea Cimitan (cimi) wrote :

murrine has no control over background pixmaps

@Didier: I've saw your little (but that makes a big difference!) change. It really looks better with vertical offset too.

Didier Roche (didrocks) on 2011-04-19
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-10-14
Changed in unity-2d (Ubuntu):
status: New → Fix Released
John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers