Lenses with no shortcut still display black box when pressing super

Reported by Greg A on 2011-03-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
AskUbuntu Lens
Undecided
Unassigned
Unity
Medium
Didier Roche
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Take a look at the screenshot. This was taken whilst pressing the Super button.

The first ten application launchers are labelled 1,2,3,4,5,6,7,8,9,0.
The next two have no "black box" because we run out of numbers (expected behaviour).

We then have the lenses. The Ask Ubuntu one has not specified a shortcut, so just has a black box with no letter in it. Presumably it should either be compulsory to specify a shortcut, or the Unity Launcher should not display the black box if a shortcut is not specified.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,vpswitch,move,animation,imgpng,shift,mousepoll,grid,gnomecompat,place,workarounds,wall,wobbly,expo,ezoom,staticswitcher,session,fade,scale,unityshell]
Date: Sat Mar 26 08:24:07 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-09 (16 days ago)

Greg A (etulfetulf) wrote :
Greg A (etulfetulf) wrote :
tags: added: bitesize
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Didier Roche (didrocks) wrote :

Hey Marco, I fixed it in my branch today without noticing this bug first, sorry about that :/

If you are interested the fix was:
=== modified file 'src/PlaceEntryRemote.cpp'
--- src/PlaceEntryRemote.cpp 2011-03-23 19:35:06 +0000
+++ src/PlaceEntryRemote.cpp 2011-03-28 09:58:28 +0000
@@ -188,7 +188,7 @@
   _icon (NULL),
   _description (NULL),
   _searchhint (_("Search")),
- _shortcut (10), // impossible shortcut
+ _shortcut (0),
   _position (0),
   _mimetypes (NULL),
   _sensitive (true),

Changed in unity:
assignee: Marco Biscaro (marcobiscaro2112) → Didier Roche (didrocks)
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
milestone: none → 3.8.2

Hey Didier, no problem! But I've solved this using a different approach: I thought the value of 10 was there by a reason (but apparently it was not), so I've done a validation on Launcher.cpp, to check if the shortcut value is greater than 32 (and not just different from zero).

I'll propose the merge with my branch anyway since this can solve future problems with this (I'll set you as reviewer).

Didier Roche (didrocks) wrote :

Hey, I've answered on the merge request :)
Not sure if I'm missing the obvious (can totally be possible! ;)) but I didn't get the > 32 (and you removed the != 0 which is wrong).

And right, I'm not sure why I set = 10 at start, let's say I wrongly hit 1 before pressing 0 :)

Yes, I saw. Let me try to explain what I've done:

I removed the != 0 because the condition > 32 includes it.

And, why > 32? ASCII codes: http://bestofthisweb.com/blogs/wp-content/uploads/2009/11/ascii_table2.jpg

Any value less than or equal to 32 is invalid for shortcuts (they're control codes and space). This way, even if a invalid shortcut is set by mistake, the black box won't be rendered. Got it?

Didier Roche (didrocks) wrote :

ok, one day, I'll learn the difference between > and < maybe. Let's say it's due to dailight saving ;)
I was thinking the otherway around! So yeah, your merge make sense.

However, we are checking that in multiple place in the code (at least 2 in Launcher.cpp), can you check that everywhere and propose a branch for that?
Thanks again for the explanation and sorry about me not being enough awake it seems :-)

:D

Ok Didier, I'll take a look on this soon.

Jorge O. Castro (jorge) on 2011-03-30
Changed in askubuntu-lens:
status: New → Invalid
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers