Unity acts not as a dock for LibreOffice but as a launcher

Bug #741995 reported by nicotem on 2011-03-24
148
This bug affects 36 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
LibreOffice
New
Undecided
Unassigned
Unity
Fix Released
Undecided
Unassigned
bamf (Ubuntu)
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, I had a look at the filed bugs but didn't see any duplicate if so I apologise...
Unity interacts with LibreOffice as a launcher with no docking capabilities as with the other programs. What I mean is: I click on LibreOffice icon, the program launches, but when it's loaded it's not docked to its icon. Instead Unity creates a new icon for the processes of ignote nature and docks from there. Have a look at the screenshot I attach: the icon with the question mark is in fact a LibreOffice process.

Related branches

nicotem (nicotem-gmail) wrote :
Mirco Müller (macslow) on 2011-03-25
tags: added: dock launcher libreoffice unity
Gord Allott (gordallott) wrote :

Hi - are you by any chance using the ppa version of libre office? if so you may want to try removing the ppa version and using the distro provided version - there is a known bug with the ppa version not matching properly

Omer Akram (om26er) wrote :

I reproduced this in the live session, the bug might be in Libreoffice.

Changed in unity:
status: New → Confirmed
nicotem (nicotem-gmail) wrote :

Hi, I confirm I am not using ppa versions but the stock

Didier Roche (didrocks) on 2011-03-25
Changed in unity (Ubuntu):
status: New → Confirmed
nicotem (nicotem-gmail) wrote :

May I add some information:

- In case I open a spreadsheet on Calc, the icon is created correctly in the Unity bar.

- In case I open a presentation on Impress, the icon created is not a ignote "question mark" one, as that of the screenshot, but one generic of "LibreOffice 3.3" (that grey one)

- I removed Writer from keeping it in launcher, but the phenomenon is still active even if Writer is not locked in the launcher. The question mark icon pops up.

- The question mark has the label "LibreOffice Small Device Format Importer". This is how Unity reports the processes of Writer to be.

Fsolda (fsolda-gmail) wrote :

A tip for the developers to fix this problem: look at the Docky (for installing it: sudo apt-get install docky); it's a dock application where this problem is not present. It acts as a dock for all apps, including LibreOffice, and ever displays the correct icon for the applications.

Jason Smith (jassmith) wrote :

*goes to look at who wrote the docky code, hmmm that name looks familiar*
*dashes over to see who wrote the matching code for the launcher*

DEAR GOD IT'S A CONSPIRACY!

I'll look into it. LibreOffice is a pain to get right and there are cases Docky get's wrong too. I think we may miss a case here too.

wrt "LibreOffice Small Device Format Importer", that is a different issue:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/732412/comments/7

Fsolda (fsolda-gmail) wrote :

Well... I noted that the bug with the dock in LibreOffice affects only the version in Brazilian Portuguese, because the name used in Brazil is actually "BrOffice". I changed it to European Portuguese and it solved the bug.

Fsolda (fsolda-gmail) wrote :

However, it works only in the same session. When we log out, then log in, clicking in the LibreOffice icon (Writer, Calc, Impress, Draw, Math or Base), if fixed in the dock, will produce a duplicate icon.

What files of libreoffice contains the differences between brazilian portuguese and european portuguese? As the file "/usr/share/applications/libreoffice-calc.desktop"
I tryed to kill the line that contains the name "BrOffice" in file "/usr/share/applications/libreoffice-calc.desktop", but it didn't work. (that line is "Name[pt_BR]=BrOffice Impress")

I found an workaround: sudo apt-get remove libreoffice3-pt-br libreoffice-l10n-pt-br libreoffice-help-pt-br

Damien Lecan (dlecan) wrote :

Same bug for me
Each time I open a file with Nautilus, Unity adds a new grey launcher.

See attached screenshot.

Danillo (danillo) wrote :

I have purged LibreOffice 3.3 (the official Brazilian version from the depositories, "BrOffice") and installed LibreOffice 3.4.1 with the debs from libreoffice.org, but the problem persists. The new version is not called BrOffice anymore, it's LibreOffice as in the rest of the world, so the problem is probably not with its name.

Danillo (danillo) wrote :

I'm also having this problem for empathy when I'm in a video call. See attached png.

Omer Akram (om26er) wrote :

Does anyone face this issue in fully updated Oneiric as well?

Danillo (danillo) wrote :

I still do using today's latest build.

vanadium (ftack) wrote :

This issue is still remaining in fully updated Oneric. I sometimes have the impression that it is related with the time needed to load a document. A short document gets correctly associated with the Libreoffice icon, whereas a document that needs more time to launch gets attached to the white "ghost" icon.

Tried Gnome shell today: it has no problem with libreOffice.

Greg Lynch (gregalynch) wrote :

I think you're right, vanadium. I have the problem, too, but only when opening a couple of files that, since they have some user-defined styles, take longer to load than others do. For all other files it works just fine.

Danillo (danillo) wrote :

I'm not sure about that. In addition to empathy, I have just noticed that this problem also happens for another application. It happened while opening Onboard's preferences. See the attached png showing two Onboard icons in the launcher, one high-res and one low-res.

billjoie (joie-bill) wrote :

Also confirm for fully updated Oneiric.

Danillo (danillo) wrote :

I have found this bug in Ubuntu Software Center too while reviewing an application. This launcher bug is also reflected in the alt+tab switcher. See attached png.

vanadium (ftack) wrote :

This issue concerns useability of Unity with a major office application. I suggest it should receive greater attention, as this issue should certainly not persist in the LTS 12.04 release.

The problem seems aggraviated in 11.10, where sometimes Unity looses track of a Libreoffice document alltogether (i.e., there is even no "ghost" icon anymore representing the application). It is diffucult to reproduce the latter issue, though. Current issue, on the other hand, can be rather easily reproduced by loading a larger LibreOffice document through a double click in nautilus or through the dash.

Eugenio Perea (eugenio-perea) wrote :

I can confirm this bug in a fully updated 11.10. I've spent a few minutes testing it and found the following:

1. Any document created from within LibreOffice gets represented correctly in both Launcher and AL+TAB.

2. Some pre-existing documents do NOT appear in the Launcher or ALT+TAB and do not use the global menu when their window is maximised. This behaviour is the same regardless of how they are opened, from within LO, directly from Nautilus or from an attachment in Thunderbird.

3. It appears that whether or not this happens depends on the provenance and age of the file itself. Not all .docs are created equally. Recent .odt, .ods and .opf files don't present the problem, whereas older files (back to .sxc format, even) and Microsoft files seem to have issues.

mcarpe (matteo-carpentieri) wrote :

I can also confirm everythinh Eugenio Perea just said.

I'm in a fully updated 11.10, with Unity 3D

It is particularly annoying when the icons DO NOT appear in the launcher at all. It is not even possible to re-open the window by using ALT+TAB, so the only two ways of going back to the opened document are:

-1- launching the document again
-2- opening a new libreoffice document, and use the menu->Window->{previously opened document}

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in bamf (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → In Progress
Changed in bamf:
importance: Undecided → Medium
Changed in bamf:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.104-0ubuntu2

---------------
bamf (0.2.104-0ubuntu2) precise; urgency=low

  * Importing trunk revision 424 fixing various LibreOffice related bugs:
    - Unity acts not as a dock for LibreOffice but as a launcher
      (LP: #741995)
    - Libreoffice and unity integration broken (LP: #842566)
    - Libreoffice Calc icon does not appear when opened via Writer
      (LP: #861355)
    - Alt-tab and launcher shows floating toolbars in LibreOffice as
      additional windows (LP: #840000)
 -- Marco Trevisan (Trevino) <email address hidden> Thu, 15 Dec 2011 22:05:02 +0100

Changed in bamf (Ubuntu):
status: In Progress → Fix Released
Greg Lynch (gregalynch) wrote :

This problem seems to have gotten worse for me (Oneiric, fully updated) in the past week. Whereas before it was only intermittent, now nearly every document opened from nautilus (including documents recently created in libreoffice) is incorrect, and most do not appear on the launcher at all (as described in post #25 above). This means that minimizing a document with unsaved changes can cause you to lose your work. Also, in these cases this problem is typically combined with a loss of the maximize/minimize buttons in the top panel (same as bug #750186) Further, now even some documents opened from within Libreoffice produce the extra icon (the one in post #13 above). Perhaps this change for the worse is related to a recent update?

Greg, try to use the fixed version manually installing the fixed packages from precise: http://packages.ubuntu.com/source/precise/bamf as explained at https://bugs.launchpad.net/bamf/+bug/842566/comments/68

The fix for oneiric should be coming as well.

Greg Lynch (gregalynch) wrote :

Marco,
Thanks for the help. I'm not super confident in my comupter abilities so I'd prefer to wait for the Oneric fix to come through update manager if it won't be too long. I saw on the other thread (the main one for this bug) that the fix is committed. Do you have any idea of how long it will be before its released? Is it more like a week or more like two months? If the former I'll probably just wait, but if the latter I'll try to install it myself.

Gord Allott (gordallott) on 2012-01-12
Changed in unity (Ubuntu):
status: Invalid → Fix Committed
Changed in unity:
status: Invalid → Fix Committed
milestone: none → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Simplehuman (simplehuman) wrote :

Unity 5.1.14 , Ubuntu 12.04 x64 - the bug is still there...

vanadium (ftack) wrote :

The bug was gone for a while, but the issue is back now in an even worse stat, if you ask me:
https://bugs.launchpad.net/unity/+bug/1026426

Sebastian Ilea (s3b4) wrote :

Ubuntu 12.04 LTS 64 bit.

Bug still present.

apienk (andrzej-pienkowski) wrote :

I know this is not about the PPA version, but maybe this "workaround" will help to track down the cause. On opening a Writer file from Nautilus, a duplicate but low-res blue Writer icon appears in the dock. Opening a second Writer file produces TWO new icons in the dock: one low-res blue Writer, and one blank white (empty document). I found out that resetting Unity (unity --reset) fixes the dock's behaviour -- I get two arrows next to a single Writer laucher icon. However, if after that I open a third file, the dock still produces a duplicate icon.

Ubuntu 12.04 (64-bit), Unity 5.20, libreoffice 4.1.3~rc2 (PPA)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers