Selection does not fit small icons in Unity Dash

Bug #735746 reported by José Lou Chang on 2011-03-15
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Exaile
Invalid
Undecided
Unassigned
Unity
Fix Released
Medium
Unassigned
gbrainy (Ubuntu)
Low
Unassigned
teeworlds (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

There is a game called "gbrainy" which is installed by default in Ubuntu.
If you try to select it in Application [unity] Dash, the white squares that surrounds the icon to represent selection does not fit to the icon.

The gbrainy's icon is too small and the dash "selection" seems to be placed a little high.

This happens not only with gbrainy, but with any application that does not have a icon with size 48x48px.

I will upload a screenshot.

***
I am running Ubuntu Natty 64-bit with all the current updates (March 15)
My video card is Intel.

Screen Resolution: 1280 x 800 (16:10)

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)

José Lou Chang (obake) wrote :
Robert Ancell (robert-ancell) wrote :

The issue is the icon /usr/share/icons/hicolor/48x48/apps/gbrainy.png is actually a 32x32 icon.

The bug appears to be in data/Makefile.am as it installs data/app-graphics/gbrainy.png into the 48x48 dir. Guessing you need to make gbrainy32.png and gbrainy48.png.

Changed in unity:
status: New → Invalid
Changed in gbrainy (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Robert Ancell (robert-ancell) wrote :

(Note this could be considered a bug in Unity - it appears to be no checking if the icon is actually the correct size, and scaling/offsetting it if it is incorrect).

Changed in unity:
status: Invalid → New
José Lou Chang (obake) wrote :

I have replaced 48x48 with 32x32 version of the gbrainy icon in /usr/share/icons/hicolor/48x48/apps/
However, upon logging out and loggin back in, the icon still displays the 32x32 version.

I checked the /usr/share/icons/hicolor/48x48/apps/ just in case to see if it has been reverted, but it shows that the 64x64 file is present.

How do we tell Dash to update its icons?

José Lou Chang (obake) wrote :

Here I am uploading a 48x48 png file for gbrainy.

Robert Ancell (robert-ancell) wrote :

Hmm, I get the same problem with the icon not being updated.

To update, I reinstalled another GTK app, e.g.:
$ sudo apt-get install --reinstall gcalctool
And that rebuilt the bamf and GTK icon caches. But it doesn't seemed to have worked.

Jordi Mas (jmas-softcatala) wrote :

Hello,

On top of the Unity bug, gbrainy was copying in the 48x48 directory the 32x32 version of the icon. I have fixed this:

http://git.gnome.org/browse/gbrainy/commit/?h=stable&id=f1c9e97389fa7d0606364755069a948a30f72fbe

And this should be part of gbrainy 1.63 to be release by the end of tomorrow.

Thanks,

Jordi,

Note: There is already a 48x48 gbrainy icon at http://git.gnome.org/browse/gbrainy/tree/data/app-graphics

Besides the problem with gbrainy's icon size, it's also a Unity bug (since it does not work with any icon smaller than 48x48). I've noticed the same problem with Virtualbox 4.0 icon.

summary: - Selection does not fit the gbrainy icon in Unity Dash
+ Selection does not fit small icons in Unity Dash
description: updated
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gbrainy - 1.63-0ubuntu1

---------------
gbrainy (1.63-0ubuntu1) natty; urgency=low

  * New upstream release (Fixes LP: #735746)
 -- Robert Ancell <email address hidden> Fri, 18 Mar 2011 12:52:26 +1100

Changed in gbrainy (Ubuntu):
status: Triaged → Fix Released
José Lou Chang (obake) wrote :

Thank you Jordi Mas. gbrainy's icon now shows up with the correct px.

On another related news:
I have encountered another application with the same problem that gbrainy was experiencing. A game called "Teeworlds"

José Lou Chang (obake) on 2011-03-19
tags: added: icons natty small-icons
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
milestone: none → 3.8
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-03-24
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Mathias Brodala (mathbr) on 2011-03-24
Changed in exaile:
status: New → Invalid
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released

The unity's problem still happening with unity 3.8.2-0ubuntu1. See screenshot.

I can't change the bug state to "In progress", but I'm working on it.

Changed in unity:
assignee: Neil J. Patel (njpatel) → Marco Biscaro (marcobiscaro2112)

The problem is not solved. Since I can't change the bug status and a new one was reported (bug #761465), the progress can be checked there.

Changed in unity:
assignee: Marco Biscaro (marcobiscaro2112) → nobody
Changed in teeworlds (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers