Minimize Application's Windows upon clicking its Launcher Icon

Reported by mlaverdiere on 2011-03-11
This bug affects 510 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
John Lea
Obsolete project please ignore
Undecided
Unassigned
Unity
Wishlist
Christopher Townsend
Unity Tweak Tool
Undecided
Sam Hewitt
unity (Ubuntu)
Wishlist
Christopher Townsend

Bug Description

What I do miss in Unity is the possibility to click on the app. icon on the Unity launcher bar to minimize all windows of that application, not only to launch/restore it.
mlaverdiere's futher addition: https://bugs.launchpad.net/ayatana-design/+bug/733349/comments/2

My suggestion would be to modify the interaction-design/process like this (*=my modification proposal/2 cents!):

1) start it, if it hasn't been started yet;
*2) restore it, if it is minimized;
*3) focus the app, if it's started, not minimized and has not the focus yet;
4) spread windows (of app), if app is focused and has multiple windows open;
*5) minimize it if it is in spread-mode (see 4).

Note that this bug has over 300 comments and several working but rejected patches. This means that this feature probably will never land in official Unity! So if you want it, you have to use a patched version of Unity.

There is a working patch for 13.04 ( from comment #322, https://bugs.launchpad.net/ayatana-design/+bug/733349/+attachment/3573380/+files/minimize.patch ). Somebody should set up a PPA (and note it here) to make it easy to install the patched version.

Related branches

lp:~ojno/unity/minimize-on-click
Rejected for merging into lp:unity
GonzO (community): Resubmit on 2012-03-21
Marco Trevisan (Treviño): Disapprove on 2012-03-20
lp:~townsend/unity/click-to-minimize
Merged into lp:unity at revision 3728
Brandon Schaefer: Approve on 2014-03-18
PS Jenkins bot: Needs Fixing (continuous-integration) on 2014-03-18
Mirco Müller (macslow) wrote :

The intended behaviour according to the interaction-design is this:

1.) start it, if it hasn't been started yet
2.) focus the app, if it's started and has not the focus yet
3.) spread windows (of app), if app is focused and has multiple windows open
4.) unspread if in spread-mode (see 3.)

For the time being this is a "Won't fix". To discuss a new feature, do so on the ayatana mailing list (with the design-folks) here:

https://launchpad.net/~ayatana or <email address hidden>

Changed in unity:
status: New → Won't Fix
Omer Akram (om26er) on 2011-03-25
Changed in unity (Ubuntu):
status: New → Won't Fix
mlaverdiere (mlaverdiere) wrote :

@Mirco: Thanks for explaining what the intended behaviour is, Now, let's talk about the expected behaviour! ;-)

More seriously: I'm testing Natty/Unity since 2 months now and I still miss the minimize function upon reclicking on the launcher icon. Again, rightly or wrongly, this is how other desktop behaves and since many of us have to use these other environments (namely various Win flavours) from time to time, I think this expectation won't go away...

My suggestion would be to modify the interaction-design/process like this (*=my modification proposal/2 cents!):

1) start it, if it hasn't been started yet;
*2) restore it, if it is minimized;
*3) focus the app, if it's started, not minimized and has not the focus yet;
4) spread windows (of app), if app is focused and has multiple windows open;
*5) minimize it if it is in spread-mode (see 4).

Consider this a wish!

Thanks.

tekstr1der (tekstr1der) wrote :

Is there a specific discussion on this in ayatana currently?

I agree entirely mlaverdiere's comment #2. That is the expected behavior from a launcher.

I hate to do this, but I have to add my "me too" to this bug.

Seriously last night when I was trying beta 1 I was shocked that I could not minimize a window without going to the minimize button. Honestly it got rather annoying (no seriously I mean annoying, not just buggy - annoying) after a while.

There wasn't even an option in the right-click menu (jumplist?) to minimize - and I found that surprising as well. Trust me, new users won't be very happy about this, so please, for the sake of new users at least, fix this issue, and if you want the intended behaviour - then make it an option, just not default D:!

Bazon (bazonbloch) wrote :

why break peoples expectations? "minimize on click" is provided by all taskbar-window-switchers and from all linux docks as well, too.
So you leave the experienced user in frustration while the inexperienced user will not be mocked by minimizing on an extra click he probably never makes.

Lucazade (lucazade) wrote :

Please consider add an option for this behavior in future releases!

If we had a Windows 7-style window selector displayed on hover then the behaviour could be:

1) Open/restore window
2) On hover, display window selector alongside icon
3) On click, minimise window

This would both match people's expectations and provide an easy way to switch between open windows.

Jorge Ortega (jorge-ortega111) wrote :

Not being able to minimize from the bar icons is my main grievance with Unity. As far as I'm concerned this is a bug and should be fixed.
Regards

Rocko (rockorequin) wrote :

One functional regression of the global menu bar is that you can't minimize maximized applications that are showing a modal popup window. (eg run Synaptic maximized and while it is reloading or applying updates, you can't minimize it because the global menu bar shows the window control buttons for the progress window.) It would sure be useful to have the ability to minimize from the unity launcher instead, even if it were just via a right-click menu option.

Another use case for minimizing from the launcher is if I want to quickly check something in an application. eg if I'm working on something in libre office and I click on unity's Thunderbird icon to quickly check on the contents of an email I have open, I would much rather just click on the Thunderbird icon again to get back to libre office, instead of being forced to move the mouse around looking for Thunderbird's minimize buttons or for libre office's launcher application. Unity's current implementation results in slower (and more frustrating) workflow in this case, and for me, this is a use case I frequently encounter.

Bazon (bazonbloch) wrote :

Rocko wrote 5 hours ago: #9

"One functional regression of the global menu bar is that you can't minimize maximized applications that are showing a modal popup window. (eg run Synaptic maximized and while it is reloading or applying updates, you can't minimize it because the global menu bar shows the window control buttons for the progress window.) It would sure be useful to have the ability to minimize from the unity launcher instead, even if it were just via a right-click menu option."

this is soooo true! is there a separate bug about this maximized background window issue? that is so confusing I git into that trap several times. So I would subscribe and click on "affected" for that bug instantly. (or file it)

Rocko (rockorequin) wrote :

Yes, I reported bug #762277 for that issue.

Michael (michaeljt) wrote :

Discussed this with a colleague with a different background and it quickly became apparent that the expected workflow here is not to re-minimise the application you are no longer using, but to simply switch to the one that you do want to use, and if you don't want the application-to-be-minimised to be covering other windows move it to its own workspace, so that selecting it in the dock automatically switches you to that.

Cas (calumlind) wrote :

This is a major bug bear for me since installing natty.

> not to re-minimise the application you are no longer using, but to simply switch to the one that you do want to use

I think it is intuitive that you click the button to re-minimise.

As Rocko mentioned, quickly checking an app and then going back to original work currently requires extra mouse and eye movement which I think is annoying and distracts from the your work flow.

If single clicking once an app is open and highlighted serves no other purpose, why not allow the option to minimize?

The app indicator functionality is single click to open and optional single click to close.

Bazon (bazonbloch) wrote :

I believe it's generally not a good idea that clicking on an interactive element of your screen leads to NOTHING.
Some users will wonder whether their system is responding slow, experienced users who are used to the minimize behaviour will miss it.
(and you know, many of them are already frustrated enough losing Gnome 2 features.....)

please change that, when you don't click a second or third time, you won't even notice the "extra" minimize feature! So no one is bothered by the minimize feature, but many are bothered if it is missing.

Rocko (rockorequin) wrote :

Does anyone know the reason behind the design decision to _not_ implement minimize in unity, or the location of the design webpage?

Michael (michaeljt) wrote :

I'm sure that if you ask on the Ayatana mailing list they will be happy to explain, and perhaps to discuss, the reasoning.

John Lea (johnlea) on 2011-04-20
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
tags: added: udo
summary: - Natty: Unity launcher buttons should allow to minimize apps, not just
- launch/restore
+ Add 'minimize all windows'Natty: Unity launcher buttons should allow
+ to minimize apps, not just launch/restore
summary: - Add 'minimize all windows'Natty: Unity launcher buttons should allow
- to minimize apps, not just launch/restore
+ Add 'minimize all windows' option to the quicklist of running
+ applications
Changed in unity:
status: Won't Fix → New
Didier Roche (didrocks) on 2011-04-20
Changed in unity (Ubuntu):
status: Won't Fix → New
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
John Lea (johnlea) on 2011-04-20
Changed in unity:
status: Triaged → New
Changed in unity (Ubuntu):
status: Triaged → New
John Lea (johnlea) on 2011-04-20
tags: removed: udo
Changed in ayatana-design:
status: Fix Committed → Won't Fix

Status changed to Won't Fix as this change is not in keeping with design. The cost of the extra chrome outweighs the net gain from this change. The current behaviour has been shown to work well in user testing, however we will watch out for this issue to in future user testing.

Alex Launi (alexlauni) on 2011-04-20
Changed in unity:
status: New → Won't Fix
Changed in unity (Ubuntu):
status: New → Won't Fix
Rocko (rockorequin) wrote :

@John Lea: The change you made in the summary and description totally ignores what I think is the primary point made in the report, ie that just clicking on the application icon/button should minimize the app if one of its windows currently has the focus, the lack of which is a major flaw in the design IMO.

This bug now looks like it is only about adding a menu option to minimize the application's windows. But this was first mentioned as a related point in comment #4.

Did you intend to do this? Can you track the request for the menu option in a separate bug?

Rocko, no, clicking on the icon will not minimise the app.

We have a minimise button for that, it's prominent.

 status opinion

Mark

Changed in ayatana-design:
status: Won't Fix → Opinion

Mark, what I don't understand in this case is that :

-it's the standard behavior in Gnome, so people are used to it

-I agree that you can use the icon to minimize, but what if you want to minimize several applications ? You have to move your mouse a lot. Using a click in the taskbar is very quick

-and last but not least, it's not like if this option was replacing another more interesting behavior ! And it's exactly how it's working for the "applications" and "files & folders" lenses ! You click, it opens. You click again, it hides it. I really find it a pity that this click is not used. Especially as it's the simplest operation on a lens. A "right click" + something is much longer.

I guess I should write all this on the Ayatana ML. But I tried to get used to this behavior, and I still find myself clicking on the application icons and waiting. Maybe it's a bad habit. And even if it's one, I still think it's a pity to waste this click. Maybe the minimize function is not the right one for it, I'm open to any good idea. But as of today, it's wasted to me. Too bad, Unity is quite good at making things efficient, a single click is still something worth using I think :)

Michael (michaeljt) wrote :

I will play the devil's advocate, as I can't make up my mind which behaviour I would prefer. But in defence of the current behaviour it has a certain consistency that the minimising proposal doesn't. Currently if you click twice on the icon you know that all the applications windows will be displayed, without a zoom if you only have one window. With the minimising proposal you would have to check whether the application has one or several windows open to know if two clicks will show all windows or hide the one window. You gain speed in one case by sacrificing it in another, possibly more common case.

François Tissandier (baloo) wrote :

I forgot about this multi-windows option...

But playing with it brings me to the same conclusion:
-I have 3 terminals on my desktop
-i click the lens, it shows me an expose view of the 3 terminals.
-if click on the lens again to "close" this expose view, and nothing happens.

Maybe I have terrible habits, but that's the first thing I noticed why trying it.

Michael (michaeljt) wrote :

Yes, I found that rather annoying too. Don't know what the reasoning was for not exiting the zoom view again, although I'm sure there must be one.

Rocko (rockorequin) wrote :

@Mark: absolutely, it is quite clear that clicking on the application icon again doesn't minimize the window. My point is that this is exactly what the original report said, and John Lea changed it to say something quite different, ie that there is no minimize option when you right-click on the icon. Why change the bug to say something different? Why not just open a new bug?

And I agree of course that the minimize button is prominent. But it's nowhere near as prominent as the application icon in unity-launcher, and more importantly you have to go searching for it, which I find inefficient from a workflow point of view. This is particularly true on a high resolution screen where the window buttons are quite small and may be at the other side of the screen from the application icon that you just clicked to activate the window. (Even a year after 10.04 came out, I still think the minimize button should not be so small and located next to the close button, as it's too easy to click the close button by accident.)

And there are even instances where there is no minimize button - eg in a maximized Synaptic with the progress window open.

I know unity was originally designed for netbooks, which have small screens, but it's a great product that I want to use on my high resolution desktop. It's just that there some things like this that make it less efficient to use on a desktop than, say, DockbarX, Avant Window Manager, or the original Gnome button taskbar.

On a slightly different topic, as an absolute design minimum, wouldn't it be better to have the application icon at least do something when you click on it if it isn't actually going to change the screen? Perhaps perform an animation? This would give some feedback to the user that he has successfully clicked on the icon, even if he finds it frustrating that it doesn't minimize the window.

tekstr1der (tekstr1der) wrote :

I consider this issue to be the single biggest usability problem with Unity currently. I've followed the Ayatana discussion thread on this topic and I'm very disappointed.

1) I'm disappointed in the way that this bug/request was misconceived and misconstrued by the developers. Adding a right-click context menu option is every bit as distracting as the current behavior, and is useless to me. With that "solution", the user must divert his attention to find the menu item, and minimizing the focused app takes two mouse clicks in separate areas of the screen.

2) The requested behavior is universal to docks. Common examples where desired behavior can be found are: a linux distro with a dock (docky, awn, cairo, etc), Mac OSX dock, Windows 7 taskbar. I know Ubuntu wants to be different, but at the cost of usability, is it really worth it? I’m a Ubuntu user, but admit Win7 really nails it when it comes to dock functionality.

3) The requested behavior only adds, not changes, functionality. Currently, clicking on a launcher who's associated window has focus does… nothing.

4) The current behavior is wildly frustrating when you’d like to quickly check the status of a running application. Currently, you click the associated launcher to bring focus (this is good), but then need to hunt down the little minimize button for that window, which, if not maximized could be virtually anywhere. This is highly distracting to workflow.

5) Instead, clicking the launcher again to minimize the focused app, as requested originally in this bug report, is quick, easy, distraction-free fun. And, is the expected behavior from a dock/launcher.

6) Please?

Cas (calumlind) on 2011-04-21
summary: - Add 'minimize all windows' option to the quicklist of running
- applications
+ Minimize windows upon clicking application's launcher
description: updated

John accidentally misdirected the bug report, that's not a conspiracy,
just an accident. It would have been better to open a separate bug. As
it happens, we won't put this on the quicklist either.

Apps that don't have minimise icons either have a reason for that, or
are buggy.

@tekstr1der: currently, clicking on the icon ALWAYS ensures you SEE the
app. Adding minimise will add complications... when would it show the
window? When would it show a spread of that apps windows? When would it
minimise.

Adding is not always improving.

Mark

I'm the original reporter for this bug/request report and I still believe (after I've read all the above comments) that minimizing upon clicking the launcher's icon would make sense, be great and would not be disruptive in any workflow I can imagine.

That being said, I had a chance to play with a Mac in the last days and clicking on the the dock/launcher app. doesn't seem to trigger windows/apps minimizing (maybe it's just the particular configuration of the Mac I've tried....?). My point here is not to suggest that OSx is THE reference for UI design's decision, far from it, but just to point point out that there is no absolute truth about the current issue.

I suppose that, at some point, good design/conception decisions could be based on the average user's expectations, for a given platform/OS/UI/etc., at a given time...

dart (dart-v85) wrote :

A show desktop icon on unity launcher by default will solve the problem to some extent as it will minimize all active windows in one click and bring focus on a clean desktop. There is a keyboard shortcut alt+ctrl+d that does the same thing but not everyone is used to keyboard shortcuts. But this is not ideal solution if one wants to minimize one/multiple instances of only one app (e.g nautilus) and not all.

Michael (michaeljt) wrote :

I could imagine a longer (two seconds?) click on the launcher icon hiding all windows for an application.

Yes, we'll also consider a show-desktop launcher icon.

+1 for show desktop icon/function (but there's another bug report - and some workarounds with compiz settings - for this: https://bugs.launchpad.net/bugs/681348)

Bazon (bazonbloch) wrote :

I want to add a typical case to the Issue François described:

François Tissandier wrote 21 hours ago: #22
"
I forgot about this multi-windows option...

But playing with it brings me to the same conclusion:
-I have 3 terminals on my desktop
-i click the lens, it shows me an expose view of the 3 terminals.
-if click on the lens again to "close" this expose view, and nothing happens.
"

A typical case for that is, when you click the the lense/launcher/button (however you call it) by mistake:
Now you have a expose view window spread of several windows of which you want none. Now, the only way to get out of that state, is selecting one window. Although you don't need it!
It's bothering to have to select a window you don't need!
Easier and more intuitive would be to simply click again: "Oh, I made a mistake, I click again so it's gone."
Just as many other UI-elements.

By the way, the frustrations generated by the bugs behaviour on the desktop is very similar to the frustration caused by the bug treatment here on launchpad:
* you click on the icon, and nothing happens.
* you give reasonable arguments on launchpad to change this, but nothing happens. (not even an explanation why the selected behaviour should be more useful)

Bazon (bazonbloch) wrote :

Another approach could be:
MAKE IT AN OPTION!

Hide the option however you could, so that the "normal user" will never see it, but give at least us "Fanboys" the option.

The thing I can't stand on apple computers is, that apple dictates the users how to use the computer. Canonical seems to go that way and that makes me lose trust in Canonical... :-(

Rubén (cont3mpo) wrote :

Now on Unity:
1. Clicking an icon of a focused (maximize) window: Does nothing (?)
2. Clicking an icon of a minimize window: Does Maximizes (intuitive)
3. Clicking an icon with two or more windows: Spread Mode of the windows (really nice)

Then, why the Launcher maximize one window but not minimize the same window? It is more intuitive that the launcher minimize and maximize the same window. The button of the windows exist for that, but is more intuitive for the user; minimize/maximize the same window on the launcher.

http://askubuntu.com/questions/36433/why-cant-i-use-the-unity-launcher-icon-to-minimize-applications-windows

"Not gonna happen? Why not? DockbarX allows you to do that same thing... Futhermore, compiz 0.9 is SUPPOSED to support showing minimized window thumbnails. Why would it be so hard? "

I quoted my own comment here. Now let me reiterate. DockbarX allows you to have both behaviours, and unity SHOULD as well (it's simple common sense. Sorry Mark, but we are not Mac users and we are not trying to be so stop trying to ape Mac (sorry if that offends, but let's be honest)).

It is simple common sense to me that if you:
 - Click on a single window's icon, it minimizes or restores the window (so long as the window supports it.
 - Click on multiple windows' icon, it should enter scale mode (common sense!)
 - Probably double click on multiple windows' icon: minimize or restore all (for example, chat applications).

What's so hard, confusing, or unintuitive about that?

BTW I would just use the ayatana mailing list, but:
1. It doesn't seem to receive my msgs.
2. I'm not convinced that our feedback has a REAL impact there (not convinced yet at least).

Bazon (bazonbloch) wrote :

btw, this would be a nice additional option to the "Launcher and Menus" Setting which momentary only include one single solitude option ("show the launcher when the pointer:"): http://i.imgur.com/f4q6k.png

Bigmoew (bigmoew) wrote :

How about one click to either minimize a single window or go into expose mode for multiple windows with an addition click to minimize??

Rasto (rasto-klc) wrote :
Download full text (3.4 KiB)

Unity launcher's behavior is terrible.
It does not make sense and is absolutely not intuitive.
I have just let 4 people to play around with Ubuntu 11.04.
There was about 10 things they did not get.
One of them was always unexpected behavior of launcher.
They wanted that it does something.
They thought it stopped responding - because it did, it was doing something before (focusing window, showing window selection, ...) and it does not continue anymore - it broke the chain, did not satisfy user.

It should be doing cycle, it is logical, it is reversible, user has more control, it is robust,

PROPOSED BEHAVIOR:

1) I click and you show me what is under this icon:
   1.a - open first instance of app (run and focus) or

   1.b - focus app if it is minimized/out-of-focus, even if there is many of them (show me what I was working on last, I am looking for something obviously under this icon)

2) I click again and you do not break my experience:
   - so multiple windows/apps are opened now and focus is on one of them (we may not notice that there are many windows, of course)
   - so right now we can see single window focused and we want more out of it (I guess we would not be clicking anymore if we do not expect more)

   2.a - show me all the apps so I can select one (user sees that pretty animation and selects what he wants, but perhaps he did not want that, he might wanted something else, or just wanted to check on something, so there MUST be way out without selecting one of the applications!)

   2.b - if there is just single window opened then finish the cycle with step 3 (minimize it, show the user there is nothing more he/she can do)

3) I am clicking again and getting back to beginning
   - for single window or multiple spread applications
   - do not worry designers, because all those people who did not expect anything they will not click (or will they?)

   3.a - minimize single app (there is no more to do, let the user know, if this was not expected, then he will click on that icon again, do not worry, it is going in cycle)

   3.b - unfocus (back to state 1) and hide multiple windows selection from step 2.a (what else do you want to do? user wants something! he is the boss, he just clicked - obviously he does not want to select one of the apps - this is essential. Maybe he did not find what he was looking for, maybe he just did. Go back to beginning, give him something familiar, let him cycle if he wants to do that one more time.

IT IS SIMPLE:
Users that do not need this multiple click functionality will simply not make that extra click (well, but they are clicking even now, I guess they are looking for something more, they just not getting it)

AGAIN:
Maybe somebody got lost in the process so here is recapitulation, it is essentially what everybody is saing:

A) got single or no app
1. click - run/focus app
2. click - minimize app

B) got multiple windows:
1. click - bring me my last app (or skip this step if app is already in focus)
2. click - show me all the apps
3. click - revert back to exact state as it was before 1. click

FINAL REMARKS:
And for gods, make it configurable! so power users can adjust it an averages have pretty...

Read more...

manny (estelar57) wrote :

Maybe expose can be more useful and show the options the user wants. So i made this quick mockup just to get an idea of the possibilities.

i think is win win for both parties :)

note:
am not so good at mockups, so i hope is not too terrible :o

Rubén (cont3mpo) wrote :

@Rasto: Too many clicks and differents behaviors in your proposed, keep simple and cool. Spread Mode show all the windows when are too many apps.

Like i say up...
Actual behavior in Unity:
1. Clicking an icon of a focused (maximize) window: Does nothing (?)
2. Clicking an icon of a minimize window: Does Maximizes (intuitive)
3. Clicking an icon with two or more windows: Spread Mode of the windows (really nice)

Now is simple, but the point 1 is failing (Does nothing).
Keep simple behavior in the launcher and add "minimize" on the icon, that's all we want.

Changed in ayatana-design:
status: Opinion → Incomplete
Extender (msveshnikov) on 2011-05-04
Changed in ayatana-design:
status: Incomplete → Confirmed
Changed in ayatana-design:
status: Confirmed → New
summary: - Minimize windows upon clicking application's launcher
+ Minimize Applications upon clicking on Launcher Icons
description: updated
summary: - Minimize Applications upon clicking on Launcher Icons
+ Minimize windows upon clicking on Launcher Icons
description: updated
summary: - Minimize windows upon clicking on Launcher Icons
+ Hide Applications upon clicking on Launcher Icons
Cas (calumlind) on 2011-05-16
summary: - Hide Applications upon clicking on Launcher Icons
+ Minimize Application's Windows upon clicking it's Launcher Icon
John Lea (johnlea) on 2011-06-20
Changed in ayatana-design:
status: New → Won't Fix
importance: Low → Undecided
max (maxozilla) on 2011-07-03
summary: - Minimize Application's Windows upon clicking it's Launcher Icon
+ Minimize Application's Windows upon clicking its Launcher Icon
description: updated
tags: added: raring
tags: added: saucy
Sam Hewitt (snwh) on 2013-09-19
Changed in unity-tweak-tool:
status: New → Won't Fix
assignee: nobody → Sam Hewitt (snwh)
quequotion (quequotion) on 2013-12-13
Changed in canonical-design:
status: New → Confirmed
tags: added: trusty
Changed in canonical-design:
status: Confirmed → Invalid
337 comments hidden view all 417 comments

One click to show the window picker. A second click to minimize all
windows. Rince and repeat.

Not so difficult, is it?

2014-02-04 Dimitri John Ledkov <email address hidden>:

> Clicking on the icon exposes apps' windows. Please, do not change that!
> It's uber useful! When i click on it, i want to focus that app not make
> it disappear into oblivion!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/733349
>
> Title:
> Minimize Application's Windows upon clicking its Launcher Icon
>
> Status in Ayatana Design:
> Won't Fix
> Status in Obsolete project please ignore:
> Invalid
> Status in Unity:
> Won't Fix
> Status in Unity Tweak Tool:
> Won't Fix
> Status in "unity" package in Ubuntu:
> Won't Fix
>
> Bug description:
> What I do miss in Unity is the possibility to click on the app. icon on
> the Unity launcher bar to minimize all windows of that application, not
> only to launch/restore it.
> mlaverdiere's futher addition:
> https://bugs.launchpad.net/ayatana-design/+bug/733349/comments/2
>
> My suggestion would be to modify the interaction-design/process like
> this (*=my modification proposal/2 cents!):
>
> 1) start it, if it hasn't been started yet;
> *2) restore it, if it is minimized;
> *3) focus the app, if it's started, not minimized and has not the focus
> yet;
> 4) spread windows (of app), if app is focused and has multiple windows
> open;
> *5) minimize it if it is in spread-mode (see 4).
>
> Note that this bug has over 300 comments and several working but
> rejected patches. This means that this feature probably will never
> land in official Unity! So if you want it, you have to use a patched
> version of Unity.
>
> There is a working patch for 13.04 ( from comment #322,
> https://bugs.launchpad.net/ayatana-
> design/+bug/733349/+attachment/3573380/+files/minimize.patch ).
> Somebody should set up a PPA (and note it here) to make it easy to
> install the patched version.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/733349/+subscriptions
>

Benjamin Geese (ben-8409) wrote :

I know this is rather annoying as everybody seems to see the need to comment on this while this issue has been decided about two years ago.

Saying that, i join this mess of noisy comments because i feel on view is rather underrepresented in this thread:
The one of a happy user!

I am perfectly happy with the current behaviour have never missed the minimized feature. I fact it might disturb my workflow.

And even more so: I have never be so happy with a stable and functional desktop environment on linux as i am with unity. I think there have been some very good design decision made and, this time, we should just trust those people who decided this is a opinion or won't fix and leave it at this.

pcworld (pcworld) wrote :

> I think there have been some very good design decision made and, this time, we should just trust those people who decided this is a opinion or won't fix and leave it at this

Yeah I will trust them that they know better what I want than I do.
Seriously, why is "customizability" becoming a foreign word to people?

So you think we should just ignore those who think it was a bad decision
(including myself) and don't provide any option to satisfy those who wish
there was an option to minimize?

http://about.me/rolandixor/

On Tue, Feb 4, 2014 at 11:10 AM, Benjamin Geese
<email address hidden>wrote:

> I know this is rather annoying as everybody seems to see the need to
> comment on this while this issue has been decided about two years ago.
>
> Saying that, i join this mess of noisy comments because i feel on view is
> rather underrepresented in this thread:
> The one of a happy user!
>
> I am perfectly happy with the current behaviour have never missed the
> minimized feature. I fact it might disturb my workflow.
>
> And even more so: I have never be so happy with a stable and functional
> desktop environment on linux as i am with unity. I think there have been
> some very good design decision made and, this time, we should just trust
> those people who decided this is a opinion or won't fix and leave it at
> this.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/733349
>
> Title:
> Minimize Application's Windows upon clicking its Launcher Icon
>
> Status in Ayatana Design:
> Won't Fix
> Status in Obsolete project please ignore:
> Invalid
> Status in Unity:
> Won't Fix
> Status in Unity Tweak Tool:
> Won't Fix
> Status in "unity" package in Ubuntu:
> Won't Fix
>
> Bug description:
> What I do miss in Unity is the possibility to click on the app. icon on
> the Unity launcher bar to minimize all windows of that application, not
> only to launch/restore it.
> mlaverdiere's futher addition:
> https://bugs.launchpad.net/ayatana-design/+bug/733349/comments/2
>
> My suggestion would be to modify the interaction-design/process like
> this (*=my modification proposal/2 cents!):
>
> 1) start it, if it hasn't been started yet;
> *2) restore it, if it is minimized;
> *3) focus the app, if it's started, not minimized and has not the focus
> yet;
> 4) spread windows (of app), if app is focused and has multiple windows
> open;
> *5) minimize it if it is in spread-mode (see 4).
>
> Note that this bug has over 300 comments and several working but
> rejected patches. This means that this feature probably will never
> land in official Unity! So if you want it, you have to use a patched
> version of Unity.
>
> There is a working patch for 13.04 ( from comment #322,
> https://bugs.launchpad.net/ayatana-
> design/+bug/733349/+attachment/3573380/+files/minimize.patch ).
> Somebody should set up a PPA (and note it here) to make it easy to
> install the patched version.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/733349/+subscriptions
>

mnrl (zxcq14) wrote :

https://launchpad.net/~zxcq14/+archive/minimize-unity-7
This patch works also with ubuntu 14.04 ubuntu unity.
I've created a ppa for 14.04 trusty but new versions of packages released very quickly.
I can update packages every week.

Mr. T (mistert) wrote :

Please add minimize functionality to the launcher (as an option). Most people intuitively expect that it can be used for minimizing too.

Daniel Moore (danielmoore73) wrote :

PLEASE PLEASE PLEASE!!!!

Ayatana design team, development team, whoever is in charge of overseeing this subject!

I beg of you, in the nicest way i can possibly ask, please fix this issue. This single issue is the bane of my existence, i cant seem to adjust but i was able too in 12.04 BECAUSE it had this feature. This was the key feature that made me turn away from windows and even mac because it was a complete system, it had all the functionality that i needed to be very very productive. I EVEN HAD ONE OF MY COLLEGE PROFESSORS TRY THIS OUT, EVEN HE SAID IT WAS AMAZING! but now this feature is gone and i find Ubuntu clunky and hard to use because of all the screen clutter that exists. Like the bug description says, that design would be perfect, but if that is too hard to implement, at least give us the benefit of the doubt by just adding this feature to single windows instead of a window stack. I can try to live with this and id be more than happy to return to Ubuntu.

This shouldn't be hard to do since i had this implemented on a 13.04 install but it was buggy cause unity didn't agree with this modification so ultimately it was unusable but regardless this feature would make 14.04 perfect. I know i speak for a lot of people when i say that this would be ideal in terms of functionality. I already feel that unity is nice in that it offers a different desktop experience but one that is well thought out in terms of functionality, however this one simple issue, to me, has caused its use to be "difficult" even new users find it hard to use because they normally come from windows and mac and say why doesn't the launcher minimize my app, that doesn't make any sense! Then they tell me they don't like it and want to go back to windows, myself included.

So PLEASE PLEASE PLEASE PLEASE! I will join a design team if i have to, i will gladly contribute to this cause, i am a computer science graduate so i know i can at least be of some assistance.

Also kudos on the integrated menu, i was amazed by that cause i didn't think there was a way to make it better, but you continue to amaze. Now if we can just get this one little tiny thing in there it'd be PERFECT!

Thank you Ubuntu team for all of your hard work in designing probably THE nicest desktop environment in the world, and to make it even better, its free! for this i thank you!

Neptilo (neptilo) wrote :

On Tue, Feb 25, 2014 at 1:43 AM, Daniel Moore <email address hidden>wrote:

> i cant seem to
>
> adjust but i was able too in 12.04 BECAUSE it had this feature.

You must be kidding, right?

Daniel Moore (danielmoore73) wrote :

Absolutely not, this feature was vital to my work flow. In fact it was to nearly half the user base for Ubuntu.

Phillip Susi (psusi) wrote :

You are confused Daniel; this feature never existed in Unity, which is why this bug requested it a full year before 12.04 came out.

Daniel Moore (danielmoore73) wrote :

I hate to be the one who argues, especially on such a professional forum over something that doesn't help the topic at hand. This feature was available in 12.04, either by users or by the Ubuntu team themselves, i'm not sure of which. What i do know is that this feature was a welcomed addition to the user experience. Also you think i'm not aware of this issue being opened for so long. Its because I have basically been waiting from the beginning for the Ubuntu team to fix this mistake.

Next time you get on to tell someone their wrong because you just want to sound smart, or whatever your problem is. Be it trolling or whatever, please refrain from posting anything that doesn't help this issue, this is a bug report and discussion about the topic of adding the minimize on launcher click feature to Ubuntu, so if your not gonna be of any help, then stay off the forum. :)

best regards

Daniel Moore (danielmoore73) wrote :

Amazing, i was just looking through the comments and found that you Phillip posted something ABOUT the topic even if it was just one little thing, i take back my previous comment, however I will explain that just posting one little thing, isn't going to make much of a difference. This very reason is why we need to talk more about the relevance of this feature rather than just complain about it.

best regards

pcworld (pcworld) wrote :

> This feature was available in 12.04, either by users

And this feature is still available "by users" for at least >= 12.04, and given that your first comment starts with "PLEASE PLEASE PLEASE!!!!", it doesn't sound like your posts are of any help here as you say in "doesn't help this issue".
Also, you got something wrong there, this is not supposed to be a "forum" where anyone posts his/her useless opinions, this is supposed to be a *bug tracker*.
Though commenting here won't have any effect on the official versions of Ubuntu anyway, Canonical has decided it neither likes the proposed feature nor does it like customization.

Daniel Moore (danielmoore73) wrote :

Forgive me for starting the comments in such a way, I am simply tired of seeing the Ubuntu team make poor choices in terms of functionality. Some can be good and some can be bad but unfortunately right now the bad out weigh the good.

> And this feature is still available "by users" for at least >= 12.04, and given that your first comment starts with "PLEASE PLEASE PLEASE!!!!", it doesn't sound like your posts are of any help here as you say in "doesn't help this issue".

Please direct me towards a PPA that i can install to allow this feature for 13.10 or 14.04, that is if you can which i highly doubt is possible without having to build unity from scratch.

> Also, you got something wrong there, this is not supposed to be a "forum" where anyone posts his/her useless opinions, this is supposed to be a *bug tracker*.

Honestly i don't really care what its called. The point of the matter is to comment on the situation and make it a bigger deal. I know that the Ubuntu team has decided that they will not fix this issue but if we continue to heat this argument then maybe that will change, but sitting here complaining about how other people are wrong isn't helping anything.

The point of this discussion is to help the Ubuntu team understand what we find is wrong with the current functionality and how they can go about fixing it.

> Though commenting here won't have any effect on the official versions of Ubuntu anyway, Canonical has decided it neither likes the proposed feature nor does it like customization.

I cannot help but feel you are missing the point of this conversation entirely. If there is a problem and no one talks about it or makes any comments about how there is something wrong, does that problem ever get fixed? NO!

Please add reason and persuasion to your comments and MAYBE the Ubuntu team will see this and decide to attempt a fix.

best regards

Phillip Susi (psusi) wrote :

Reason and persuasion can be found in several comments here. Your comments on the other hand lack any, so you should take your own advice rather than drown out those comments that add something to the discussion.

Daniel Moore (danielmoore73) wrote :

lol that is a good phrase, you should take your own advice because you sure haven't added anything to the discussion except your own ignorance of the matter :)

congrats on proving my point

best regards lmao

Neptilo (neptilo) wrote :

On Tue, Feb 25, 2014 at 7:35 PM, Daniel Moore <email address hidden>wrote:

> Please direct me towards a PPA that i can install to allow this feature
> for 13.10 or 14.04, that is if you can which i highly doubt is possible
> without having to build unity from scratch.

Have you tried mnrl's PPA at comment
#382<https://bugs.launchpad.net/ayatana-design/+bug/733349/comments/382>
?

As for users like me who wanted to keep 12.04 until the next LTS comes out,
I could only get this feature to work following the instructions of this
very well explained post:
http://ubuntuforums.org/showthread.php?t=2093170&page=2&p=12407469#post12407469
and
replacing the version numbers by the more recent ones. Yes, it is quite a
tedious method, and it installs lots of other features along with it. But I
found that was worth it.

I hope it helps.

Daniel Moore (danielmoore73) wrote :

Thanks for the help Neptilo, i tried the first fix but no luck, im not sure why but i got error after i upgraded to 14.04 so that might have had something to do with it.

As for the second fix, im gonna work on that tonight and see. If i could get this feature back id gladly go back to 12.04 but im worried that since they have updated 12.04 to 12.04.4 then it may not work. Who knows, cant hurt to try.

Thank you for your help it was much appreciated

mnrl (zxcq14) wrote :

Daniel I've add packages for 12.04 to that ppa using unity revamped patch. https://launchpad.net/~zxcq14/+archive/minimize-unity-7 So you can use unity revamped without compliation with last version of unity. I'm going to check package versions every week and keep it updated.

Daniel Moore (danielmoore73) wrote :

Thank you for all the help and especially thank you for this fix mnrl. But I cant seem to get it to work, ive tested out various way of adding this ppa and applying the fix but i keep getting duplicate ppa error and it doesn't work, now it keeps wanting me to restart Ubuntu to apply changes, i do and then it says to restart again. If there is a guide somewhere for the exact steps to take when doing this then that would be great, im sure the problem is on my part i just have no idea what to do to fix it :(

mnrl (zxcq14) wrote :

Daniel, Are you using 12.04? you must add ppa like that:
sudo add-apt-repository ppa:zxcq14/minimize-unity-7
sudo apt-get update
sudo apt-get upgrade
And packages should be updated. Maybe there is a problem with your package system like broken depencies.
Run top three command above and put the errors in your terminal output in a text file, then attach here.

Daniel Moore (danielmoore73) wrote :

Ok i ran those commands and i ended up getting a similar error just like before. I attached the text file with the comment.

Daniel Moore (danielmoore73) wrote :

Oh and i forgot to mention, i am running ubuntu 12.04, also i am still currently working to figure this issue out but nothing so far, another thing is that im not sure of that file was uploaded so if it wasnt let me know and ill post it in the next comment.

best regards

mnrl (zxcq14) wrote :

Daniel, there is no attachment in your comment, maybe it wasn't uploaded.
Here is not a forum, so it's not right to talking about only my ppa.
Please e-mail me your terminal outputs. I can help you via e-mail.

Comment #335 should remain the focus of this post I'd like to remind.

Ubuntu 14.04 is great.

The dash is fine for type-launching an application, but not good for surveying the applications you got. However, the classicmenu-indicator package addresses this shortcoming.

Now, in 14.04, you can set window's menus to be in the title bar of each window, instead of that mac-like crap on the top panel. This is huge preference addition for me in 14.04.

I love the Unity Launcher (task bar).

My only remaining gripe with Unity is this bug of not implementing what's described in post #335.

Ok folks, I know this is loooong overdue, but we are going to put in as an unsupported option to allow clicking the Launcher icon of single windowed apps and minimize that window:)

By unsupported, I mean that functionality is "as-is" and no more tweaks or enhancements to it.

Thanks for everyone's patience and comments on your desire for this. It's good to see passion in the Community.

Changed in unity:
importance: Undecided → Wishlist
status: Won't Fix → In Progress
Changed in unity (Ubuntu):
status: Won't Fix → In Progress
importance: Undecided → Wishlist
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
milestone: none → 7.2.0

The attachment "Allows for minimizing windows from the launcher on Unity 2D" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

@townsend: and will this land for Trusty? The Feature Freeze and UI Freeze has passed already...

mlaverdiere (mlaverdiere) wrote :

As the original reporter of this "bug", I guess that all I have to say is thanks for finally acting on it.

I would hope that this the beginning of a different attitude from Ubuntu/Canonical leaders and devs when it's time to deal with some reasonnable community desires or whishes...

Anyway, thanks again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.2+14.04.20140318-0ubuntu1

---------------
unity (7.1.2+14.04.20140318-0ubuntu1) trusty; urgency=low

  [ Brandon Schaefer ]
  * Update the DPI when we setup the view. (LP: #1292268)
  * Do not avoid rendering the lockscreen when we have a fullscreen app.
    This also removes the old fullscreen + lockscreen fix where we force
    painted our selfs on top. (LP: #1291571)

  [ Chris Townsend ]
  * Add ability to minimize a single window application when clicking on
    the Launcher icon of the application. (LP: #733349)

  [ Andrea Azzarone ]
  * Whitelist "onboard" for rendering during lockscreen. (LP: #1291402)
  * Do not consider minimized windows for cross fade effect. (LP:
    #1291402)
 -- Ubuntu daily release <email address hidden> Tue, 18 Mar 2014 23:53:51 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
b_b (brunobergot) wrote :

Thank you *very much* @townsend \o/

@Christopher Townsend

Thank you so much for listening to user feedback and implementing a fair compromise. Please don't under estimate how important this is to us. I can barely stand it when a lot of people want something and the developers won't even at least add it as a preference that can be access through a settings menu.

You have no idea how much this little fix has boosted my Ubuntu morale!

Question: I have a fully updated Ubuntu 14.04; when can I expect to see your fix in action (by simply installing updates suggested by the Ubuntu Update Manager)?

1 comments hidden view all 417 comments

Hi,

The option should be available now.

CCSM->Ubuntu Unity Plugin->Launcher->Minimize Single Window Applications

On 03/19/2014 08:44 AM, Lonnie Lee Best wrote:
> @Christopher Townsend
>
> Thank you so much for listening to user feedback and implementing a fair
> compromise. Please don't under estimate how important this is to us. I
> can barely stand it when a lot of people want something and the
> developers won't even at least add it as a preference that can be access
> through a settings menu.
>
> You have no idea how much this little fix has boosted my Ubuntu morale!
>
> Question: I have a fully updated Ubuntu 14.04; when can I expect to see
> your fix in action (by simply installing updates suggested by the Ubuntu
> Update Manager)?
>

Stephen M. Webb (bregma) wrote :

@Lonnie Lee Best

It's in the Trusty archives now. Installing updates should do the trick.

1 comments hidden view all 417 comments

CompizConfig Settings Manager-> Ubuntu Unity Plugin -> Launcher -> Minimize Single Window Applications

Yep, it's there and it works like a charm! I'm happy again ( it's the little things ).

Changed in unity:
status: In Progress → Fix Committed
Tal Liron (emblem-parade) wrote :

I'm sorry, but it's hard for me to be happy with this fix. Why hide it away? Why not make it a public option in Unity settings? Most Ubuntu users will have no idea that this option is available. Those who will discover it will be baffled by how hard it is to enable (or disable) it.

We are trying to make Ubuntu better for everyone, not just fulill the needs of a few users. The only thing being "compromized" here is user friendliness.

As much as I appreciate "any way" to accomplish this, I must agree with Tal Liron.

To achieve this option, you must install additional software and a regular use won't ever know this option exists.

Furthermore, this option should be the default for 14.04. Not one bug report would be reported if this option were made default in the 14.04 release. No one would complain *period*. This should be given to everybody. It is completely intuitive. Every other major operating system does this by default.

quequotion (quequotion) wrote :

>>Townsend

First, thank you for doing the right thing. I haven't tried this feature yet, since I'm still not using Unity (or even Ubuntu anymore) and I have a question: does this feature distinguish between "focused" (to be minimized) and "unfocused" (to be focused) state?

quequotion (quequotion) wrote :

This is the code I asked about:

=== modified file 'launcher/ApplicationLauncherIcon.cpp'
--- launcher/ApplicationLauncherIcon.cpp 2014-03-12 23:46:10 +0000
+++ launcher/ApplicationLauncherIcon.cpp 2014-03-17 20:58:25 +0000
@@ -399,7 +399,16 @@
{
if (arg.source != ActionArg::Source::SWITCHER)
{
-Spread(true, 0, false);
+WindowList windows = GetWindows(WindowFilter::ON_CURRENT_DESKTOP);
+
+if (windows.size() == 1 && minimize_window_on_click)
+{
+wm.Minimize(windows[0]->window_id());
+}
+else
+{
+Spread(true, 0, false);
+}
}
}
}

Looks like it checks how many windows are in the group (windows.size() == 1) and if the setting is enabled (minimize_window_on_click); and the function is limited to windows on the current desktop (WindowFilter::ON_CURRENT_DESKTOP); but I don't see anything about focused/unfocused state.

Most of the time it will be fine as-is, especially for users who don't clutter a single workspace with lots of windows, but there may be occasions when a single window on the current desktop may be under another window or a group of windows and clicking on the icon will minimize it behind them ("Aunt Suzy"). Since there's a minimize animation to see, most users will probably realize what happened and click the icon one more time to get the desired window out and on top.

Adding an additional if statement to cover this case would be a nice improvement. Please excuse my ignorance of the proper names of the functions and variables involved; consider this a blueprint for actual code:

if (windows.size() == 1 && minimize_window_on_click)
{
+if ( windows[0]->window_state() == unfocused )
+{
+wm.Raise(windows[0]->window_id());
+}
+else
+{
 wm.Minimize(windows[0]->window_id());
 }

I know how hard it was to get this feature in even "as-is" with "no more tweaks or enhancements", and I'm happy to see it happen at all, so I won't hold it against anyone if this behavior is never updated; just a suggestion (and reiteration of the same from several comments in this report).

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 417 comments or add a comment.