UIFe: Icon in Launcher should be home folder icon

Reported by Mark Shuttleworth on 2011-02-18
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Medium
Unassigned
Unity Asset Pool
Undecided
Unassigned
unity-2d
Medium
Florian Boucault
ubuntu-mono (Ubuntu)
Critical
Vish
unity (Ubuntu)
Undecided
Unassigned
unity-asset-pool (Ubuntu)
High
Paul Sladen

Bug Description

Binary package hint: nautilus

The file manager (nautilus) icon in the Unity launcher is a folder with a pointer. That is a bug, because it puts a phantom pointer on the screen. The default icon there should be the home folder icon, and the icon should open the home folder (/home/<user>).

Didier Roche (didrocks) wrote :

some hints for prospective contributor: nautilus.desktop is opening a file from the humanity-icon-theme named
humanity-icon-theme: /usr/share/icons/Humanity/apps/48/system-file-manager.svg

We can either point nautilus.desktop to another file, or change this one. The impacts have to be looked at though.

tags: added: bitesize
Changed in unity:
status: New → Triaged
Changed in nautilus (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

the issue seems an icon theme one rather than a nautilus or unity bug though...

affects: nautilus (Ubuntu) → humanity-icon-theme (Ubuntu)
Sebastien Bacher (seb128) wrote :

reassigning to humanity-icon-theme but we should make sure that design knows about it because it seems nobody is watching the icon theme bugs on their side and nobody in the desktop team is likely to draw icons

Vish (vish) wrote :

As mentioned in the bug report description, for the default folder icon to be the home folder icon, Unity needs to use the icon "/usr/share/icons/Humanity/places/48/user-home.svg"
This icon already exists, we just need to switch to the right icon.

affects: humanity-icon-theme (Ubuntu) → unity (Ubuntu)
Didier Roche (didrocks) wrote :

Hey Vish, sorry but you are wrong ;)

The icons comes from bamf matching nautilus to a desktop file. The nautilus desktop file contains system-file-manager. This icon should be changed in any case as when you click on the launcher, nautilus is started without any argument, and so, open the home folder…

affects: unity (Ubuntu) → humanity-icon-theme (Ubuntu)
Vish (vish) wrote :

But changing the 'system-file-manager' icon to a 'Home folder' icon would be wrong.
Off the top of my head, the 'system-file-manager' icon is used in the file progress window and in its systray icon too. Using the home icon here is not right. (I'd need to check whereelse it is used)

As we discussed on -desktop, a solution would be to provide a "nautilus-unity.desktop" with the user-home as the icon

Vish (vish) wrote :

Its also used for the Applications menu items> (1)File Browser , (2)File Manager and system preferences menu item > (3)File Management. Replacing all these with the Home folder icon is not right.

Didier mentioned we would look into this again on Monday(he is busy with crashes today ;p )

Changed in humanity-icon-theme (Ubuntu):
status: Triaged → Incomplete

I think the "system file manager" icon could be updated to not have the
pointer, for a start. Separately, we should figure out how to make the
"home folder" icon be on the launcher, since it says very clearly what
you'll get when you click on it :-)

Mark

Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Triaged

Regarding changing the icon to a home icon by adding the nautilus-unity.desktop, we discussed this today,
 <didrocks> vish: but I'm afraid that when you start it, you will be matched against nautilus.desktop
 <didrocks> vish: this needs a try :)
 <didrocks> there was a hook for that case in maverick, not sure it survived natty though.

So bitesizers, need to check if a nautilus-unity.desktop works and if that fixes this issue.
If that does not work, then we'd have to hack it in Humanity as a last resort. But that is not a pretty option, since it breaks the above menu items(and not sure what other third party apps use it) and I'd be left with bugs regarding wrong icons used.. :p

For updating the "system-file-manager" icon to something else, we have another bug. but right now, neither of us on have a better alternate idea for that though.. :)

Changed in unity-2d:
importance: Undecided → Medium
status: New → Triaged
Didier Roche (didrocks) wrote :

So, just to highlight that the default should be "nautilus-unity.desktop" in the default unity gsettings favorites as well.
@Florian: I think there will be nothing to do in unity-2d on your side as bamf makes the matching and the gsettings favorites are common ;)

Olivier Tilloy (osomon) wrote :

Unity 2d hasn’t switched to gsettings yet, it’s still building its list of favorites from gconf. This will eventually happen but if we want to fix this bug in the meantime we’ll have to update the package’s default gconf settings.

Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)

And what about it?

tags: added: patch
Changed in unity:
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-03-05
Changed in unity (Ubuntu):
status: Triaged → In Progress

Could someone examine the patch, please?

Didier Roche (didrocks) wrote :

Merged the gsettings schema! Will be in 3.6.2. Thanks a lot Marco :)

Changed in unity:
status: In Progress → Fix Committed
milestone: none → 3.6.2
Didier Roche (didrocks) on 2011-03-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.2-0ubuntu1

---------------
unity (3.6.2-0ubuntu1) natty; urgency=low

  * New upstream release:
    - unity-window-decorator crashed with SIGSEGV in
      g_cclosure_marshal_VOID__OBJECT() (LP: #724874)
    - blinking screen at searching "gn" (LP: #674022)
    - Top panel isn't multimonitor aware (LP: #675862)
    - Leaving fullscreen causes the launcher to rapidly appear and then
      disappear (LP: #718054)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-Watch TV
      Shows.desktop/type": ` ' is an invalid character in key/directory names
      (LP: #722403)
    - does not display icons until hovered (LP: #726033)
    - Unintuative Application Matching (LP: #726711)
    - icons missing in the dash recent files and directory search returns
      (LP: #727824)
    - some result cache broke the dash search (LP: #728961)
    - Protect against conflicts with unity super keys (LP: #729166)
    - not installed apps sorting in global search (LP: #636996)
    - No 'safely remove' option is present in the unity menu when a usb disk
      is inserted (LP: #660010)
    - Dash - Implement new Dash design! (LP: #683762)
    - Expose or add missing nux functions for a11y support (LP: #701672)
    - Launcher - A single finger 'hold' on a Launcher app icon should open the
      quicklist (LP: #702486)
    - No "Search" default entry (LP: #710794)
    - Icon in Launcher should be home folder icon (LP: #721121)
    - Launcher bindings require Super to be held down to work (LP: #727580)
    - compiz crashed with SIGSEGV in nux::CairoGraphics::GetBitmap()
      (LP: #727636)
    - Unity "Lens" do not scroll to bottom (LP: #719616)
    - Double-click on panel to unmaximize only works in right half
      (LP: #725529)
    - clicking multiple time on the bfb makes the logo darker and darker
      (LP: #727146)
    - the launcher should go away if it has been open using the keyboard and
      the mouse is not moved while the cursor is on it (LP: #727746)
    - migrate_favorites.py crashed with OSError in makedirs(): [Errno 13]
      Permission denied: '/home/aquarius/.local/share/unity' (LP: #723656)
    - No feedback when unmounting busy device in Unity (LP: #730638)
 -- Didier Roche <email address hidden> Mon, 07 Mar 2011 19:10:27 +0100

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Vish (vish) on 2011-03-07
Changed in humanity-icon-theme (Ubuntu):
status: Incomplete → Invalid

I think I'm up to date, and this isn't fixed :-(

 status triaged

Mark

Changed in humanity-icon-theme (Ubuntu):
status: Invalid → Triaged
Vish (vish) on 2011-03-08
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in humanity-icon-theme (Ubuntu):
status: Triaged → Incomplete

If the patch here was the only change done for this bug, looks like the patch only changed schema and no new nautilus-home.desktop file was added ?

Just to clarify: the file nautilus-home.desktop is already built-in Ubuntu (on nautilus package). What I've done is change the *default* LauncherIcon to be nautilus-home.desktop (and not nautilus.desktop).

This means that your current account will not be changed (because nautilus.desktop is in your favorite list). Try to create a new user on your computer and you'll see that the default icon is now the home icon (that opens /home/<user>).

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in humanity-icon-theme (Ubuntu):
status: Incomplete → Invalid

Mark, but it's not a quite intrusive action simply change the favorite list of users?

Anyway, if this will be done, the action must be thinked very well. When (I mean, in which part of Unity loading) the icon will be changed? And if the user puts the nautilus.desktop icon on launcher again? Unity shouldn't modify it again. And probably there is some other points to think about.

Sebastien Bacher (seb128) wrote :

hum, Mark could you explain what is the issue? do you want migration code to be written which deal with natty alpha version updates to newer alpha versions?? we could do that but it seems we would better work on fixing extra bugs that handling cosmetic details for earlier testers

Fair point. Please file a separate bug on the pointer-on-icon icon.

Not sure if there is a misunderstanding there Mark, the launcher configuration has been changed to list "nautilus-home.desktop" which is a nautilus launcher which has some settings:

"Name=Home Folder
Comment=Open your personal folder
Icon=user-home"

The icon used is "user-home" which is the home directory one so the pointer-on-icon should be resolved?

Sebastien Bacher (seb128) wrote :

some settings -> those settings

Vish (vish) wrote :

The pointer-on-folder icon will be resolved once humanity-icon-theme (0.5.3.5) hits the archives.

Changed in unity-2d:
status: Triaged → Fix Committed
milestone: none → 3.8
assignee: nobody → Florian Boucault (fboucault)
Changed in unity-2d:
status: Fix Committed → Fix Released
Mark Shuttleworth (sabdfl) wrote :

Sorry guys, but the home folder icon is just not good enough.

Please can we have a folder with a home on it, which follows the pattern established in the Humanity icon theme folder-recent.svg and folder-ubuntu.svg, which I attach as examples. The "big orange home" in user-home or folder-home is NOT A FOLDER and does not look like a folder and therefor does not fix the bug.

Also, we need the File Manger icon to look like a variation on a set-of-folders, NOT a filing cabinet.

Changed in humanity-icon-theme (Ubuntu):
status: Invalid → Confirmed
importance: Medium → Critical
Mark Shuttleworth (sabdfl) wrote :

I'm marking this critical because this is the TOP item on the launcher for EVERY new user, and currently the icon fails to convey it's intended meaning.

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Mark Shuttleworth (sabdfl) wrote :

Reopening on Unity for desktop team visibility till it is fixed.

Mark Shuttleworth (sabdfl) wrote :
Vish (vish) wrote :

Explained the icon changes on their respective bugs:
Bug #737183 : Home Folder
Bug #689486 : File Manager icon(I just removed the confusing icon since neither of us had any better idea..)

Vish (vish) wrote :

I did think of doing File Manger icon as a bunch of folders; but that would basically be ripping of Windows Explorer's icon :-) > http://upload.wikimedia.org/wikipedia/en/9/92/Windows_Explorer_Icon.png

David Barth (dbarth) wrote :

Incomplete = blocked on design. I'll turn that in a UIF exception once we get the icon.

Changed in unity:
milestone: 3.6.2 → 3.8.4
status: Fix Released → Incomplete
Vish (vish) wrote :

Copy pasting from Bug #737183 since Mark seems to prioritize "message-rationale: Unity" bug mail... ;-)
=====
The fact that the /home/$USER is a folder is inconsequential,
the same way that / can also be considered a folder inside the location computer:///
Or, the way any partition or external-media-device is a folder in /media .
And we dont etch a partition/device on a folder icon for either of them even though they are folders within a higher folder hierarchy. They are each Top levels for that location.

No one wants to interact _with_ the Home(folder) , they want to interact with files or folders _inside_ Home . Further, so many actions are not available for interaction on the /home/$USER folder. It is better we differentiate it like how we differentiate the / and other devices.

At a time when we are trying to move away from the hierarchal arrangement of folders, It is to eliminate that Home is a folder metaphor and to treat it as a higher level location like / or /media/$foo where folders exist.
It is to show that Home is a similar higher level place where user just has _their_ folders or files .

This icon change is inline with nautilus design specification for a "Consistent name for home", which calls for the use of name "Home" everywhere(not Home folder). I would rather like to see *some* attention focused on improving the user experience > Bug 372703 , we have a completed design specification and a patches in bugzilla and it has recently been fixed upstream too. But still we have been sitting on it since Karmic.
====

However, If you dont like the current icon, I could work on iterations which do not require showing the folder metaphor... :-)
But I'm sorry Mark, I wont be adding a folder icon for user-home in Humanity. :-(

If you only require user-home to be shown as a folder icon; pls *kindly* add it to ubuntu-mono which is set as the default icon theme for Ubuntu.
I'm moving the task to ubuntu-mono where the change can be done.

Changed in humanity-icon-theme (Ubuntu):
importance: Critical → Wishlist
status: Confirmed → Opinion
affects: humanity-icon-theme (Ubuntu) → ubuntu-mono (Ubuntu)
Changed in ubuntu-mono (Ubuntu):
importance: Wishlist → Critical
status: Opinion → New
Vish (vish) wrote :

This is same in launcher too: even "Trash" is a nautilus folder, and clicking on the monochrome-trash icon on launcher brings up the nautilus trash *folder*. But we dont show trash as a folder either.. :-)

Vish (vish) wrote :

(just a note: That ^ "No" is from the only remaining Humanity author who has _always_ been willing to change icons as per design team's suggestions) was not easy for me either, to say No to Mark. :s

I think there is nothing more to do on unity. The unity task is already fix release.

OK, thanks for the copy-paste, I'll reply on the humanity-icon bug.

I respect the Humanity icon theme designer's preference to design
Humanity icons the way they feel it's best. Nevertheless, I'd like this
changed in ubuntu-mono so that it's fixed for all Ubuntu users by
default. The icon should be a folder, with the home on it.

Please update the bug tasks accordingly, and let me know who's tackling
it in ubuntu-mono.

Mark

I think the options here are:

  a. Forward port the previous Folder-with-home from Humanity into unity-assert-pool/unity-icon-theme.
  b. Forward port the previous Folder-with-home from Humanity into ubuntu-mono.

  c. From-scratch design a symbolic Folder-with-home and put into unity-asset-pool/unity-icon-theme.
  d. From-scratch design a symbolic Folder-with-home and put into ubuntu-mono.

What's the preference here?

Changed in ayatana-design:
status: New → Incomplete
Paul Sladen (sladen) wrote :

Clarified with Mark: both the Filing Cabinet in the Unity Launcher and the icon seen when doing `nautilus /home` should be an orange folder with a house:

Proposed icon (thanks to the speedy work of Vish) pushed to:

  http://bazaar.launchpad.net/~ubuntu-art-pkg/ubuntu-mono/trunk/files/head:/ubuntu-mono-dark/places/48/ (click the download arrow on the right-hand-side)

Changed in ayatana-design:
status: Incomplete → In Progress
Changed in ubuntu-mono (Ubuntu):
status: New → In Progress
assignee: nobody → Vish (vish)
milestone: none → ubuntu-11.04-beta-2
Changed in ayatana-design:
milestone: none → beta
Paul Sladen (sladen) wrote :

For the filing cabinet which is currently coming from:

  /usr/share/icons/gnome/48x48/apps/system-file-manager.png

pushing a 'system-file-manager' icon to 'unity-asset-pool'/'unity-icon-theme' should cause it to be overridden when used by (just) Unity. Alternatively, we could patch 'nautilus.desktop' to point to another icon:

  $ grep Icon /usr/share/applications/nautilus.desktop
  Icon=system-file-manager

or point to something other than 'nautilus.desktop'.

Paul Sladen (sladen) wrote :

Nota Bene to above. Compositing the Folder and House from Humanity elements probably creates a combined work. I believe Unity Asset Pool currently requires copyright assignment.

Copyright assignment would require removing the copyright ownership from the Humanity/Tango authors (GPLv2/PD/GPLv3) before attempting to insert the result into the Ubuntu-Mono (CC-BY-SA-3.0) and Unity Asset Pool (CC-BY-SA-3.0 CAA Canonical).

I have filed a request with Legal, about whether the icons, as "simple geometric shapes" are insignificant enough to fall outside copyright, in which case there would not be a problem, as the copyright would not need to be transferred.

(FWIW, to my knowledge all of the authors are perfectly comfortable for their work to be used and under whatever licence is required).

Vish (vish) wrote :

Also to note that Tango authors have noting to do with the Humanity folders, they are attributed in Humanity for other icons we may have used in the earlier releases of Humanity.

And as the only person actively involved and in-charge of Humanity I dont mind if they are copied.. And i dont plan on going crazy over licenses ever (never understood them and dont plan to think about it.. ) ;p

I don't think the generic "file manager" icon should have a home on it.
I think the icon on the launcher by default should be the "home folder",
not "file manager".

On Mon, 2011-04-04 at 20:24 +0000, Mark Shuttleworth wrote:
> I don't think the generic "file manager" icon should have a home on it.

Cool! then that should solve Paul's worry about the copyright and unity asset pool..

Paul Sladen (sladen) wrote :

Vish: sadly, the opposite. It means that the reference in 'nautilus.desktop' to 'Icon=system-file-manager' needs to be overridden (for Unity Launcher only); so that means putting an icon named 'system-file-manager' into 'unity-icon-theme'.

Or coming up with new names, or new symlinks, or whipping up from-scratch a non-derived icon.

Vish (vish) wrote :

Paul, ah! OK. My understanding was that if something from Humanity was being included, in unity-asset-pool to *hardcode* for the filemanager icon, there is this copyright problem. And thought that since Mark dint want the Home+folder icon from Humanity it wasnt an issue now.

We are yet to come up with an acceptable generic icon for filemanager, and that new icon would not have anything to do with Humanity. Maybe we can use the old Unity places folder icon(it is already be in asset pool > browser.svg in http://bazaar.launchpad.net/~unity-team/unity-asset-pool/trunk/files/head:/unity-icon-theme/places/svg/).
( not sure if it is any better than cabinet though...)

Vish (vish) wrote :

We could just draw the background orange; we'd be using unity-icon-theme and this was once an accepted icon for the Places launcher..

Changed in unity-2d:
status: Fix Released → Incomplete
Didier Roche (didrocks) on 2011-04-05
Changed in unity:
status: Incomplete → Confirmed
Changed in unity-2d:
status: Incomplete → Confirmed
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Martin Pitt (pitti) wrote :

When I start nautilus I get a gray closet icon without a pointer; was that fixed and the bug not updated, or am I seeing something else?

You are seeing the hideous File Manager icon. We should have a
folder-with-home icon, which opens in ~/

Mark

Paul Sladen (sladen) on 2011-04-11
summary: - Icon in Launcher should be home folder icon
+ UIFe: Icon in Launcher should be home folder icon
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
Paul Sladen (sladen) wrote :

Pushed the Nautilus side (Humanity-style icon into Ubuntu-Mono): [ubuntu/natty] ubuntu-mono 0.0.28 (Waiting for approval)

Pitti: the Unity Launcher part still needs doing into unity-asset-pool, so that it overrides what Nautilus looks like when on the Launcher (anything better than the original dull grey filing cabinet from 'gnome-icons') but doesn't override it in the rest of the system.

Changed in ubuntu-mono (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-asset-pool (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Paul Sladen (sladen)
milestone: none → ubuntu-11.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.28

---------------
ubuntu-mono (0.0.28) natty; urgency=low

  [K.Vishnoo Charan Reddy]
  * User-home should be folder. (LP: #721121)

  [Olivier Tilloy]
  * Removed a suspicious 'fill="none"' attribute from some paths in the
    start-here icons, this was resulting in fully transparent rendering
    with Qt’s SVG engine. (LP: #752607)
 -- Paul Sladen <email address hidden> Mon, 11 Apr 2011 11:24:58 +0100

Changed in ubuntu-mono (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-11
Changed in unity-asset-pool:
status: New → In Progress
Changed in unity-2d:
milestone: 3.8 → 3.10
Changed in unity-2d:
milestone: 3.10 → 3.8.4
Giovanni Mellini (merlos) wrote :

I have updated my system and still not seeing the Home Folder in my launcher.
I did a unity --reset command too

Didier Roche (didrocks) wrote :

Hey Giovanni,
The icons aren't reset on purpose with unity --reset, only the compiz configuration is.
You have unity --reset-icons to explicitly reset all icons that are in your launcher to the default.

Giovanni Mellini (merlos) wrote :

Tks Didier for suggestion, now launcher looks ok :)

Olivier Tilloy (osomon) wrote :

Confirming that with today’s round of updates, in Unity 2D the default icon for the home folder in the launcher is the desired home folder icon.

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) wrote :

This is already done as per: ubuntu-mono (0.0.28)

Changed in unity:
assignee: Marco Biscaro (marcobiscaro2112) → nobody
milestone: 3.8.8 → none
Changed in unity-asset-pool (Ubuntu):
status: In Progress → Invalid
Changed in unity-asset-pool:
status: In Progress → Invalid
Paul Sladen (sladen) on 2011-04-12
Changed in ayatana-design:
status: In Progress → Fix Released
Ahmet (dr-ahmet) on 2011-05-04
Changed in ayatana-design:
assignee: nobody → Ahmet (dr-ahmet)
assignee: Ahmet (dr-ahmet) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers