Dash view should use "Preferred Applications" icons where appropriate

Reported by kyleabaker on 2011-01-27
114
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity-2d
Critical
Olivier Tilloy
unity (Ubuntu)
Medium
Unassigned

Bug Description

The dash view should make use of the settings from Preferred Applications to show an appropriate icon for:
1. Browse the Web
2. Check Email
3. Listen to Music

This would mean that if the user changes their preferred web browser to Opera or Chrome (or some other alternative) that the dash icon would still be appropriate to their settings. This is also true with the email client being used and media player (for example if they set Rhythmbox back to default then a banshee icon is inappropriate).

The default applications can also be uninstalled, so having them hardcoded into the dash is is a bad idea anyway.

Changed in unity:
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-02-20
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
milestone: none → 3.6
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity-2d:
importance: Undecided → Medium
status: New → Triaged
Neil J. Patel (njpatel) on 2011-02-22
Changed in unity:
milestone: 3.6 → 3.4.6
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-02-24
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-02-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.6-0ubuntu1

---------------
unity (3.4.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dash times out (LP: #662618)
    - possible memory leak in compiz when using places, dashboard
      (LP:#720446)
    - compiz crashed with SIGSEGV in IconTexture::~IconTexture() (LP: #721907)
    - dash - search string not always taken into account (LP: #701569)
    - Unity allows you to Quit itself (LP: #705536)
    - invisible window border problems (LP: #710271)
    - Slowliness in the file places (LP: #710791)
    - add super shortcuts to the launcher - logic (LP: #721264)
    - key navigation doesn't activate trash, keys, expo or places
      (LP:#723141)
    - Super-shortcuts for apps, files, and workspace switcher (LP: #617356)
    - New launcher tile super key overlay aesthetic (LP: #646712)
    - add cursor-key navigation to quicklists (LP: #701543)
    - Super key should open Dash (LP: #706713)
    - Dash view should use "Prefferred Applications" icons where appropriate
      (LP: #708479)
    - some partitions appear with questionmark icon (LP: #710809)
    - Unity wrongly resizes thumbnails after first opening of Files place
      (LP:#721123)
    - Change the fading and showing curve effect when hovering the bfb
      (LP:#721125)
    - Recent files appear duplicated in the Dash (LP: #646758)
    - All Applications tab only shows first 100 applications (LP: #660979)
    - slide animation typo in unity configuration (LP: #723354)
    - Place icons should be in their respective packages (LP: #672447)
    - Trash right click menu is positioned incorrectly (LP: #718880)
    - Require to use gconf to check on unity and the panel-service if the
      accessibility should be enabled (LP: #723699)
  * debian/control:
    - dep on latest nux
 -- Didier Roche <email address hidden> Thu, 24 Feb 2011 20:16:29 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
tags: added: delta-with-3d
Florian Boucault (fboucault) wrote :

Related to bug #736097 and bug #730623

Changed in unity-2d:
importance: Medium → High
milestone: none → 3.10
Olivier Tilloy (osomon) wrote :

To get the desktop file corresponding to the preferred web browser application, we could use `xdg-settings get default-web-browser`. Unfortunately this won’t help for the other application families (photos, e-mail, music).

The following GConf keys are what unity uses to discover the preferred applications:

Browser: /desktop/gnome/applications/browser/exec
E-mail: /desktop/gnome/applications/calendar/exec
Music: /desktop/gnome/applications/media/exec
(Photos: no preference, hardcoded to shotwell in the code…)

kyleabaker (kyleabaker) wrote :

Its nice to see one of my bugs get fixed so quickly, though I filed it hoping to see my preferred Web browser appear in the Dash. I'm using Opera 11 and have selected it in Preferred Applications as my default web browser and it does not appear in Dash as Chromium and Firefox do when they are set as default.

Before I reopen this bug report, I'd like to find out if this is a problem with the way this feature was implemented (possibly hard coded to allow certain browsers) or if its a problem with the way that Opera is installed. Any ideas?

@Olivier Tilloy
I'm away from my Ubuntu computer at the moment, but will check those GConf keys for this Opera specific bug when I get home. Maybe that isn't being set properly for some reason with Opera?

Olivier Tilloy (osomon) wrote :

@kyleabaker: I had a look at unity’s code, and it appears that it first checks the value of the /desktop/gnome/applications/browser/exec GConf key, and if it’s invalid it falls back on a hardcoded whitelist of possible browsers (firefox, chromium-browser, epiphany-browser, midori), which doesn’t include opera.

kyleabaker (kyleabaker) wrote :

@Olivier Tilloy
It seems that unity's "check" on the value of the /desktop/gnome/applications/browser/exec GConf key is faulty. I've got gconf-editor open and watching the browser value change between "firefox", "/usr/bin/opera" and "/usr/bin/chromium-browser". All of those are valid.

Also, a hard-coded whitelist seems like a really bad idea. Technically, if you manually edited this value to equal the path to Terminal (just as an example) then it should fetch the terminal icon and launch a Terminal window, not ignore it and select from a deprecated "whitelist" list.

I wonder if I should reopen this so the value is correctly evaluated and used without a "whitelist".

Olivier Tilloy (osomon) wrote :

@kyleabaker: if the value of /desktop/gnome/applications/browser/exec isn’t picked up correctly, then that’s definitely a flaw in the implementation and you should indeed re-open the bug for unity developers to look into it.
Note that as I understand it, the whitelist mechanism is there only as a fallback, so if the primary mechanism worked as expected, one could set her "Browse the web" shortcut to launch a terminal.

Bill Filler (bfiller) wrote :

need to make sure unity-2d uses the same preferred apps specified by gconf keys

Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
importance: High → Critical

I think the solution for the icons is put generic icons, for example, a
world for browser, a music note for music, a stack of photos for photos, and
a stack of letters for mail :)

2011/3/29 Bill Filler <email address hidden>

> need to make sure unity-2d uses the same preferred apps specified by
> gconf keys
>
> ** Changed in: unity-2d
> Assignee: (unassigned) => Olivier Tilloy (osomon)
>
> ** Changed in: unity-2d
> Importance: High => Critical
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (741737).
> https://bugs.launchpad.net/bugs/708479
>
> Title:
> Dash view should use "Prefferred Applications" icons where appropriate
>
> Status in Unity:
> Fix Released
> Status in Unity 2D:
> Triaged
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> The dash view should make use of the settings from Preferred Applications
> to show an appropriate icon for:
> 1. Browse the Web
> 2. Check Email
> 3. Listen to Music
>
> This would mean that if the user changes their preferred web browser
> to Opera or Chrome (or some other alternative) that the dash icon
> would still be appropriate to their settings. This is also true with
> the email client being used and media player (for example if they set
> Rhythmbox back to default then a banshee icon is inappropriate).
>
> The default applications can also be uninstalled, so having them
> hardcoded into the dash is is a bad idea anyway.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/708479/+subscribe
>

I think we need dconf for full happy switcherooing between -gl and -2d.

Mark

Why Unity 2D isn't DConf based? :S
And... how configure unity 2D without a GUI?
El 30/03/2011 00:21, "Mark Shuttleworth" <email address hidden>
escribió:
> I think we need dconf for full happy switcherooing between -gl and -2d.
>
> Mark
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (741737).
> https://bugs.launchpad.net/bugs/708479
>
> Title:
> Dash view should use "Prefferred Applications" icons where appropriate
>
> Status in Unity:
> Fix Released
> Status in Unity 2D:
> Triaged
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> The dash view should make use of the settings from Preferred Applications
to show an appropriate icon for:
> 1. Browse the Web
> 2. Check Email
> 3. Listen to Music
>
> This would mean that if the user changes their preferred web browser
> to Opera or Chrome (or some other alternative) that the dash icon
> would still be appropriate to their settings. This is also true with
> the email client being used and media player (for example if they set
> Rhythmbox back to default then a banshee icon is inappropriate).
>
> The default applications can also be uninstalled, so having them
> hardcoded into the dash is is a bad idea anyway.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/708479/+subscribe

@Mark: yes, the task is tracked by bug #692965.

@Joaquin: the current behaviour in Unity, which will be replicated in Unity-2d, is to display the icons of the default applications (e.g. Firefox/Chromium/Epiphany… depending on the default browser). If no browser is present, the plan is to simply not display a "Browse the Web" icon at all (see comment #6 in bug #736097). The same applies for "View Photos", "Check Email" and "Listen to Music".

Olivier Tilloy (osomon) on 2011-03-30
Changed in unity-2d:
status: Triaged → In Progress
Changed in unity-2d:
milestone: 3.10 → 3.8.2
Olivier Tilloy (osomon) on 2011-04-04
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
Malin Bruland (malinkb) wrote :

I run unity 3.8.6-0ubuntu1 and when I change default browser to Opera, it dosen't change. If I change default musicplayer from Rhythmbox to Banshee, it chage shortcut.

kyleabaker (kyleabaker) wrote :

@Malin
Confirmed. We discussed this briefly above. I'm going to reopen this bug since its intended behavior differs for Opera and possibly others.

Changed in unity:
status: Fix Released → Confirmed
Malin Bruland (malinkb) wrote :

@kylebaker
Thank you.

Omer Akram (om26er) on 2011-04-16
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Ant Dickens (antonydickens) wrote :

Opera user who would like to be able to launch my default browser, Opera, from the Unity dash. Opera is set as default in Preferred Applications.

Olivier Tilloy (osomon) wrote :

@Antony: out of curiosity, does it work for you with Unity 2D? (it definitely should, but I don’t think Opera was specifically tested)

Hernando Torque (htorque) wrote :

@Olivier Tilloy: In Unity 2D, the browser item isn't shown at all in the Dash home screen. See attached screenshot.

Olivier Tilloy (osomon) wrote :

Thanks for the feedback Hernando. Could you please file another bug report to track separately the Opera issue?
The original issue tracked by this bug report is fixed (use the actual icons for the preferred applications), but somehow Opera isn’t found.

dep (matias-wilkman) wrote :

This is still an issue in 3.8.16-0ubuntu1~natty1. I have Opera set at the preferred application for Web and email, but the dash shows Firefox, or, if I uninstall it, Chrome. I've also set Opera as the default x-www-browser via sudo update-alternatives:
"x-www-browser - manual mode
  link currently points to /usr/bin/opera"

As of now, I've not tried with Unity2D.

Omer Akram (om26er) on 2011-09-24
Changed in unity:
milestone: 3.4.6 → backlog
Changed in unity (Ubuntu):
importance: Undecided → Medium
Carey Underwood (cwillu) on 2011-10-12
summary: - Dash view should use "Prefferred Applications" icons where appropriate
+ Dash view should use "Preferred Applications" icons where appropriate
Robert Roth (evfool) wrote :

As the original issue filed here (change icons to preferred applications in dash) has been fixed, this should be closed with Fix released. The issue related to opera not being recognized is tracked in bug #786870, so anyone interested in getting Opera properly work in the dash should follow that bug.

Omer Akram (om26er) on 2012-01-27
Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
milestone: backlog → none
assignee: Neil J. Patel (njpatel) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers