No unity board but White screen after GDM

Bug #638808 reported by PhuniX
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Mesa
New
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
mesa (Ubuntu)
Critical
Bryce Harrington
ubuntu-netbook-default-settings (Ubuntu)
Low
Unassigned

Bug Description

Following the update of Unity this morning (15-09-2010) , i can't load Unity after GDM. A blank screen appears instead ! No problem with desktop option.

http://paste.ubuntu.com/494295/
"""
...
Begin render texture tid b784f890 tex=31 w=256 h=256 refcount=1
Render to RGBA8 texture OK
Begin render texture tid b784f890 tex=43 w=1022 h=548 refcount=1
Mesa 7.9-devel implementation error: Bad renderbuffer format: 21
Please report at bugzilla.freedesktop.org
...
"""

7.8.2-2ubuntu2 - GOOD
7.9~git20100825-0ubuntu2 - GOOD
7.9~git20100903.a5fd0396 - GOOD
7.9~git20100904.20bf5037 - GOOD
7.9~git20100907.60fce154 - GOOD
7.9.0+git20100908.5ecd9c70-0ubuntu0~bwh1 - GOOD
7.9.0+git20100908.5ecd9c70-0ubuntu0~bwh2 - BAD
7.9.0+git20100908.5ecd9c70-0ubuntu0~bwh3 - GOOD
7.9~git20100908.5ecd9c70 - BAD
7.9~git20100909-0ubuntu1 - BAD
7.9.0+git20100913.e7eff0cf-0ubuntu0sarvatt - BAD (tested by Sarvatt)

Changed in mesa (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-10.10
status: New → Confirmed
Revision history for this message
Robert Hooker (sarvatt) wrote :

Can you please run apport-collect 638808 to attach your logs to this bug?

Revision history for this message
Dan Scott (danieljamesscott) wrote :

I'm seeing the same problem. I've tried to run 'apport-collect 638808' but it requires me to login using my browser, which can't be launched because Unity won't start. Is there a way to authenticate from the command line?

Revision history for this message
Robert Hooker (sarvatt) wrote :

comment out AutomaticLoginEnable=true in /etc/gdm/custom.conf if its enabled, and pick a normal gnome session instead?

Revision history for this message
PhuniX (xavierouvray) wrote :

Sorry but it don't want send a "apport-collect" , It say i don't have permission to do it and want apport a new bug !

Revision history for this message
Dan Scott (danieljamesscott) wrote : apport information

Architecture: i386
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386 (20100318)
MachineType: ASUSTeK Computer INC. 900
Package: mesa (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-21-generic root=UUID=8eb81644-45f9-4780-b861-cd34fa27214b ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-21.31-generic 2.6.35.4
Tags: maverick ubuntu-une maverick
Uname: Linux 2.6.35-21-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/03/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1006
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 900
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1006:bd03/03/2009:svnASUSTeKComputerINC.:pn900:pvr0405:rvnASUSTeKComputerINC.:rn900:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 900
dmi.product.version: 0405
dmi.sys.vendor: ASUSTeK Computer INC.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-21-generic

tags: added: apport-collected
Revision history for this message
Dan Scott (danieljamesscott) wrote : BootDmesg.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : DRM.card0.SVIDEO.1.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : GdmLog.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : GdmLog1.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : GdmLog2.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : Lspci.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : Lsusb.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : PciDisplay.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : ProcModules.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : RelatedPackageVersions.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : UdevDb.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : UdevLog.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : XorgLog.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : XorgLogOld.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : Xrandr.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : peripherals.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : setxkbmap.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : xdpyinfo.txt

apport information

Revision history for this message
Dan Scott (danieljamesscott) wrote : xkbcomp.txt

apport information

Revision history for this message
David Barth (dbarth) wrote :

It's most probably due to this mesa bug: https://bugs.edge.launchpad.net/ubuntu/+source/mesa/+bug/638725
Feel free to re-open if the upcoming mesa fix doesn't solve the problem.

Changed in unity:
status: New → Invalid
Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
description: updated
Revision history for this message
Bryce Harrington (bryce) wrote :

So if I gather right, this bug has been confirmed to occur:

7.8.2-2ubuntu2 - GOOD
7.9~git20100909-0ubuntu1 - BAD
7.9.0+git20100913.e7eff0cf-0ubuntu0sarvatt - BAD (tested by Sarvatt)

Revision history for this message
Vish (vish) wrote :

fix committed in ubuntu-netbook-default-settings (0.8.6) , it just needs to be build and will be released soon.
This is just a workaround for Unity to work.. mesa bug still exists.

Changed in ubuntu-netbook-default-settings (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Revision history for this message
Bryce Harrington (bryce) wrote :

The attached Xorg.0.log has the following backtrace:

[ 96.366] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 116.735]
Backtrace:
[ 116.736] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e83bb]
[ 116.736] 1: /usr/bin/X (0x8048000+0x5da8d) [0x80a5a8d]
[ 116.736] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x54440c]
[ 116.736] 3: /usr/bin/X (FreeClientResources+0xed) [0x808f04d]
[ 116.736] 4: /usr/bin/X (FreeAllResources+0x60) [0x808f120]
[ 116.736] 5: /usr/bin/X (0x8048000+0x1a5e6) [0x80625e6]
[ 116.736] 6: /lib/libc.so.6 (__libc_start_main+0xe7) [0x1dece7]
[ 116.736] 7: /usr/bin/X (0x8048000+0x1a191) [0x8062191]
[ 116.737] Segmentation fault at address (nil)
[ 116.737]
Caught signal 11 (Segmentation fault). Server aborting
[ 116.737]
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.

Revision history for this message
Bryce Harrington (bryce) wrote :

Sarvatt says the above backtrace is a known but unrelated bug, something that happens on shutdown only.

Revision history for this message
papukaija (papukaija) wrote :

Looks like a duplicate of bug 638725

Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
description: updated
description: updated
description: updated
description: updated
Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
description: updated
Revision history for this message
Bryce Harrington (bryce) wrote :

Fixed in mesa_7.9~git20100909-0ubuntu2. Confirm please.

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Bryce Harrington (bryceharrington)
Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

Bryce, nicely bisected! However, with a fully up to date including mesa 7.9~git20100909-ubuntu2 I still see the problem on Intel N10 if I remove the CLUTTER_VBLANK=none from /etc/X11/Xsession.d/80clutter_vblank_none (the workaround).

Changed in mesa (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Bryce Harrington (bryce) wrote :

Btw, make sure to restart X (e.g. `sudo service gdm restart` would do it). I found this resolved the white screen issue, but it is possible there are subsequent usage issues.

Mark, some further info I've gleaned. The root cause here actually is not a bug in X, but rather that clutter has been depending on a bug in mesa which was fixed in mesa 7.9. My bisection work actually just restored the buggy code that clutter depends on.

The proper fix is to fix Clutter... Specifically https://bugs.edge.launchpad.net/ubuntu/+source/clutter-1.0/+bug/632352 needs to be resolved.

As I understand the bug, Mesa 7.8 would spam event notifications to all clients regardless of whether they wanted them. Clutter used this to do its updates. In Mesa 7.9, it changed to only send notices to clients that registered interest in them. Since clutter doesn't register interest, it doesn't get updated, so you just see a white screen. The patch in bug #632352 enables clutter to request these updates. The "fix" I uploaded causes mesa to resume its old spammy behavior.

Revision history for this message
Chris Halse Rogers (raof) wrote :

I think this is actually bug #632352 in clutter. I've pushed a package to https://edge.launchpad.net/~raof/+archive/aubergine for testing.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-netbook-default-settings - 0.8.7

---------------
ubuntu-netbook-default-settings (0.8.7) maverick; urgency=low

  * 80clutter_vblank_none
    - Dropped work around for mesa bug, fixed in latest mesa and
      clutter (LP: #638808)
 -- Ken VanDine <email address hidden> Thu, 16 Sep 2010 09:15:21 -0400

Changed in ubuntu-netbook-default-settings (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Chris Halse Rogers (raof) wrote :

This bug was fixed in the package clutter-1.0 - 1.2.12-0ubuntu12

---------------
clutter-1.0 (1.2.12-0ubuntu12) maverick; urgency=low

  * debian/patches/always_select_glx_events.patch:
    - Patch taken from upstream git to fix clutter with mesa 7.9 which
      (correctly) only delivers swap_event events when the client has asked
      for them. (LP: #632352) (LP: #638808)
 -- Christopher James Halse Rogers <email address hidden> Tue, 31 Aug 2010 16:16:09 +1000

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers