can't take screenshot when menu on panel is opened

Bug #29894 reported by Ramon de Ruiter
516
This bug affects 97 people
Affects Status Importance Assigned to Milestone
GNOME Panel
In Progress
Wishlist
Unity
Triaged
Low
Unassigned
gnome-panel (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-screenshot (Ubuntu)
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

I can always press the "Print screen" key to take a screenshot of my desktop. When i click on say, the System menu in the gnome-panel, it just doesn't work anymore.

Note: this is in fact only a symptom of bug 10905 that states that no hotkeys/shortcuts whatsoever can be triggered when a menu is open. there seems to be a dispute if that is a bug or an intended design decision. thus bug 10905 and its duplicates always get closed. people seem to agree that not being able to take screenshots is not intended bahavior and considered a bug. thus this report is allowed to stay open :)

a known workaround for taking screenshots of menus is to directly launch the screengrabber with a delay like so:
gnome-screenshot --delay=5

Revision history for this message
Manu Cornet (lmanul) wrote :

Same issue here. Changing severity to minor, though.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's not a bug, GTK needs the keyboard events for the menu accelerators by example so GNOME doesn't get them. you can use gnome-screenshot --delay= for that

Changed in gnome-utils:
assignee: nobody → desktop-bugs
status: Unconfirmed → Rejected
Revision history for this message
Jakob Unterwurzacher (jakobunt) wrote :

Upstream thinks it's a bug ( http://bugzilla.gnome.org/show_bug.cgi?id=144907 ) - IMO we should agree.

Changed in gnome-utils:
status: Invalid → New
Changed in gnome-utils:
status: Unknown → In Progress
Changed in gnome-utils:
status: New → Triaged
Revision history for this message
Derek White (d-man97) wrote :

Correction: NO keyboard shortcuts work when the menu is open, not just Print Screen. Description update needed?

Revision history for this message
Derek White (d-man97) wrote :

Something interesting that I found...

One thing that does work:
Open Firefox, Hit Alt-F (To open file menu), then hit Alt-Tab.
As soon as Alt is hit, the menu closes so the following -Tab, -E, -V, etc. still work.

I assume this is a work-around that Firefox programmed in? Why can't that also be added in for all GTK+ programs? If a menu is open, and the Alt key is pressed/held down, the menu exits. Sounds simple :)

Michael Nagel (nailor)
description: updated
Revision history for this message
dinamic (dinamic6661) wrote :

Same issue here. 10.04

Changed in gnome-utils (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

don't change bug settings if you don't know what you are doing, triaged means confirmed and having enough informations which is obviously correct there

Changed in gnome-utils (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
dinamic (dinamic6661) wrote :

isn't it "confirmed" the same thing?
Confirmed: a member of the community other than the original reporter believes that this report describes a genuine bug in enough detail that a developer could start work on a fix.

sorry i'm new to Launchpad

Revision history for this message
Michael Nagel (nailor) wrote :

@dinamic: no, not exactly, look at https://help.launchpad.net/Bugs/Statuses

triaged means confirmed by someone "important" and the underlying cause has been figured out. confirmed only means that someone was able to reproduce the problem. so triaged is one step "further"...

Revision history for this message
dinamic (dinamic6661) wrote :

i feel so unimportant right now :(( (joke)
when the triaged is selected the confirmed option shoud be unselectable by "unimportant" users X-)

Revision history for this message
KaOSoFt (maxzagato) wrote :

I'm new to any Linux-related topic, but if this means any kind of conflicts between people in the community, at least its behavior should be "toggeable". Thanks!

Revision history for this message
Noel E. (noelesp) wrote :

Unable to take screen shot when a menu is open e.g Applications

Changed in gnome-utils:
importance: Unknown → Wishlist
Revision history for this message
Paul Sladen (sladen) wrote :

Adding a Unity task; it's a biggie to fix, but with some focus might be possible.

Revision history for this message
Omer Akram (om26er) wrote :

the think to notice here is that this was not an issue with mutter version of Unity. I guess the implementation of menus in that case was working around this problem. also bug 722082 might have the same cause and seems to be targeted for unity 3.8

Alex Launi (alexlauni)
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Revision history for this message
typo (gnomeuser8) wrote :

I'm using gnome-panel and not Unity and I can confirm the same bug, that I can't take a screenshot, when I am in a menu of the panel. I experienced this bug when I was trying to report bug #768509.

Revision history for this message
Domar (domar) wrote :

Same thing here with Ubuntu 11.04 and unity...

Hope that this is going to be fixed soon!

Revision history for this message
Brendan Donegan (brendan-donegan) wrote :

Still the case in Oneiric

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in unity (Ubuntu):
importance: Undecided → Low
Revision history for this message
manny (estelar57) wrote :

a workaround might be that "PrtSc key" always opens the screenshot tool MAIN interface.

that way users can set the delay and various other options.

http://imagecdn.maketecheasier.com/2008/11/gnome-screenshot.jpg
http://www.myapitips.com/wp-content/uploads/2011/03/Screenshot-2.png

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

I'm also getting this issue in Oneiric, which I just checked out after seeing http://askubuntu.com/questions/72208/print-screen-key-doesnt-work-if-a-drop-down-menu-is-active . Interesting to note is that the Print Screen key works if menus on the top panel in GNOME Shell are open. I haven't checked to see whether this is a problem with Unity yet, though.

I also just took a look at the upstream bug out of curiosity, and I don't see any attention paid to it for over 2 years now.

Revision history for this message
edjash (edjash) wrote :

When I press the Print Screen key in Chrome web browser, I cannot take a screen shot if a menu is open.

It is not just menu's. I am developing a chrome extension that opens a HTML window, there are no key bindings for this but a screenshot cannot to be taken unless that overlay is closed.

I don't see why the PRINT SCREEN key is important for accelerators, it's not a key that usually has any other function other than printing the screen, indeed that is the primary function which is being blocked.

Omer Akram (om26er)
Changed in unity:
importance: Undecided → Low
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: In Progress → Triaged
Revision history for this message
Hanine HAMZIOUI (hanynowsky) wrote :

Meanwhile, we're using Shutter (An application for advanced desktop screenshots http://shutter-project.org/ ) to take screenshots.

Ubuntu 11.10 and 12.04 BEta 1 are also affected. Only occurs in Unity.

Revision history for this message
Alan Morgan (alanmorgan) wrote :

In the small chance the bug-fixing people aren't aware, it's the case with quicklists as well.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I agree, menus should ignore keys that are not accelerators, or Esc/Enter. It is a general problem and is still open in bug 10905, so I think this should be a duplicate of that.

Changed in hundredpapercuts:
milestone: none → quantal-5-unity
assignee: nobody → Papercuts Ninja (papercuts-ninja)
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue there is an hard technical problem going down to the way x11 is working (there is a reason it didn't get fixed in all those years), doesn't look like a papercut bug...

no longer affects: hundredpapercuts
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
typo (gnomeuser8)
affects: gnome-shell → gnome-shell (Ubuntu)
Revision history for this message
Andrea Corbellini (andrea.corbellini) wrote :

Are we sure the cause of this bug are the various shells? As Sebastien said, this looks to me as an Xorg bug. Could somebody with more knowledge than me provide feedback, please?

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Brandon Schaefer (brandontschaefer) wrote :

With bug 10905 fix, and the fix overall being that the menus are closed when a hotkey is pressed. So this bug is still valid, if there is a fix else where and they start seeing the menu close, take a look at bug 10905. Shouldn't be to hard to ignore the print screen button if a fix lands anywhere else.

Mathew Hodson (mhodson)
affects: gnome-utils → gnome-panel
affects: gnome-utils (Ubuntu) → gnome-panel (Ubuntu)
Revision history for this message
Seb Bonnard (sebma) wrote :

Hi,

This bug affects me in both XFCE and KDE environments.
I have not tried in LXDE yet but I am about to try.

This issues is been opened in 2006, can you please change the severity to "Medium" or "High" so that someone help us ?

Sebastien.

Revision history for this message
Seb Bonnard (sebma) wrote :

BTW : I'm Using Ubuntu 14.10.

LXDE does not have this pb. since the PrintScreen triggers the scrot program that generates the screenshot in my home directory.

Sebastien.

Revision history for this message
Robert Hönig (indielives010) wrote :

This bug was fixed with the fix of bug #10905. Also, it is not possible to reproduce it given the instructions: Taking a screenshot with the PrtSc-Key works now even with gnome-panel opened.

Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-screenshot (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
bojojo@orange.fr (bojojo-orange) wrote :

"[Bug 29894] Re: can't take screenshot when menu on panel is opened"
typo doc

Revision history for this message
sergeos (sergeos) wrote :

I have this issue in Ubuntu 18.04 (X) when trying to take a screenshot of an application with a menu open.
Tried to add custom shortcuts like gnome-screenshot -w --delay=3 but it still wouldn't work

Revision history for this message
Jeroen (jeroenst) wrote :

Today I wanted to make a screenshot on Ubuntu 18.04.1 LTS with a menu open but it still fails and the issue still persists.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.