Unity 14.04 Lock button sometimes takes 30~60s to enter lock screen

Bug #1398287 reported by Franz Hsieh on 2014-12-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
7.2
Fix Released
Medium
Stephen M. Webb
unity (Ubuntu)
Medium
Andrea Azzarone
Nominated for Trusty by Stephen M. Webb
Trusty
Medium
Stephen M. Webb

Bug Description

[Impact]

When the power button is pressed, the shutdown dialog will be displayed. Then clicks the 'Lock' button in the shutdown dialog and it sometimes takes about 30~60s to lock screen. This happens on many Intel-only platforms.

PS: If user moves the cursor out of the dialog window after clicking the 'Lock' button, it will switch to lock screen immediately.

[Test Case]

See description under "Impact' above.

[Regression Potential]

The fix for this problem involves releasing the grab on the input devices earlier in the sequence, allowing the animation sequence to begin immediately without a grab-release timeout. It is unlikely that this could introduce any regressions.

[Other Info]

This fix was cherry picked for Ubuntu 14.04 LTS from the Ubuntu "Vivid Vervet" dev release where it has been in test for some time without incident.

Related branches

Andrea Azzarone (azzar1) wrote :

What you mean for HUD?

Changed in unity:
status: New → Incomplete
Franz Hsieh (franz-hsieh) wrote :

@Andrea

I do not know its exactly name, I posted the screenshot.

Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2014-12-03
Changed in unity:
status: Incomplete → New
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
importance: Undecided → High
Andrea Azzarone (azzar1) on 2014-12-03
description: updated
Andrea Azzarone (azzar1) on 2014-12-05
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: lockscreen
Andrea Azzarone (azzar1) on 2014-12-05
Changed in unity:
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) wrote :

I managed to reproduce it but just not every time. Do you have a reliable way to reproduce it?

Andrea Azzarone (azzar1) wrote :

Btw this is due to the way nux animation and compiz work. Basically can happen that an animation start later because the screen is truely idle. In this case the grab will be released later and the lockscreen will be delayed. The best way to fix this bug is to call cscreen->damagePending() as soon as we start a nux::animation.

Stephen M. Webb (bregma) on 2014-12-15
Changed in unity:
milestone: none → 7.3.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20141216-0ubuntu1

---------------
unity (7.3.1+15.04.20141216-0ubuntu1) vivid; urgency=low

  [ Stephen M. Webb ]
  * replace the use of static glib with gi glib in AP test cases (LP:
    #1397006)
  * fix AP test failures due to upstream FileRoller .desktop file rename
    (LP: #1402707)

  [ Andrea Azzarone ]
  * Set the correct size for the lockscreen message. (LP: #1384242)
  * Ungrab the shoutdown dialog as soon as possible. (LP: #1398287)
  * skipped the animation of BGHash on startup to prevent unwanted fade-
    in (LP: #1241757)
 -- Ubuntu daily release <email address hidden> Tue, 16 Dec 2014 13:25:57 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Franz Hsieh (franz-hsieh) wrote :

@Andrea

Thanks for your help and patch.

@janitor

Will this package be available on -trusty ?

Nekhelesh Ramananthan (nik90) wrote :

@franz, It will be released to trusty in Unity version 7.2.4 SRU as can be seen at the top of this bug report. The exact ETA is however unknown.

Franz Hsieh (franz-hsieh) wrote :

Unity 7.2.4+14.04.20141217-0ubuntu1 is now available on trusty-update, after some tests I confirmed this issue has been fixed.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.2 → 7.3.1
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-03-17
description: updated
Changed in unity (Ubuntu Trusty):
status: New → In Progress
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium
assignee: nobody → Stephen M. Webb (bregma)

Hello Franz, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20150316-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

I've only checked it in VirtualBox but Franz Hsieh the original bug reporter mentioned earlier in comment #9 that this was fixed.

The locking isn't immediate but it happens after about 5 seconds so it's a good response time from GUI.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20150316-0ubuntu1

---------------
unity (7.2.4+14.04.20150316-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Avoid running potentially dangerous code paths when the screen is
    locked. (LP: #1410582)
  * Ungrab the shoutdown dialog as soon as possible. (LP: #1398287)
  * Use COMPIZ_METAKEY where needed. (LP: #1363534)
  * disabled Pointer Barriers during lockscreen (LP: #1401911)
  * disabled markup for VolumeLauncherIcon quicklist menu items (LP:
    #1413411)
  * enable Dash, Hud, and session dialogs over full screen window (LP:
    #1159249, #860970, #1413773, #1404486)
  * made unity unlockable if user is in nopsswdlogin group (LP:
    #1413790)
  * skipped the animation of BGHash on startup to prevent unwanted fade-
    in (LP: #1241757)

  [ Luke Yelavich ]
  * extended accessible exploration of the Dash dynamic content (LP:
    #1066157)

  [ Marco Trevisan (Treviño) ]
  * MenuManager: make sure menus are always shown when mouse is over
    them or when the always-show-menus option is on (LP: #955193,
    #1390562, #1374942, #1312137)
  * PanelService: use gdbus to notfy upstart of service start/stop (LP:
    #1302955)
 -- CI Train Bot <email address hidden> Mon, 16 Mar 2015 17:30:35 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments