The dash closes when trying to switch from Command lens to home lens

Bug #1108956 reported by Romain Perier on 2013-01-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Unity
Low
Brandon Schaefer
7.2
Low
Brandon Schaefer
unity (Ubuntu)
Low
Brandon Schaefer

Bug Description

When I open the command lens by pressing ALT+F2, if I press "Super" the dash is closed. It should not be closed, it should switch to the home lens instead. This is the suite of the bug 1019457

Related branches

lp:~rperier/unity/command-lens-switching
Superseded for merging into lp:unity
Łukasz Zemczak: Needs Fixing on 2013-02-01
lp:~brandontschaefer/unity/lp.1108956-fix
PS Jenkins bot: Approve (continuous-integration) on 2013-04-02
Andrea Azzarone: Approve on 2013-04-02
Łukasz Zemczak: Pending requested 2013-03-29
lp:~brandontschaefer/unity/lp.1108956-fix-again
On hold for merging into lp:unity
Marco Trevisan (Treviño): Approve on 2013-04-16
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-04-13
lp:~brandontschaefer/unity/command-to-dash-fix
Stephen M. Webb: Approve on 2015-04-10
PS Jenkins bot: Approve (continuous-integration) on 2015-03-31
Christopher Townsend: Approve on 2015-03-31
Romain Perier (rperier) wrote :

What I suggest:

1. Put LensBar::getActiveLensId() public
2. Use the previous method to get the current lens id from dash/DashView.cpp:OnActivateRequest
3. If the dash if visible && the event is of type NOT_HANDLED && the new lens id is != the current lens id : switch to the lens instead of closing the dash, otherwise close the dash.

Changed in unity:
assignee: nobody → Romain Perier (rperier)
John Lea (johnlea) on 2013-01-31
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
tags: added: udp
Changed in unity:
importance: Undecided → Low
Changed in unity:
status: New → Fix Committed
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
status: Fix Committed → In Progress
milestone: none → 7.0.0
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
assignee: Romain Perier (rperier) → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.04.05.2-0ubuntu1

---------------
unity (7.0.0daily13.04.05.2-0ubuntu1) raring; urgency=low

  * Revert r3266 "Don't close the dash when switching from the command lens
    to the home lens.", it's breaking dash closing for individual lens,
    which also result in a serie of failing tests (lp: #1164915)

  [ Stephen M. Webb ]
  * Bumped released version to 7.0.0

  [ Brandon Schaefer ]
  * Invalid Dnd is not being ingored in the launcher. (LP: #1163473)
  * Dash Overlay scrollbars should allow dragging, until the scrollbars
    themselfs hit the top/end of the track. (LP: #1163616)
  * [regession] Multi-monitor: Mousepointer hangs when passing between
    monitors, although no Launcher is there. (LP: #1161726)
  * The dash closes when trying to switch from Command lens to home lens
    (LP: #1108956)

  [ Chris Townsend ]
  * Need to tweak the icon glow for urgent apps (LP: #1163944)

  [ Andrea Azzarone ]
  * Window management - grab icons appear when using touchpad (LP:
    #1026712)

  [ Marco Trevisan (Treviño) ]
  * compiz crashed with SIGSEGV in
    sigc::internal::slot_call0<unity::launcher::VolumeImp::Impl::Impl()
    (LP: #1161916)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3279
 -- Ubuntu daily release <email address hidden> Fri, 05 Apr 2013 14:51:53 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Fix had to be reverted, as it causes a bunch of failing AP tests.

Changed in unity (Ubuntu):
status: Fix Released → In Progress
Changed in unity:
status: Fix Released → In Progress
milestone: 7.0.0 → 7.0.1
Stephen M. Webb (bregma) on 2013-08-21
Changed in unity:
milestone: 7.0.1 → 7.1.1
Stephen M. Webb (bregma) on 2013-10-10
Changed in unity:
milestone: 7.1.1 → 7.2.0
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Stephen M. Webb (bregma) on 2014-03-25
Changed in unity:
milestone: 7.2.0 → 7.2.1
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity:
milestone: 7.2.2 → 7.2.3
Changed in unity:
milestone: 7.2.3 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.04.20150410.1-0ubuntu1

---------------
unity (7.3.2+15.04.20150410.1-0ubuntu1) vivid; urgency=medium

  [ Brandon Schaefer ]
  * When we get a launcher key press (ie. super key). We check if the
    command lens is open. If it is then just switch the lens to the home
    lens. This way we dont close the dash. (LP: #1108956)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Gerry Boland ]
  * SwitcherController: add first selection mode property, to decide
    what to select at first (LP: #998285)

  [ Marco Trevisan (Treviño) ]
  * SwitcherController: add first selection mode property, to decide
    what to select at first (LP: #998285)
  * UnityScreen: terminate spread if active when initiating Switcher
    (LP: #1412001)

  [ Stephen M. Webb ]
  * (Ubuntu packaging) move the session migration scripts to Python3
    (LP: #1440560)
  * fixed the Panel title string expected by Launcher keynav AP tests
    (LP: #1435830)
  * test_wm_keybindings: fix AP failures caused by upstream Compiz
    change (LP: #1294864)
 -- CI Train Bot <email address hidden> Fri, 10 Apr 2015 21:59:12 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-04-13
Changed in unity:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers