Super key not registered if held too long

Bug #1097189 reported by Alan Pope 🍺🐧🐱 🦄 on 2013-01-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Łukasz Zemczak
unity (Ubuntu)
Medium
Łukasz Zemczak

Bug Description

In the latest daily PPA build of Unity..

Press super quickly and the dash appears
Hold down super for "too long" and it doesn't.

This is "too long"..

KeyPress event, serial 41, synthetic NO, window 0x4800001,
    root 0x297, subw 0x0, time 987630, (164,688), root:(219,740),
    state 0x0, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 41, synthetic NO, window 0x4800001,
    root 0x297, subw 0x0, time 987902, (164,688), root:(219,740),
    state 0x40, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

This is fast enough...

KeyPress event, serial 41, synthetic NO, window 0x4800001,
    root 0x297, subw 0x0, time 1036733, (197,791), root:(252,843),
    state 0x0, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 41, synthetic NO, window 0x4800001,
    root 0x297, subw 0x0, time 1036805, (197,791), root:(252,843),
    state 0x40, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 6.12.0daily13.01.07-0ubuntu1 [origin: LP-PPA-ubuntu-unity-daily-build]
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CrashDB: unity
Date: Tue Jan 8 09:01:39 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-01-02 (371 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Changed in unity:
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

I thought this was an intentional design decision. Unity still has a time limit because we can't always enable reliable tap detection on the Compiz side. And there was another good reason thumper had for keeping the time limit even when Compiz did have tap detection on.

Changed in unity:
status: In Progress → Incomplete
Didier Roche (didrocks) wrote :

After a discussion on IRC, we'll reset it to 250ms, we have 5 people who thought that was a bug due to a too short limit constraint.

Changed in unity:
status: Incomplete → Triaged
Changed in unity:
status: Triaged → Fix Committed
Changed in unity:
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: New → Fix Committed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Łukasz Zemczak (sil2100)
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package unity - 6.12.0daily13.01.11.2-0ubuntu1

---------------
unity (6.12.0daily13.01.11.2-0ubuntu1) raring; urgency=low

  [ Didier Roche ]
  * debian/control:
    - bump some missed build-deps
    - bump compiz and nux build-deps for the API and ABI breakages
      (LP: #1095981)
  * debian/rules:
    - disable pch for now as it's not working with -g -02 (LP: #1095978)

  [ Brandon Schaefer ]
  * Ported Compiz to 0.9.9
  * debian/control:
    - bump the build-deps
  * Dash and HUD do not have X event focus, causing XIM to not work.
    (LP: #1086988)
  * Windows losing focus after the start/restart of Unity (LP: #1097368)

  [ Łukasz 'sil2100' Zemczak ]
  * Dash - Update Dash nav bar icons (LP: #1089373)
  * Autopilot tests failing in the test_hud suite due to locale
    dependency (LP: #1076531)
  * Super key not registered if held too long (LP: #1097189)
  * Unity HUD uses wrong icon when switching from the Dash to HUD (LP:
    #1089482)

  [ Marco Trevisan (Treviño) ]
  * Using bleeding edge Mesa drivers causes GL_INVALID_OPERATION error
    in glDrawBuffer / glReadBuffer (LP: #1092550)
  * [Regression] Window buttons / Title doesn't redraw correctly on
    windows with no menus (LP: #1090439)

  [ Nick Dedekind ]
  * Dash - When the Dash preview is open, the ghost images should run
    all the way to the top of the screen as shown in the design (LP:
    #1060948)
  * Dash - When the Dash preview opens, the category headers should be
    expanded and the filters should hide (LP: #1060937)
  * Dash - In the Dash preview, when a user moves to the next or
    previous preview the highlighted ghost image should change (LP:
    #1060941)
  * Dash - As soon as a user starts dragging a .png file from the Dash,
    the file icon changes size (LP: #863412)

  [ Gord Allott <email address hidden>, Łukasz 'sil2100' Zemczak <email address hidden>, Didier Roche ]
  * "unitydashlegalseen" Causing back-up error (LP: #1066646)
  * unity dash should show legal disclaimer (LP: #1065652)

  [ Manuel de la Pena ]
  * StaticCairoText makes NUX get into an infinte loop (LP: #1071327)

  [ Daniel van Vugt ]
  * Minimized windows don't restore, or restore as blank (LP: #1089779)

  [ Andrea Azzarone ]
  * TestOverlayScrollBar.TestScrollDownSignal segfaults (LP: #1089888)
  * Dash - Update Dash Launcher icon tooltip to say "Search your
    computer and online sources" (LP: #1090325)
  * TestLauncherController.GetLastIconPriorityUnStickyWithNoIconsAndUri
    segfaults (LP: #1089894)
  * TestDashController.TestShowAndHideDash fails (LP: #1089904)
  * [Regression] Tapping super key shows shortcuts overlay. (LP:
    #1090388)
  * [Regression] Unity fails to restore initially minimized windows.
    (LP: #1097686)
  * launcher does not show minimized update manager while clicked (LP:
    #1003950)
  * Dash - Update Dash Home search box hint message to say "Search your
    computer and online sources" (LP: #1090327)
  * can't quit a minimized application (LP: #1086366)
  * Unity daily-build (07.01.13) empty space between launcher and dash
    in non default launcher size (LP: #1097184)

  [ Sam Spilsbury ]
  * Fonts get chang...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers