[regression] Graphical glitches in HUD/Dash bottom left and top right corner

Bug #1060532 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Nicolas d'Offay
6.0
Fix Released
High
Nicolas d'Offay
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Running Unity 6.8 pre-release from ppa:unity-team/ppa and notice while autopilot was running that there are two graphical glitches in HUD.

See screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0+bzr2749stagingubuntu0+789 [origin: LP-PPA-unity-team]
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CrashDB: unity
Date: Wed Oct 3 00:51:14 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120102)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) on 2012-10-03
Changed in unity:
importance: Undecided → High
status: New → Confirmed
milestone: none → 6.8.0
Nick Dedekind (nick-dedekind) wrote :

Looks like it might affect the bottom right of the Dash. See screenshot.
Also, why is there no rounding on bottom left? Seems to be missing the rounding border that the Hud has.

Possibly something funky going on with the resources for those glitches.

Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Nick Dedekind (nick-dedekind) wrote :

Glitches caused by regression in the overlay render in r2774.

Dash right-corner glitch caused by changes for redirected rendering. Dash is being painted on top of overlay, causing square corner.

Thanks for bringing this to my attention Nick. Fix has been committed:

trunk @ lp:~nicolas-doffay/unity/low-gfx-mode.
6.0 @ https://code.launchpad.net/~nicolas-doffay/unity/blend-mode-bug-fix-6.0

Omer Akram (om26er) on 2012-10-03
summary: - Graphical glitches in HUD
+ [regression] Graphical glitches in HUD/Dash bottom left and top right
+ corner
Changed in unity:
milestone: 6.8.0 → 7.0.0
assignee: Nick Dedekind (nick-dedekind) → Nicolas d'Offay (nicolas-doffay)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers