[regression] Dash - Hitting enter after opening Lens or searching no longer opens first item

Bug #1041583 reported by Alan Pope ๐Ÿบ๐Ÿง๐Ÿฑ ๐Ÿฆ„ on 2012-08-25
86
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Michal Hruby
unity (Ubuntu)
High
Michal Hruby

Bug Description

In Quantal, press Super then search for "terminal".
Observe that the first hit in the first section "Applications" is indeed Gnome Terminal.
Press Enter

Terminal does not open, the first hit in the "Files" section opens.
This appears to be a change in behaviour from 12.04 where the application would start.

Alternative description:

When the Dash is opened or after typing a search query, pressing return should perform the equivalent action to left clicking on the very top left item in the results (underneath the top category header).

In Beta 1 of 12.10, pressing return after opening the Dash home launches the first item underneath the 'Files & Folders' category header, even though it is the second category header from the top.

---------------------------------------
Desired Resolution

- When the Dash is opened or after typing a search query, pressing return should perform the equivalent action to left clicking on the very top left item in the results (underneath the top category header).

Related branches

Seems to have gone away after a restart.

Changed in unity:
status: New → Invalid

Ok, I was wrong, it's intermittent, happens quite a lot.

Changed in unity:
status: Invalid → New
Timo Jyrinki (timo-jyrinki) wrote :

I'm seeing this as well, starting to type "com" (for compizconfig settings manager) and pressing enter results in /etc/compizconfig opened instead for me. This happens repeatedly.

Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2012-08-28
Changed in unity:
importance: Undecided → High
milestone: none → 6.4
assignee: nobody → Michal Hruby (mhr3)
Michal Hruby (mhr3) on 2012-08-28
Changed in unity:
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Update: Unity 6.4 is revision 2632, so this is actually fix committed for Unity 6.6.

Changed in unity:
status: Fix Released → Fix Committed
milestone: 6.4 → 6.6
Michal Hruby (mhr3) wrote :

And to add even more confusion, it's part of Ubuntu's 6.4.

John Lea (johnlea) on 2012-09-04
description: updated
tags: added: dashm udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in ayatana-design:
status: New → Fix Committed
John Lea (johnlea) on 2012-09-04
summary: - Dash home opens files by default, should be applications?
+ [regression] Dash - Hitting enter after opening Lens or searching no
+ longer opens first item
Rainer Rohde (rainer-rohde) wrote :

I experience the same. This was not the case with Unity 6.0.0 on Quantal alpha 3.

When using Unity via keyboard, e.g. hitting "super", then tying an application name, and hitting enter, Unity launches a totally unrelated app, instead of the one the search shows.

For example, I was typing "fire" in order to launch Firefox, and Firefox did show up correctly in the first position of the dash, however, when hitting enter, Nautilus launched instead.

The correct behavior, until recently, was that the application that pops up in the first place after typing parts of its name will launch when hitting enter.

This bug seems to just recently have appeared, since everything worked as expected before.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-09-06
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Michal Hruby (mhr3)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.4.0-0ubuntu6

---------------
unity (6.4.0-0ubuntu6) quantal; urgency=low

  * Backport a fix for [regression] Dash - Hitting enter after opening
    Lens or searching no longer opens first item (LP: #1041583)
 -- Didier Roche <email address hidden> Mon, 10 Sep 2012 11:33:32 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
milestone: 6.6 → 7.0
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Changed in unity:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers