The Dash closes when trying to switch to the Command lens (Alt+F2)

Bug #1019457 reported by Brandon Schaefer on 2012-06-30
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Romain Perier
unity (Ubuntu)
Medium
Romain Perier

Bug Description

When trying to switch from the Dash to the Command lens it closes.

How to reproduce:
1. Open the dash
2. Press Alt+F2

What happens:
Dash Closes

What should happen:
The Dash should not close, rather command lens should open

Related branches

description: updated
MC Return (mc-return) wrote :

I can confirm this bug.

Bilal Akhtar (bilalakhtar) wrote :

On further testing, this happens only with the command lens (alt+f2), not with the HUD.

Changed in unity:
status: New → Confirmed
importance: Undecided → Low
tags: added: bitesize
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Sami Jaktholm (sjakthol) wrote :

In theory solution to this bug would be to send 'dash::GOTO_DASH_URI' (3) instead of 'dash::NOT_HANDLED' (0) to the dash with the 'UBUS_PLACE_ENTRY_ACTIVATE_REQUEST' in 'UnityScreen::SendExecuteCommand' (plugins/unityshell/src/unityshell.cpp line 1773). The logic inside 'DashView::OnActivateRequest' (dash/DashView.cpp line 331) also supports this change: if dash is hidden (!_visible), the lens will be activated and dash shown; if dash is visible, the lens is activated inside last 'else if' clause. Right now only dash is hidden inside first 'else if'.

Regression potential should be very minimal as this is the way the other lens shortcuts are handled (Controller::CheckShortcutActivation in dash/DashController.cpp on line 343) and they seem to work fine.

However I can't test this right now in real world conditions so I'd rather not send a patch. Feel free to pick this up as this fix is really trivial and should only take few minutes...

ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DistroRelease: Ubuntu 13.04
InstallationDate: Installed on 2012-11-02 (5 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.2)
MarkForUpload: True
Package: unity 6.8.0-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Tags: raring running-unity
Uname: Linux 3.5.0-17-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

tags: added: apport-collected raring running-unity

apport information

apport information

Changed in unity (Ubuntu):
assignee: nobody → Michael Spencer (mdspencer)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: Michael Spencer (mdspencer) → nobody
status: In Progress → Confirmed
Omer Akram (om26er) on 2012-12-18
Changed in unity:
importance: Low → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
summary: - The Dash closes when trying to switch to the Command lens (Alt+F2)
+ [regression]The Dash closes when trying to switch to the Command lens
+ (Alt+F2)
description: updated
summary: - [regression]The Dash closes when trying to switch to the Command lens
- (Alt+F2)
+ The Dash closes when trying to switch to the Command lens (Alt+F2)
Romain Perier (rperier) on 2013-01-24
Changed in unity:
assignee: nobody → Romain Perier (rperier)
Changed in unity (Ubuntu):
assignee: nobody → Romain Perier (rperier)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: none → 7.0.0
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.02.04.1-0ubuntu1

---------------
unity (6.12.0daily13.02.04.1-0ubuntu1) raring; urgency=low

  * debian/control:
    - recommends indicator-sync so it gets installed by default
      (lp: #1053482)
    - recommends indicator-bluetooth as well (lp: #1111314)

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - bump compiz build-dep due to the last ABI break

  [ Brandon Schaefer ]
  * [regression] Clicking on the indicators when the Dash is open no
    longer closes the Dash. (LP: #1109150)
  * [staging][raring] Dash Maximise/Restore button depends on the
    launcher icon size. (LP: #1101310)

  [ Romain Perier ]
  * The Dash closes when trying to switch to the Command lens (Alt+F2)
    (LP: #1019457)

  [ Marco Trevisan (Treviño) ]
  * Launcher can have smaller size on monitor resolution change (LP:
    #1105382)
  * Dragging down a window from the panel on an external monitor,
    restores it at wrong offset (LP: #1104043)
  * [regression] Alt+Tab/Alt+grave brings other window to the front but
    loses focus entirely. (LP: #1111620)
  * Quicklist items need a way to be ellipsized (LP: #1111471)

  [ Charles Kerr <email address hidden>, Andrea Azzarone ]
  * the GObject subclasses in tests/ don't dispose() properly (LP:
    #986875)

  [ Nicolas d'Offay ]
  * Speed up dash blur (LP: #1102410)

  [ Manuel de la Pena ]
  * API changes to FindKeyFocusArea in the Preview class stops more
    complicated previous fom setting the correct focus (LP: #1102387)

  [ MC Return ]
  * Wrong description in Dconf key
    com.canonical.unity.launcher.favorites (LP: #1112560)
  * Keyboard shortcut overlay says Ctrl+Super+Down "minimises" the
    current window, but it doesn't (LP: #966099)

  [ Andrea Azzarone ]
  * unmounting any gvfs-mounted device from unity menu crashes compiz
    (LP: #1111389)
  * compiz crashed with SIGSEGV in async_wrapper_callback() from
    g_simple_async_result_complete() from
    _g_simple_async_result_complete_with_cancellable() from
    unmount_reply() (LP: #1102926)

  [ Łukasz 'sil2100' Zemczak ]
  * SwitcherControllerImpl autopilot test failures in unity -
    6.12.0daily13.01.29.2-0ubuntu1 (LP: #1109192)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3117
 -- Automatic PS uploader <email address hidden> Mon, 04 Feb 2013 09:59:13 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers