Nothing should be written into the dash/hud searchbar when holding super, ctrl or Alt

Bug #1013751 reported by Marco Trevisan (Treviño) on 2012-06-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Marco Trevisan (Treviño)
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
5.0
Fix Released
Medium
Marco Trevisan (Treviño)
nux (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Precise
Medium
Unassigned

Bug Description

[Test Case]
Case 1:
1) Open the dash or the HUD
2) Press the Super or Alt key
3) While holding a modifier, start writing something

Real result:
4) The pressed keys are written in the search bar.

Expected result:
4) Nothing should be written in the search bar

Case 2:
1) Open the dash or the HUD
2) Press the Ctrl key
3) While holding it, start writing something

Real result:
4) unknown symbols are written in the search bar

Expected Result:
4) Nothing should be written in the search bar

[Regression Potential]
Broken character input to the HUD and Dash.

Related branches

Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: 5.14.0 → 6.0
Changed in nux:
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nux:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 3.0.0-0ubuntu1

---------------
nux (3.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Conditional jump or move depends on uninitialised value(s)
      nux::GraphicsDisplay::ProcessXEvent(_XEvent, bool) (LP: #983321)
    - Coverity PW.PARAMETER_HIDDEN - CID 10653 (LP: #937588)
    - Coverity SECURE_CODING - CID 10659 (LP: #937564)
    - Coverity PW.PARAMETER_HIDDEN - CID 10651 (LP: #937576)
    - Coverity PW.PARAMETER_HIDDEN - CID 10652 (LP: #937586)
    - QueueDraw is very expensive (LP: #994884)
    - Unity is slow and pausing occasionally (when its DrawList size spikes,
      to almost 6000!) (LP: #1014610)
    - IBus hotkey using Release modifier doesn't work in unity (LP: #1016665)
    - Nothing should be written into the dash/hud searchbar when holding super,
      ctrl or Alt (LP: #1013751)
    - IBus can't be activated on dash or HUD since r2428 (LP: #1016354)
  * debian/control, debian/libnux-3.0-0.install,
    debian/libnux-3.0-common.install, debian/libnux-3.0-dev.install:
    - switch to nux-3.0
 -- Didier Roche <email address hidden> Tue, 10 Jul 2012 08:53:00 +0200

Changed in nux (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu Precise):
importance: Undecided → Medium
status: New → In Progress

Hello Marco, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Doesn't seem fixed to me. On my laptop with an external keyboard if I do:-

Tap and release alt
Press and hold alt
Start typing

Result: The text appears in the HUD. See screenshot

description: updated
Łukasz Zemczak (sil2100) wrote :

After a discussion with Marco, it seems that this bug is not fixed by the unity SRU that has been prepared.

The reason is that a unity fix itself is not sufficient to fix this issue without breaking ibus support. A change in nux is also required. The committed nux fix is not easily-portable to lp:nux/2.0 for an SRU since currently it breaks ABI/API - which is what we don't want for a stable release. I have been informed that a partial fix for nux can be compiled soon, but we'll take care of it later as the issue is not a serious one.

Just noting - as the submitted fix does not introduce any regressions, I am setting verification-done for this bug. It will be reopened once the SRU is published to -updates.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers