Sometimes need 3 power button presses to turn on screen

Bug #1429887 reported by Pat McGowan
144
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Unity System Compositor
Undecided
Unassigned
powerd (Ubuntu)
High
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

[filing here although may be other components]

Mako running 211 from rtm
 I experienced these symptoms which have been previously mitigated in other scenarios.
Last week while traveling and roaming this happened pretty much 100% of the time.
This occurred in all areas (hotel, MWC, outside, etc)

Press power button, no response
Press button again, screen turns on for a few seconds then turns off
Press button again, either phone resumes or more often the power dialog is shown

When I returned back home the function was normal without reboot or other changes.

The differences in environment:
Roaming on foreign GSM network
Lots of Wifi APs not connected

Attached are some perhaps relevant logs, unfortunately the syslog rolled.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :
description: updated
Revision history for this message
Michał Sawicz (saviq) wrote :

This seems to basically be a dupe of bug #1421455.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

I think it is different (perhaps related) as it never turns on the screen without an additional press. So its not a delay because the system is busy, it seems to completely ignore the first press. I also did not get it once it cleared the initial 3 press dance.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in powerd (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Revision history for this message
John McAleely (john.mcaleely) wrote :

I have certainly seen this on recent builds of rtm on krillin. I have not yet tested OTA3

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

This bug is not in powerd itself, it's usually caused by the amount of events that are either on hold before suspending, or that are triggered after resuming back (which makes the device to take a while to fully resume back).

We landed quite a few changes as part of OTA3 that reduced such events (battery, console, etc), which improved quite a bit. I still saw this happening once, but then wasn't really able to reproduce it anymore.

Changed in powerd (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
kevin gunn (kgunn72) wrote :

adding u-s-c to this, along with pm-fail tag.
There is an internal push the need to rewrite powerd to better centralize control of the pm.
Collecting this bug as part of the evidence.

tags: added: pm-fail
Revision history for this message
Michael Terry (mterry) wrote :

Re-opening powerd task, as OTA3 did *not* solve this problem, and we're still not sure where the problem lies.

I'm also going to rename the title to "Sometimes need 3 power presses to turn on screen" because I want to make this bug more obviously distinct from bug 1421455 and other display bugs.

Changed in powerd (Ubuntu):
status: Invalid → New
summary: - Pressing power button to resume does not turn on screen
+ Sometimes need 3 power button presses to turn on screen
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

I am seeing this again this week while traveling, only similarity was a lot of APs listed which seems unrelated
Pressing 3 times quickly wakes it up without delay so it doesn't seem there are events being processed at the time

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww21-2015
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in powerd (Ubuntu):
status: New → Confirmed
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

incomplete until we can get a good reproduction scenario

Changed in canonical-devices-system-image:
milestone: ww21-2015 → none
status: Confirmed → Incomplete
Revision history for this message
David Zschille (david-zschille) wrote :

I experience this behavior everytime i leave a wifi network which my bq 4.5 was connected to. For ~10 minutes it reacts very slow. Even making a phone call is not really possible.

This behavior goes away when i disable wifi on my phone.

Revision history for this message
Ari Börde Kröyer (ari-kroyer-online) wrote :

The last comment here is from July and I have been experiencing this issue practically every single day since first asking about it on the Ubuntu Phone mailing list in April, so I thought I'd take the time to say that it is still an issue, and an extremely annoying one. If there is anything I can do to help (observe any specific behavior of my phone - BQ 4.5 - or carry out any specific test) I would be more than happy to do so. Just let me know! (I updated my phone to r25 on September 2nd. )

Revision history for this message
Michael Terry (mterry) wrote :

I did some more testing, trying to reproduce this. I did my usual "get dbus-daemon to go crazy because I'm running through a bunch of wifi networks" test in my neighborhood.

After getting my phone to be a bit overloaded, I still couldn't trigger this bug even once.

But I did notice one oddity -- sometimes the phone screen wouldn't finish fading in to full brightness. It would then go to full brightness if I touched the screen.

But that made me think that there is some mechanism/bug by which the fade-in early-exits. So what if this bug is an immediate early-exit to the fade? Then second press is actually accurately received as a turn-off-screen-please request (which flashes the screen to full brightness for a moment). And the third is a normal turn-on-request. Pure conjecture without much evidence. Just a thought.

Revision history for this message
Robie Basak (racb) wrote :

I think this might be related to the phone powering on the screen after a notification. That is: I believe the occurrence is higher after the phone has woken the screen (and perhaps then timed out), compared to when there was no notification since I last used it. This is because it seems to affect me more when I'm responding to something (eg. notification LED with screen off) versus when I have taken the initiative to use my phone.

I also haven't seen this since OTA-7, where other bugs related to screen power seem to have been fixed.

Revision history for this message
Ari Börde Kröyer (ari-kroyer-online) wrote : Re: [Bug 1429887] Re: Sometimes need 3 power button presses to turn on screen

On my handset I get the bug whether there are incoming notifications or
not. I have reproduced it three times out of four attempts while writing
a few emails on my laptop just now. No notifications.

Regards,
Ari

Den 21. okt. 2015 20:08, skrev Robie Basak:
> I think this might be related to the phone powering on the screen after
> a notification. That is: I believe the occurrence is higher after the
> phone has woken the screen (and perhaps then timed out), compared to
> when there was no notification since I last used it. This is because it
> seems to affect me more when I'm responding to something (eg.
> notification LED with screen off) versus when I have taken the
> initiative to use my phone.
>
> I also haven't seen this since OTA-7, where other bugs related to screen
> power seem to have been fixed.
>

Revision history for this message
Michael Terry (mterry) wrote :

I'm beginning to doubt that this is particularly associated with system load (there was speculation that this is related to the scenario of wifi APs causing NetworkManager and dbus-daemon to go crazy, slowing down the system, which is a separate bug).

I've used the following script in /etc/init/load.conf to simulate heavy system load:

description "load"
manual
script
 while true; do true; done &
 while true; do true; done &
 while true; do true; done &
 while true; do true; done &
 while true; do true; done &
 exec cpulimit -l 1 -c 1 -p `ps ax | grep dbus-daemon | head -n 1 | awk '{print $1;}'`
end script

And it definitely slows things down. But I couldn't reproduce this specific bug with that running. I actually haven't seen it at all on my test or daily driver devices since OTA7. I don't know if that means it is fixed, harder to reproduce, or I've just been lucky.

Ari, you mention seeing this a lot. Are you on OTA7?

Revision history for this message
Ari Börde Kröyer (ari-kroyer-online) wrote :

Sorry for the late reply. I unfortunately overlooked your post.

Yes, I am on OTA-7 and I am getting it constantly, although not every
single time I want to turn on the screen.

Ari

Den 22. okt. 2015 20:20, skrev Michael Terry:
> I'm beginning to doubt that this is particularly associated with system
> load (there was speculation that this is related to the scenario of wifi
> APs causing NetworkManager and dbus-daemon to go crazy, slowing down the
> system, which is a separate bug).
>
> I've used the following script in /etc/init/load.conf to simulate heavy
> system load:
>
> description "load"
> manual
> script
> while true; do true; done &
> while true; do true; done &
> while true; do true; done &
> while true; do true; done &
> while true; do true; done &
> exec cpulimit -l 1 -c 1 -p `ps ax | grep dbus-daemon | head -n 1 | awk '{print $1;}'`
> end script
>
> And it definitely slows things down. But I couldn't reproduce this
> specific bug with that running. I actually haven't seen it at all on my
> test or daily driver devices since OTA7. I don't know if that means it
> is fixed, harder to reproduce, or I've just been lucky.
>
> Ari, you mention seeing this a lot. Are you on OTA7?
>

Revision history for this message
Michael Terry (mterry) wrote :

Thanks, Ari. I also happened to catch this several times this weekend on my phone, which is running rc-proposed (so OTA7+).

Here's an interesting tidbit though: I tried waiting after the first power button press. So rather than thinking "oh, I must not have hit it right" and pressing it again (thus causing the screen to flash on and then off immediately), I waited. Sometimes it took a LONG time like 30s. But the screen eventually came on by itself.

So this bug is *not* about the screen not coming on at all after a press. But rather a long delay.

Folks that are experiencing this bug: can you please verify by also waiting next time your screen doesn't immediately come on after pressing the power button? Please wait up to a minute to test.

Knowing it's a delay may help narrow this down. A delay that immediately gets short-circuited when the power button is pressed again...

Revision history for this message
Ari Börde Kröyer (ari-kroyer-online) wrote :

Hi Michael,

I just tested, but so far only three times.

1st time: Screen came on after 17s showing the "turn off / restart /
cancel" dialogue box. This, incidentally, is something I often get when
switching on the screen.

2nd time: Screen came on normally after 15s.

3rd time: Screen came on after 1s (i.e. right away).

I will check some more and give an update tomorrow around the same time.

Ari

Den 26. okt. 2015 13:35, skrev Michael Terry:
> Thanks, Ari. I also happened to catch this several times this weekend
> on my phone, which is running rc-proposed (so OTA7+).
>
> Here's an interesting tidbit though: I tried waiting after the first
> power button press. So rather than thinking "oh, I must not have hit it
> right" and pressing it again (thus causing the screen to flash on and
> then off immediately), I waited. Sometimes it took a LONG time like
> 30s. But the screen eventually came on by itself.
>
> So this bug is *not* about the screen not coming on at all after a
> press. But rather a long delay.
>
> Folks that are experiencing this bug: can you please verify by also
> waiting next time your screen doesn't immediately come on after pressing
> the power button? Please wait up to a minute to test.
>
> Knowing it's a delay may help narrow this down. A delay that
> immediately gets short-circuited when the power button is pressed
> again...
>

Revision history for this message
Michael Terry (mterry) wrote :

Thanks Ari, so that confirms that this is a delayed-screen-on bug, not a screen-never-comes-on bug.

You mentioned the shutdown dialog appearing. That's bug 1508563, with a fix incoming.

Revision history for this message
Ari Börde Kröyer (ari-kroyer-online) wrote :

Update:

I have tested this some more now and it seems like the delay from
pressing the power button until the screen comes on gets longer the
longer the time lapse since the phone was last booted.

Yesterday, I had the following experience:

  * With the phone on and screen off, I pressed the power button and
    waited...
  * After more than 3 full minutes I gave up and pressed once more. The
    screen flashed on for a second and switced off.
  * Approximately 7-10s later I pressed the power button again. The
    screen did not light up.
  * This time I waited for 4 minutes before giving up and pressing the
    button again. The screen flashed on for a second and switced off.
  * Again, I waited a few seconds before pressing the button once more.
    The screen remained dark.
  * By now my patience was gone and I only waited 10-15s before pressing
    the buttong again, causing the screen to flash on-off like before. I
    then immediately pressed one more time and it came on.
  * When trying to unlock the screen there was an awful lagging behavior.
  * I decided to switch the phone completely off.
  * I then restarted the phone. Once it was on, I switched off the
    screen, waited a short while and pressed the button to switch it on.
    This time it came on right away.

This is not the first time the phone has performed normally right after
switching it on (after switching completely off).

It is my impression than both the current bug as well as the tendency to
lag when swiping across the screen and when scrolling, manifest
themselves more the longer the time lapse since the last time the phone
was powered on.

I hope this helps to narrow down the cause. Good luck!

Best regards,
Ari

Den 26. okt. 2015 23:38, skrev Michael Terry:
> Thanks Ari, so that confirms that this is a delayed-screen-on bug, not a
> screen-never-comes-on bug.
>
> You mentioned the shutdown dialog appearing. That's bug 1508563, with a
> fix incoming.
>

Revision history for this message
jose sanchez (speedracer08861) wrote :

This problem started after the ota 14 update

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers