Unity: Some untranslatable and wrong strings in the previews

Bug #1074038 reported by Bence Lukács on 2012-11-01
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
Unity
Fix Released
Low
Sebastien Bacher
Unity Videos Lens
Low
Unassigned
unity-lens-applications
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
unity-lens-video (Ubuntu)
Low
Unassigned
Raring
Undecided
Unassigned

Bug Description

[Impact]

Untranslatable strings.

[Test Case]

See below.

[Regression Potential]

None.

In the attached screenshot you can see lots of bugs.
Firstly, the „No image available” string can't be translated, just like the „Size”, „Unknown” and the „reviews” string, I couldn't find them there: https://translations.launchpad.net/ubuntu/quantal/+source/unity-lens-applications/+pots/unity-lens-applications/hu/
After the „Installed on:” string, there is an unnecessary big space, furthermore the „None” string is either can't be translated, and it also doesn't fit the sentence „Installed on:”. The double colon is our fault, please don't mind it :)
Is it possible to fix these bugs in this release or they will be fixed just for the next release?
http://bug.openscope.org/secure/attachment/10427/bug2.png

Related branches

tags: added: translation
summary: - in the previews there are lots of untranslatable and wrong strings
+ Lots of untranslatable and wrong strings in the previews

"No Image Available" is translatable in unity, see bug #1106849. We're only 4 days from release, so no, these can't be changed for raring.

tags: added: l10n
removed: translation
Sebastien Bacher (seb128) wrote :

the "<...> reviews" string is in dash/previews/PreviewRatingsWidget.cpp:

"void PreviewRatingsWidget::SetReviews(int count)
{
  std::stringstream out;
  out << count;
  out << " reviews";
...
}"

Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The "size" is from unity-lens-application:

src/daemon.vala:

" subtitle += ("Size %s").printf (GLib.format_size (details.size));"

there is probably a "_" missing there

summary: - Lots of untranslatable and wrong strings in the previews
+ Some untranslatable and wrong strings in the previews

the license text is coming from " preview.license = details.license;" in the same function of the lens code

Changed in unity-lens-applications:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

unity-lens-video had some untranslatable strings due to outdated template/incomplete POTFILES.in, I've uploaded an updated template to launchpad which has been important and submitted a merge request to fix the POTFILES.in list

Changed in unity-lens-video (Ubuntu):
importance: Undecided → Low
Changed in unity-lens-video:
importance: Undecided → Low
Changed in unity-lens-video (Ubuntu):
status: New → Fix Released
Changed in unity-lens-video:
status: New → In Progress
David Planella (dpm) on 2013-04-22
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
importance: High → Medium
Changed in unity:
status: Confirmed → In Progress
Changed in unity-lens-applications:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-lens-video at revision 112, scheduled for release in unity-lens-video, milestone 0.1

Changed in unity-lens-video:
status: In Progress → Fix Committed
Changed in unity-lens-applications:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-lens-applications at revision 336, scheduled for release in unity-lens-applications, milestone 7.0.0

Ads20000 (ads20000) wrote :

sorry, I changed the Ubuntu version but I don't actually know if it has the same problem (moment of indecision)

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Changed in unity-lens-applications:
status: Fix Committed → New
status: New → Fix Committed
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → New
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-lens-video/raring at revision 112, scheduled for release in unity-lens-video, milestone Unknown

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-lens-applications/raring at revision 336, scheduled for release in unity-lens-applications, milestone Unknown

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity/7.0 at revision None, scheduled for release in unity, milestone 7.0.1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu Raring):
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu Raring):
status: New → Confirmed
Changed in unity-lens-video (Ubuntu Raring):
status: New → Confirmed
description: updated
summary: - Some untranslatable and wrong strings in the previews
+ Unity: Some untranslatable and wrong strings in the previews
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 7.0.0daily13.06.05-0ubuntu1

---------------
unity-lens-applications (7.0.0daily13.06.05-0ubuntu1) saucy; urgency=low

  [ Sebastien Bacher ]
  * Set one extra string as translatable. (LP: #1074038)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 339

unity-lens-applications (7.0.0daily13.05.31ubuntu.unity.next-0ubuntu1) raring; urgency=low

  [ Pawel Stolowski ]
  * New upstream release.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 338 (ubuntu-unity/next)

unity-lens-applications (6.10.0daily13.05.01.1ubuntu.unity.next-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 336 (ubuntu-unity/next)
 -- Ubuntu daily release <email address hidden> Wed, 05 Jun 2013 06:08:37 +0000

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

Hello Bence, or anyone else affected,

Accepted unity into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.0.0daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Bence, or anyone else affected,

Accepted unity-lens-video into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-video/0.3.14daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-lens-video (Ubuntu Raring):
status: Confirmed → Fix Committed
Changed in unity-lens-applications (Ubuntu Raring):
status: Confirmed → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Bence, or anyone else affected,

Accepted unity-lens-applications into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-applications/0.3.14daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I'm going to mark this verification-done for the Unity Raring SRU since the changes are absolutely needed. However, some strings are still not translated, but new language packs are needed for those strings to be translated.

tags: added: verification-done
removed: verification-needed
Stephen M. Webb (bregma) wrote :

Released in Unity 7.1.0

Changed in unity:
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.14daily13.06.19~13.04-0ubuntu1

---------------
unity-lens-video (0.3.14daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 114 (bootstrap)
  * Automatic snapshot from revision 115
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:01:08 +0000

Changed in unity-lens-video (Ubuntu Raring):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.10.0daily13.06.19~13.04-0ubuntu1

---------------
unity-lens-applications (6.10.0daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 338 (bootstrap)
  * Automatic snapshot from revision 339
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:01:14 +0000

Changed in unity-lens-applications (Ubuntu Raring):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.06.19~13.04-0ubuntu1

---------------
unity (7.0.0daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ William Hua ]
  * Revert 3196 to fix menu highlighting issues with LibreOffice.
    Revision 3196 prevents LibreOffice's menu items from highlighting.
    See Launchpad bug #1153350. (LP: #1153350)

  [ Chris Townsend ]
  * Fixes issue where minimizing a full screen window would not draw the
    Launcher and Panel after minimization. This is a backport of
    lp:unity revno. 3320. (LP: #1064155)

  [ Marco Trevisan (Treviño) ]
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime. (LP: #1181367)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3319 (bootstrap)
  * Automatic snapshot from revision 3320

unity (7.0.0daily13.05.08~13.04-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Andrea Azzarone ]
  * [alt-tab] Disable detail view for webapp icons. (LP: #1169340)

  [ Marco Trevisan (Treviño) ]
  * Launcher - count label pops out in auto-hide mode (LP: #1171476)
  * Panel shadow is drawn above full-screen windows when notifications
    are shown (LP: #1171934)
  * [regression] Icon count is not shown if the icon is not transformed
    (LP: #1171663)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3314
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:02:40 +0000

Changed in unity (Ubuntu Raring):
status: Fix Committed → Fix Released
Changed in unity:
milestone: none → 7.1.0
assignee: nobody → Sebastien Bacher (seb128)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers