Searches fail across changes in case

Bug #1056743 reported by Tyler Wagner on 2012-09-26
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
unity-lens-applications
High
Michal Hruby
5.0
High
Michal Hruby
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Timo Jyrinki

Bug Description

[IMPACT]

 * Currently application lens tokenizes applications names on change in the case. This means an application named "AisleRiot" can be found by searching "aisle" or "riot" (or any of its prefixes), but not the full name "aisleriot". This may cause the users to not find an application.

 * Fix for this is already present in Quantal, and since searching for applications is one of primary uses of dash, it should be backported to Precise.

 * Despite what the original description says, full substring matching is not desired (ie "leriot" should NOT find "AisleRiot".

[TESTCASE]

 * Before the fix - observe that searching for "aisle" finds "AisleRiot Solitaire" (it is installed by default), but searching for "aisleri" doesn't match any applications.

 * With fix - seaching for "aisleri" correctly finds AisleRiot.

 * Note that this may seemed to work properly in P for some CamelCase applications (like LibreOffice, but that's because "office" is present in the binary name)

[Regression Potential]

Possible regressions:
 * Searching for the individual tokens no longer works.

=====================================
Original description:

Application Lens searches seem to be based on tokens of entire words, not substrings. They are delimited by whitespace or changes in capitalisation. If you attempt to search across changes in case, or in the middle of a word, the search fails.

For example, I have Handbrake installed (http://handbrake.fr/ ). The desktop file gives a description of "HandBrake". The capital letter B is significant. The following Lens application searches find Handbrake:

1. hand
2. brake

The following Lens searches DO NOT find Handbrake:

1. Handbrake
2. HandBrake
3. Handb
4. and
5. rake

I would expect any of these searches to produce it. Even disregarding the substring matches in cases 4 and 5, cases 1-3 should work.

Related branches

Tyler Wagner (tyler) wrote :

Note that substrings matching the begin of a word do work. Examples:

3. han
4. brak

Tyler Wagner (tyler) wrote :

See related bug (but this is not the same request).

https://bugs.launchpad.net/ubuntu/+source/unity-lens-applications/+bug/752259

seoras (bhaltair) on 2012-09-26
Changed in unity-lens-applications:
status: New → Confirmed
Omer Akram (om26er) on 2012-09-26
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Michal Hruby (mhr3) on 2012-09-26
Changed in unity-lens-applications:
importance: Undecided → High
status: Confirmed → Triaged
milestone: none → 6.8.0
Tyler Wagner (tyler) wrote :

I'm glad to see the high importance, Michal, thanks. Perhaps I misunderstand status, but you've marked it as "Triaged". Does that mean there is a workaround?

Changed in unity-lens-applications:
status: Triaged → Fix Committed
Omer Akram (om26er) on 2012-10-02
Changed in unity-lens-applications:
assignee: nobody → Michal Hruby (mhr3)
Michal Hruby (mhr3) on 2012-10-03
description: updated
summary: - Searches fail across changes in case or in middle of word
+ Searches fail across changes in case
Tyler Wagner (tyler) wrote :

Thank you for describing the new plan, Michal. I figured it was a using tokens.

Under the new design, will "Riot" find "AisleRiot"? Why is it desirable that "aisleri" and "riot" finds it, but not "isleriot"? People don't expect searches to only work on the start of a token. Others aren't so good at spelling and may only type in part of the name.

As I was active in a duplicate, here is my fairly old comment, just for information :

-------------

I confirm this with another example: MusicBrainz Picard.
In the dash and the launcher, it is displayed as "MusicBrainz Picard".
If I search in the dash for "music" or "music b*", I can see its icon, but if I search for "musicb*" or "musicB*", it doesn't appear.

I think the problem is the capital letter of the second word when there is no space between them, because I can reproduce it with
- MusicBrainz Picard
- AisleRiot Patience
- FreeCell Patience
- IcedTea Web Control Panel
- PureData
- Transmission BitTorrent Client

However, I don't have this problem with:
- ImageShack Uploader.
- MyPaint
- MyUnity
- LibreOffice
- RecordMyDesktop
- QjackCtl

Any idea what could this come from?

--------------

Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.8.0-0ubuntu1

---------------
unity-lens-applications (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Use icon_url when displaying preview of an installable app; use
      find_pkg_icon instead of find_app_install_icon_path, as it also uses
      icons from ~/.cache/software-center/icons (LP: #1054085)
    - Remove unneeded gconf dep
    - Use size-hint for items in "More suggestions" category (LP: #1052513)
    - Disable collapsing by key (desktop file) when querying for specific
      packages (LP: #1057565)
    - Improve Utils.preprocess_text (LP: #1056743)
  * Bump libunity-dev dependency

  [ Didier Roche ]
  * Remove gconf build-dep as removed upstream.
 -- Didier Roche <email address hidden> Thu, 04 Oct 2012 16:22:31 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-applications (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Timo Jyrinki (timo-jyrinki)

Hello Tyler, or anyone else affected,

Accepted unity-lens-applications into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-applications/5.18.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-lens-applications (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
skorasaurus (skoraw) wrote :

I had experienced this problem as well but never got around to filing the bug.

After installing proposed package, The test case now works; when searching for aisleri - Aisleriot now displays as intended.

unity-lens-applications - 5.18.0-0ubuntu1
3.2.0-34-generic-pae
12.04 precise

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.18.0-0ubuntu1

---------------
unity-lens-applications (5.18.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Backport: Make sure searches for apps with CamelCase names work
      as expected. (LP: #1056743)
 -- Timo Jyrinki <email address hidden> Tue, 13 Nov 2012 12:12:02 +0200

Changed in unity-lens-applications (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers