Multi-monitor: indicators acting up when second monitor disconnected with indicator opened

Reported by Hernando Torque on 2012-02-21
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
Unity Distro Priority
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

TEST CASE:
1. Have a second monitor connected.
2. Open an indicator (menu, time, session, ...) on the second monitor.
3. Disconnect the second monitor.

RESULT:
The indicators on the right side of the panel on the primary screen seem to jump around between the "real" indicators and the ones from the secondary screen (I use a larger secondary monitor, that's why the affected area starts in the middle of the indicator area of my notebook screen - I guess).

Window buttons and menu area don't seem to be affected. Key navigation works fine.

Short clip attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,vpswitch,place,mousepoll,resize,imgpng,regex,gnomecompat,grid,snap,wall,session,animation,expo,workarounds,fade,ezoom,scale,unityshell]
Date: Tue Feb 21 20:15:01 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110112)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Hernando Torque (htorque) wrote :
tags: added: multimonitor
Omer Akram (om26er) wrote :

there are quite a lot of bugs reported for this

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

quite everyone sees this issue after disconnecting external monitor.

Changed in unity:
importance: Undecided → High
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Omer Akram (om26er) wrote :

Trevino, assigned it you initially please un/re-{assign} if that looks wrong. This is one of the most important multimonitor bugs in Unity right now.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 5.6.0
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0

Mh, even if I've experienced this issue few times, I actually can't reproduce this using the given test case in Precise...

Hernando Torque (htorque) wrote :

Confirmed. Not seeing this anymore.

Omer Akram (om26er) wrote :

Closed as fixed. Hernando if you see it again please re-open this bug.

Changed in unity:
status: Triaged → Fix Released
milestone: 5.8.0 → none
Changed in unity (Ubuntu Precise):
status: Triaged → Fix Released
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers