if libdir does not equal lib

Bug #888164 reported by Matthew Dawkins on 2011-11-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Olivier Tilloy
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

It is common for libdir on x86_64 machines to not be /usr/lib. So there is not reason to hardcode libdir as $prefix/lib

This is part of the current workaround employed.
%if %{_lib} != "lib"
sed -i 's|lib/|%{_lib}/|g' \
    panel/applets/*/CMakeLists.txt \
    libunity-2d-private/Unity2d/CMakeLists.txt \
    libunity-2d-private/src/launcherapplicationslist.cpp\
    config.h.in
%endif

This is the patch for libunity-2d-private/src/CMakeLists.txt
--- unity-2d-4.12.0/libunity-2d-private/src/CMakeLists.txt~ 2011-09-29 08:12:44.000000000 -0600
+++ unity-2d-4.12.0/libunity-2d-private/src/CMakeLists.txt 2011-11-08 16:10:22.016440228 -0700
@@ -151,7 +151,7 @@
 #
 set (PREFIXDIR "${CMAKE_INSTALL_PREFIX}")
 set (EXEC_PREFIX "${CMAKE_INSTALL_PREFIX}")
-set (LIBDIR "${CMAKE_INSTALL_PREFIX}/lib")
+set (LIBDIR "${CMAKE_INSTALL_LIBDIR}")
 set (INCLUDEDIR "${CMAKE_INSTALL_PREFIX}/include")

 install(DIRECTORY .
@@ -162,5 +162,5 @@

 configure_file (${LIB_NAME}.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/${LIB_NAME}.pc)
 install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${LIB_NAME}.pc DESTINATION
- ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig)

Related branches

Gerry Boland (gerboland) on 2011-11-09
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Gerry Boland (gerboland) on 2011-11-09
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2011-11-09
Changed in unity-2d:
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

Fixed at revision 777 of the trunk. I also un-hardcoded a number of paths, including data and include directories.

@Matthew, could you please test and confirm that this works as expected now?

Changed in unity-2d:
milestone: none → 4.14
status: In Progress → Fix Committed
Matthew Dawkins (mattydaw) wrote :

It is fixed now thank you very much.

Changed in unity-2d:
milestone: 4.14 → 5.2
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers