[dash] Unity-2d dash very slow to open

Bug #881756 reported by John Stultz on 2011-10-26
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Using Unity-2d, the dash (or unity-2d-places, or whatever its properly called) takes almost two seconds to open. This is far too long when trying to quickly access applications.

I've reproduced this on one system I connect to via xdmcp, as well as natively on a different system. The second system runs unity-3d just fine, and clicking the dash there opens in under a second (still there's a noticeable lag, but its much better then unity-2d).

Related branches

Gerry Boland (gerboland) on 2011-10-31
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
Gerry Boland (gerboland) on 2011-10-31
summary: - Unity-2d dash very slow to open
+ [dash] Unity-2d dash very slow to open
Changed in unity-2d:
assignee: nobody → Lohith D Shivamurthy (dyams)
status: Confirmed → In Progress
Changed in unity-2d:
milestone: none → 5.2
Changed in unity-2d:
assignee: Lohith D Shivamurthy (dyams) → nobody
status: In Progress → Confirmed
Florian Boucault (fboucault) wrote :

Rigourous profiling needs to be conducted and reported back here.
For now, the quick profiling that I conducted led to the 2 following culprits being identified:

- (blurred) background is making us take a screenshot of the desktop twice for no reason
Fix at: https://code.launchpad.net/~fboucault/unity-2d/windowimageprovider_remove_timestamp_hack/+merge/84662

- everytime the dash is opened the home page is reloaded whereas we could just not destroy the home page
Fix at: https://code.launchpad.net/~fboucault/unity-2d/dash_no_unload_page/+merge/84672

Gerry Boland (gerboland) on 2011-12-19
Changed in unity-2d:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: New → Fix Released
David Nemeskey (nemeskeyd) wrote :

Thanks for the fix, but Unity 2D still opens very slowly on my machine, and mine is at version 5.12.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers