[dash] Huge performance hit when scrolling search results with accessibility enabled

Bug #862956 reported by Florian Boucault on 2011-09-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Michał Sawicz
qt4-x11 (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Open up a lens in the dash that has a lot of results to display
2. Expand the results
3. Scroll up and down using any mean at your disposal (scrollbar, mouse chord, dragging)

The CPU load of unity-2d-places goes through the roof (100%) and visually the scrolling is not smooth at all.

This is a very recent regression. Probably not in the QML code since it has nearly not changed at all recently. Maybe a new bug in QML itself or in Dee?

Related branches

Changed in unity-2d:
importance: Undecided → Critical
milestone: none → 4.14
Alberto Mardegan (mardy) wrote :

Hmmm... <small>I changed a few things, for bug 817421</small>
I'll try to revert that patch, and see how things go.

Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
status: New → Triaged
Alberto Mardegan (mardy) wrote :

Florian, I'm not sure that I can reproduce it. I just upgraded my system, and I don't notice any performance regressions. I also tried reverting the changes I did for bug 817421, but I don't notice any speed difference.

I tried in VirtualBox, both when the VM has 4 processors, and when it has 1.
I'm using the ubuntu-desktop-ppa-oneiric, unity-2d-team-unity-2d-daily-oneiric and yannubuntu-boot-repair-natty (I guess the last one has no relevance here).
Do you have some other PPAs active?

Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
status: New → Triaged
Alberto Mardegan (mardy) wrote :

After installing the qt-at-spi package I notice the same performance degradation as well. So, it looks like this bug is related to accessibility.

I'll have a look at how a11y is implemented, to see if there are some obvious improvements we can make.

tags: added: a11y
tags: added: performance
Alberto Mardegan (mardy) wrote :

After a quick investigation, it seems that graphic elements need to notify the accessibility plugin (qt-at-spi) whenever their position changes; I'm not sure how costly this is, and if there are ways to fix it. I'm getting in touch with Qt developers to know more about it.

OTOH, qt-at-spi seems to have changed a lot since June (and the version we are shipping now in Ubuntu is from June); unfortunately I couldn't test the new version, as it requires qt 4.8.

summary: - [dash] Huge performance regression when scrolling search results
+ [dash] Huge performance hit when scrolling search results with
+ accessibility enable
summary: [dash] Huge performance hit when scrolling search results with
- accessibility enable
+ accessibility enabled
Changed in unity-2d:
importance: Critical → High
Michał Sawicz (saviq) on 2011-10-10
Changed in unity-2d:
assignee: Alberto Mardegan (mardy) → Michał Sawicz (saviq)
Michał Sawicz (saviq) wrote :

I'm attaching a simple test app that exposes the issue, try running with QT_ACCESSIBILITY=0 - everything's fine, but make that QT_ACCESSIBILITY=1 and scrolling slows down significantly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2011-11-21
Changed in unity-2d:
milestone: 4.14 → 5.2
Gerry Boland (gerboland) wrote :

The Dash Grid has been re-architectured significantly in commit 788. Please check to see if this change has improved this situation.

Michał Sawicz (saviq) wrote :

Indeed the impact of accessibility seems to have reduced greatly. Unless someone with a slower machine still finds this to be a problem, I'm ok to close this.

Gerry Boland (gerboland) wrote :

Me too, I did a quick test and have no complaints. Marking as Fixed

Changed in unity-2d:
status: Triaged → Fix Committed
Changed in unity-2d (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments