[workspace switcher] Performance can be poor when using the opengl backend because of window texture sizes that are not limited

Reported by Florian Boucault on 2011-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Florian Boucault
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

TBD

Related branches

lp:~fboucault/unity-2d/spread_limit_sizes
Merged into lp:unity-2d at revision 830
Gerry Boland: Approve on 2011-12-13
Ugo Riboni: Pending requested 2011-12-07
Superseded for merging into lp:unity-2d/3.0
Ugo Riboni: Needs Fixing on 2011-07-14
lp:~tiagosh/unity-2d/unity-2d-shell-homelens
Merged into lp:unity-2d at revision 910
Albert Astals Cid: Approve on 2012-02-13
Gerry Boland: Pending requested 2012-02-10
Michał Sawicz: Pending requested 2012-02-10
Albert Astals Cid: Approve (fun) on 2012-02-10
Gerry Boland: Needs Fixing on 2012-02-03
Michał Sawicz: Abstain on 2012-02-03
Changed in unity-2d:
status: New → In Progress
assignee: nobody → Florian Boucault (fboucault)
milestone: none → 3.8.12
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-07-20
Changed in unity-2d (Ubuntu):
status: New → In Progress
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
milestone: 3.8.12 → 3.8.14
Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-08-11
Changed in unity-2d:
milestone: 4.0 → 4.2
Changed in unity-2d:
milestone: 4.2 → 4.4
Changed in unity-2d (Ubuntu):
status: In Progress → Confirmed
Changed in unity-2d:
status: In Progress → Confirmed
summary: - [spread] Performance can be poor when using the opengl backend because
- of window texture sizes that are not limited
+ [workspace switcher] Performance can be poor when using the opengl
+ backend because of window texture sizes that are not limited
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
milestone: 4.10 → 4.14
Changed in unity-2d:
milestone: 4.14 → none
Changed in unity-2d:
milestone: none → 5.2
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers