[workspace switcher] keyboard navigation of workspace switcher broken for accessibility

Bug #744978 reported by Bill Filler on 2011-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

For accessibility support, the workspace switcher needs to support the following. Goal would be to do everything via keyboard.
1) hot key to activate switcher (should match unity-3d which I believe is super-w)
2) first window in first workspace focused
3) tab or arrow key navigate between windows on workspace and then BETWEEN workspaces
4) enter key should exit switcher and activiate focused window
5) ESC exit the switcher without changing workspace

Related branches

Bill Filler (bfiller) on 2011-03-29
Changed in unity-2d:
milestone: none → 3.10
importance: Undecided → Critical
Bill Filler (bfiller) wrote :

A few corrections:
- unity-3d hotkey for spread is super-s. hotkey to show all windows is super-w
- in unity-3d in the spread, you can only navigate between workspaces (not windows) by using the arrow keys. this should be our goal as well. That is 3) above should allow navigation between workspaces (not windows) and enter should show that workspace.

Bill Filler (bfiller) on 2011-03-29
Changed in unity-2d:
assignee: nobody → Ugo Riboni (uriboni)
Bill Filler (bfiller) on 2011-03-29
summary: - keyboard navigation of workspace switcher broken for accessibilty
+ [spread] keyboard navigation of workspace switcher broken for
+ accessibilty
summary: [spread] keyboard navigation of workspace switcher broken for
- accessibilty
+ accessibility
Changed in unity-2d:
importance: Critical → High
tags: added: delta-with-3d
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
milestone: 3.10 → none
tags: added: a11y
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: Ugo Riboni (uriboni) → nobody
summary: - [spread] keyboard navigation of workspace switcher broken for
- accessibility
+ [workspace switcher] keyboard navigation of workspace switcher broken
+ for accessibility
Alberto Mardegan (mardy) on 2011-10-07
Changed in unity-2d:
status: Confirmed → In Progress
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) on 2011-10-19
Changed in unity-2d:
milestone: none → 4.14
Gerry Boland (gerboland) on 2011-11-21
Changed in unity-2d:
milestone: 4.14 → 5.2
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers