[panel] navigation between application menus temporarily gives focus back to the application

Bug #717682 reported by Omer Akram on 2011-02-12
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Aurélien Gâteau
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Unity 3.2.2-0ubuntu1
Title says it all.

Steps to reproduce:
1. open nautilus and click on the 'Documents' bookmark in the side pane.
2. click on the nautilus menu bar in unity panel and move around menus

what happens:
its clearly visible that nautilus is given focus shortly

what should happen:
nautilus should not get the focus

Also this problem does not happen when navigating between system indicators.

Related branches

Omer Akram (om26er) on 2011-02-12
summary: - navigation between application menus temporarily gives focus back to the
- application
+ [panel] navigation between application menus temporarily gives focus
+ back to the application
Andrew Hayzen (ahayzen) wrote :

Hi Omer

Description: Ubuntu 10.10
Release: 10.10
unity-2d-default-settings:
  Installed: 0.4-0ubuntu1~bzr405
  Candidate: 0.4-0ubuntu1~bzr405
  Version table:
 *** 0.4-0ubuntu1~bzr405 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

I can confirm that when using the package unity-2d on ubuntu 10.10 using the steps provided by Omer Akram that I can reproduce the bug. Therefore I have set this bug to confirmed.

Also I can confirm the behaviour that this problem doesn't exist when navigating system indicators.

Andy

Changed in unity-2d:
status: New → Confirmed
Florian Boucault (fboucault) wrote :

I cannot observe that issue Omer. Maybe I am not looking at the right thing. Do you have any tips?

Also, are you using metacity?

at the moment indicators are broken in unity-2d so cant test it. as soon as
they are back i'll report

On Fri, Feb 25, 2011 at 10:45 PM, Florian Boucault <email address hidden>wrote:

> I cannot observe that issue Omer. Maybe I am not looking at the right
> thing. Do you have any tips?
>
> Also, are you using metacity?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/717682
>
> Title:
> [panel] navigation between application menus temporarily gives focus
> back to the application
>
> Status in Unity 2D:
> Confirmed
>
> Bug description:
> Unity 3.2.2-0ubuntu1
> Title says it all.
>
> Steps to reproduce:
> 1. open nautilus and click on the 'Documents' bookmark in the side pane.
> 2. click on the nautilus menu bar in unity panel and move around menus
>
> what happens:
> its clearly visible that nautilus is given focus shortly
>
> what should happen:
> nautilus should not get the focus
>
> Also this problem does not happen when navigating between system
> indicators.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity-2d/+bug/717682/+subscribe
>

Andrew Hayzen (ahayzen) wrote :

Hi Florian

I am running Ubuntu 10.10 and I have installed unity-2d from the ppa. I have not manually installed metacity but it seems to have installed one from the ppa itself (see below). Also I am experiencing the same issue as Omer (I confirmed the bug).

metacity:
  Installed: 1:2.30.2-0ubuntu1upicek6
  Candidate: 1:2.30.2-0ubuntu1upicek6
  Version table:
 *** 1:2.30.2-0ubuntu1upicek6 0
        500 http://ppa.launchpad.net/unity-2d-team/unity-2d-daily/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
     1:2.30.2-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

If you want any more information just ask.

Hope that helps.

Andy

Florian Boucault (fboucault) wrote :

Bumping importance as it could cause performance issues on low end machines (BAMF reacts to focus changes, D-Bus traffic happens and the launcher reacts as well).

Changed in unity-2d:
importance: Undecided → Medium
importance: Medium → High
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: none → 3.8.12
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
Changed in unity-2d:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-07-20
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Gerry Boland (gerboland) wrote :

The implementation of QMenuBar in Qt4.7 does not hold onto focus while panning horizontally through menus with the mouse or keyboard. In the brief pause between one menu closing and another opening, the focus is returned to the application, causing the flicker.

This behaviour can be seen in other native Qt apps like Qt Creator or KDE apps like Kate. However it is more noticeable in thus dbus-based menus, due to the fact that each menu display causes dbus traffic which elongates the pause between menus.

GTK menus do not have this focus problem, hence the indicator bar does not exhibit this issue.

Have reported to upstream Qt: https://bugreports.qt.nokia.com/browse/QTBUG-20532
Will lower priority for now.

Changed in unity-2d:
importance: High → Medium
tags: added: a11y
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → Aurélien Gâteau (agateau)
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers