Lotus Notes is incompatible with ayatana scrollbars

Bug #890986 reported by WenLong FENG
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unico
Invalid
Undecided
Unassigned
overlay-scrollbar
Confirmed
Undecided
Unassigned
overlay-scrollbar (Ubuntu)
Fix Released
Undecided
Unassigned
Precise
Fix Released
High
Mathieu Trudel-Lapierre
Quantal
Fix Released
High
Mathieu Trudel-Lapierre

Bug Description

= Problem =

When using Lotus notes with Unity the scrollbars do not display correctly. This uses gtk_paint_box, the theme for the scrollbar should be redrawn but is not.

= Environment =

* Ubuntu 11.10 (Oneiric) i386
* Unity 4.22.0-0ubuntu3

= Steps to reproduce =

1. Compile scroll.cpp: g++ -o scroll scroll.cpp `pkg-config --libs gtk+-2.0``pkg-config --cflags gtk+-2.0`
2. Launch it from a terminal
3. Click on the buttons to make the scroll bar scroll up and down

[Regression Potential]
Minimal; adds Notes to the list of applications that won't get overlay scrollbars and instead revert to the GTK-style scrollbars. This would also affect any other applications using the same binary name: "lnotes", "notes".

= Other Information =

See screenshot attached (scrollbar-1.png)

Revision history for this message
WenLong FENG (fengwl) wrote :
Omer Akram (om26er)
affects: unity → ubuntu
Revision history for this message
SwitchDK (switchdk) wrote :

Dear WenLong FENG,

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

I have converted the bug report to a question since it has more to do with developing for Ubuntu than reporting a problem with Ubuntu. For others to be able to help with your question, I would recommend you include more information about the version of Ubuntu you are using, a description of what you are attempting (attaching a cpp file doesn't explain to the triagers what is the problem) and other information that describe your environment and what you are attempting to do.

-----
Many thanks,
Peter Dam (SwitchDK)

Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: New → Invalid
Revision history for this message
Tom Ellis (tellis) wrote :

This is a valid bug.

Changed in ubuntu:
status: Invalid → New
affects: ubuntu → unity (Ubuntu)
Tom Ellis (tellis)
description: updated
summary: - unity theme dose not paint when call gtk_paint_box
+ Unity theme does not paint when calling gtk_paint_box
Tom Ellis (tellis)
description: updated
Revision history for this message
Tom Ellis (tellis) wrote : Re: Unity theme does not paint when calling gtk_paint_box

When running I get the error:
Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap"

That seems to be:
https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/762167

`apt-get install gtk2-engines-pixbuf` this stops the error, but it appears the problem still occurs. That error was a red herring.

The problem still occurs after adding that package.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Omer Akram (om26er) wrote :

not a unity bug, could be light-themes,unico or gtk itself, unity here is unrelated.

affects: unity (Ubuntu) → light-themes (Ubuntu)
affects: unity → unico
Revision history for this message
Andrea Cimitan (cimi) wrote :

Overlay scrollbars ignore paintings to optimize the performances, they are just in ubuntu indeed.
Try running the test app with LIBOVERLAY_SCROLLBA=0 ./scroll to see if it happens with native scrollbars

Revision history for this message
Andrea Cimitan (cimi) wrote :

LIBOVERLAY_SCROLLBAR=0

Revision history for this message
Tom Ellis (tellis) wrote :

Yep, that's it. If I run it with:
LIBOVERLAY_SCROLLBAR=0 ./scroll
... the scrollbar works as expected.

So other than launching an application with LIBOVERLAY_SCROLLBAR=0 is there anyway I can do that? like some sort of blacklist for the scrollbars?

Revision history for this message
Andrea Cimitan (cimi) wrote :

Tom, grab me in the office on Monday... cheers, have a good weekend

Changed in light-themes (Ubuntu):
status: Confirmed → Invalid
Changed in unico:
status: New → Invalid
Changed in ayatana-scrollbar:
status: New → Won't Fix
Revision history for this message
Tom Ellis (tellis) wrote : Re: Scrollbars do not paint when calling gtk_paint_box with Lotus Notes
summary: - Unity theme does not paint when calling gtk_paint_box
+ Scrollbars do not paint when calling gtk_paint_box with Lotus Notes
description: updated
description: updated
description: updated
Revision history for this message
Tom Ellis (tellis) wrote :

After some chat IRL with Andrea it appears Lotus Notes is relying on the repaint, a bug will be opened with their product however in the meantime I added "notes.bin" to the blacklist and recompiled and it fixes the issue for me.

Attached as a patch.

Revision history for this message
Andrea Cimitan (cimi) wrote :

I'll blacklist lotus in the meanwhile

summary: - Scrollbars do not paint when calling gtk_paint_box with Lotus Notes
+ Lotus Notes is incompatible with ayatana scrollbars
Changed in ayatana-scrollbar:
status: Won't Fix → Triaged
Revision history for this message
WenLong FENG (fengwl) wrote :

Hi Tom, I'm not sure how would you blacklist Lotus Notes from the appmenu, but I provide more details in case you need.
The real executable binary launcher should be called "notes" and some organization add an wrapper which set env before launch it, and may add the wrapper named as "notes.bin", so please make sure the "notes" will be considered, thanks.

Revision history for this message
Tom Ellis (tellis) wrote :

Hi WenLong Feng,
I have already written the patches to do this and tested them. They work well for me and have been merged into the codebase.

Using the executable binary or wrapper doesn't make a difference, we grab the name using gtk's g_get_prgname.
I've tested this by wrapping notes in shell scripts and running directly and it makes no difference, the blacklisting still works and the scrollbars then behave in the way you would expect.

I would like to see Lotus Notes support the overlay scrollbars but understand there would have to be some code changes to do this, I believe blacklisting Notes from the overlay-scrollbar would be the best behaviour for 12.04 LTS.

I have a test package that is compiled to work on Ubuntu 11.10 (Oneiric) with this patch which you can try if you like:
$ sudo apt-add-repository ppa:tellis/generic
$ sudo apt-get update
$ sudo apt-get install overlay-scrollbar

Alternatively, the same behaviour can be achieved by exporting the environment variable LIBOVERLAY_SCROLLBAR=0. I would prefer if you could test the package above.

Andrea Cimitan (cimi)
Changed in ayatana-scrollbar:
status: Triaged → Fix Committed
Revision history for this message
WenLong FENG (fengwl) wrote :

It is still reproducible on 12.04 GA version with Lotus Notes 12.04.

Revision history for this message
WenLong FENG (fengwl) wrote :

It is still reproducible on 12.04 GA version with Lotus Notes 8.53.

Revision history for this message
Tom Ellis (tellis) wrote :

Hi WenLong Feng,

So, it appears you still see the problem but within another window. Previously "notes.bin" was blacklisted and this seemed to work in my tests but you also mention

"The launcher of Lotus Notes is named 'notes' but it create two other processes named 'notes2' and 'lnotes'. 'notes2' is java process and "lnotes" is the core c++ process."

I will create a test package with lnotes and notes2 blacklisted.

Thanks,
Tom

Revision history for this message
WenLong FENG (fengwl) wrote : Re: [Bug 890986] Re: Lotus Notes is incompatible with ayatana scrollbars

Hi Tom,
Thanks for your feedback. For formal version of Lotus Notes we only have
processes named as "lnotes" and "notes2" and "notes"

Best Regards
WenLong FENG
IBM China Software Development Lab
Tel : 86-10-82452499
Mailto:<email address hidden>

From: Tom Ellis <email address hidden>
To: Wen Long WL Feng/China/IBM@IBMCN,
Date: 2012/05/22 14:20
Subject: [Bug 890986] Re: Lotus Notes is incompatible with ayatana
            scrollbars
Sent by: <email address hidden>

Hi WenLong Feng,

So, it appears you still see the problem but within another window.
Previously "notes.bin" was blacklisted and this seemed to work in my
tests but you also mention

"The launcher of Lotus Notes is named 'notes' but it create two other
processes named 'notes2' and 'lnotes'. 'notes2' is java process and
"lnotes" is the core c++ process."

I will create a test package with lnotes and notes2 blacklisted.

Thanks,
Tom

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/890986

Title:
  Lotus Notes is incompatible with ayatana scrollbars

Status in Ayatana Scrollbar:
  Fix Committed
Status in The Unico Gtk+ Theming Engine:
  Invalid
Status in “light-themes” package in Ubuntu:
  Invalid

Bug description:
  = Problem =

  When using Lotus notes with Unity the scrollbars do not display
  correctly. This uses gtk_paint_box, the theme for the scrollbar should
  be redrawn but is not.

  = Environment =

  * Ubuntu 11.10 (Oneiric) i386
  * Unity 4.22.0-0ubuntu3

  = Steps to reproduce =

  1. Compile scroll.cpp: g++ -o scroll scroll.cpp `pkg-config --libs gtk
+-2.0``pkg-config --cflags gtk+-2.0`
  2. Launch it from a terminal
  3. Click on the buttons to make the scroll bar scroll up and down

  = Other Information =

  See screenshot attached (scrollbar-1.png)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ayatana-scrollbar/+bug/890986/+subscriptions

Revision history for this message
Mark Russell (marrusl) wrote :

Test packages with "lnotes" and "notes2" added to the blacklist can be found here:

https://launchpad.net/~marrusl/+archive/overlay-scrollbar-notes

Changed in ayatana-scrollbar:
status: Fix Committed → Confirmed
Revision history for this message
Mark Russell (marrusl) wrote :

Changing status back to Triaged because the problem was not entirely resolved with the first fix.

Revision history for this message
Mark Russell (marrusl) wrote :

Or rather, Confirmed.

Revision history for this message
Andrea Cimitan (cimi) wrote :

Patch for precise

Revision history for this message
Mark Russell (marrusl) wrote :

Any guess on when this will hit precise or at least the unapproved queue? Thanks!

Mark Russell (marrusl)
tags: added: precise quantal
Revision history for this message
Ken VanDine (ken-vandine) wrote :

This was fixed in 0.2.16+r359daily12.11.28.1-0ubuntu1

Changed in overlay-scrollbar (Ubuntu):
status: New → Fix Released
Changed in overlay-scrollbar (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in overlay-scrollbar (Ubuntu Quantal):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in light-themes (Ubuntu Quantal):
status: New → Invalid
Changed in light-themes (Ubuntu Precise):
status: New → Invalid
Changed in overlay-scrollbar (Ubuntu Precise):
status: New → Triaged
Changed in overlay-scrollbar (Ubuntu Quantal):
status: New → In Progress
Changed in overlay-scrollbar (Ubuntu Precise):
importance: Undecided → High
Changed in overlay-scrollbar (Ubuntu Quantal):
importance: Undecided → High
description: updated
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

overlay-scrollbar 0.2.16+r357-0ubuntu1.1 was just uploaded to the quantal-proposed queue. Waiting for a member of the SRU team to review it...

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello WenLong, or anyone else affected,

Accepted overlay-scrollbar into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/overlay-scrollbar/0.2.16+r357-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in overlay-scrollbar (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello WenLong, or anyone else affected,

Accepted overlay-scrollbar into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/overlay-scrollbar/0.2.16-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in overlay-scrollbar (Ubuntu Precise):
status: Triaged → Fix Committed
Revision history for this message
Mark Russell (marrusl) wrote :

Quantal and precise verified. Looks good! Thanks!

tags: removed: verification-needed
tags: added: verification-done
Revision history for this message
Scott Kitterman (kitterman) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.16-0ubuntu1.1

---------------
overlay-scrollbar (0.2.16-0ubuntu1.1) precise-proposed; urgency=low

  * debian/control: add quilt to Build-Depends.
  * debian/rules: include patchsys-quilt.
  * debian/patches/blacklist-notes.patch: Blacklist Lotus Notes; to avoid
    display issues when scrolling. (LP: #890986)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 13 Dec 2012 10:44:16 -0500

Changed in overlay-scrollbar (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package overlay-scrollbar - 0.2.16+r357-0ubuntu1.1

---------------
overlay-scrollbar (0.2.16+r357-0ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches/02_blacklist_lotus_notes.patch: blacklist Lotus Notes
    to avoid display issues when scrolling. (LP: #890986)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 04 Dec 2012 14:06:10 -0500

Changed in overlay-scrollbar (Ubuntu Quantal):
status: Fix Committed → Fix Released
no longer affects: light-themes (Ubuntu)
no longer affects: light-themes (Ubuntu Precise)
no longer affects: light-themes (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers