missing dependency on gtk2-engines-pixbuf

Bug #762167 reported by Felix Zweig
486
This bug affects 111 people
Affects Status Importance Assigned to Milestone
light-themes (Ubuntu)
Low
Scott Moser

Bug Description

Binary package hint: light-themes

Selecting Ambiance/Radiance as GTK2 theme without having gtk2-engines-pixbuf installed results in

Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

messages in the terminal and an error in gnome-appearance-properties.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: light-themes 0.1.8.12
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Fri Apr 15 22:41:46 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: light-themes
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Felix Zweig (f.zweig) wrote :
Changed in light-themes (Ubuntu):
status: New → Confirmed
Revision history for this message
Lucazade (lucazade) wrote :

this is present also in oneiric.
.xsession-errors file is full of these warnings

Gary M (garym)
tags: added: oneiric
Gary M (garym)
tags: added: iso-testing
Revision history for this message
actionparsnip (andrew-woodhead666) wrote :

If you run:

sudo apt-get install gtk2-engines-pixbuf

Then retry, it is smooth. I suggest you add this as a dep so it gets automagically installed.

Revision history for this message
John Winterton (jwinterton) wrote :

Tried that and got:
john@john-11:~$ sudo apt-get install gtk3-engines-pixbuf
[sudo] password for john:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gtk3-engines-pixbuf

Should one change the update selections to accept untested stuff?

Revision history for this message
actionparsnip (andrew-woodhead666) wrote :

gtk2-engines-pixbuf not gtk3-engines-pixbuf

If I'd meant gtk3-engines-pixbuf I would have written it.....

Revision history for this message
actionparsnip (andrew-woodhead666) wrote :

andy@D420:~$ apt-cache policy gtk2-engines-pixbuf
gtk2-engines-pixbuf:
  Installed: 2.24.6-0ubuntu2
  Candidate: 2.24.6-0ubuntu2
  Version table:
 *** 2.24.6-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status

Revision history for this message
John Winterton (jwinterton) wrote :

Oops. sorry. typo. I am listening to a parliamentary debate and they are talking inflation. will try again.

Revision history for this message
John Winterton (jwinterton) wrote :

Failed to fumble finger it this time. Worked fine, thanks.

Revision history for this message
Regression (gitsfans) wrote :

sudo apt-get install gtk2-engines-pixbuf solved that for me.

Revision history for this message
Felix Zweig (f.zweig) wrote :

That's right, installing gtk2-engines-pixbuf resolves the warning messages. That's why this bug aims for adding gtk2-engines-pixbuf as a dependency in the light-themes package.

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

In Ubuntu 11.10, aside from seeing the messages in the terminal periodically, I don't observe any other errors.

In particular, gnome-appearance-properties is no longer available in 11.10, and when using the "Appearance" section of gnome-control-center in the default "Ubuntu" session, no error appears when switching between the Ambiance & Radiance themes (I have not tried in the "Ubuntu 2D" session).

Anyway, it may be hasty to say that the issue is a missing dependency on the gtk2 engine. Perhaps the issue is unpurged legacy content in light-themes. For example, I can grep "pixmap" in /usr/share/themes/Ambiance/gtk-2.0/apps, but nowhere in /usr/share/themes/Ambiance/gtk-3.0/apps.

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

Follow-up: /usr/share/themes/Ambiance/gtk-2.0/gtkrc contains the following lines:

#include "apps/gedit.rc"
include "apps/gnome-panel.rc"
include "apps/ubuntuone.rc"

…and in fact these three files are the only ones containing configuration like: engine "pixmap" { …

Commenting out the lines for gnome-panel.rc and ubuntuone.rc causes the error messages to disappear. The appearance of the Ubuntu One control panel changes, but otherwise it continues to work properly under both the "Ubuntu" and "Ubuntu 2D" sessions.

I also note that I do not have gnome-panel installed on any system I've upgraded to 11.10 from 11.04.

papukaija (papukaija)
tags: added: unmetdeps
Revision history for this message
Jason Frost (jasonf) wrote :

Confirmed in 12.04 Precise Pangolin as well - I agree that perhaps the gtk2-engines-pixbuf package should be added to the dependencies for light-themes, as it obviously references it. Alternatively, the source of the errors should be fixed so that the package isn't needed.

Revision history for this message
Susan Spencer (susan-spencer) wrote :

Problem appears on Precise Pangolin when calling Inkscape 0.48.2 from the command line.
'sudo apt-get install gtk2-engines-pixbuf' solved it.

Gary M (garym)
tags: added: precise
Revision history for this message
emre yilmaz (emre06ylmz) wrote :

Regression (gitsfans) thanks a lot. u r right installing gtk2-engines-pixbuf solved problem. i have one more question for. i m pretty new for verilig language. do u have any suggestion for me or you know any book or notes? cos i will have some homework for verilig and i dont have any source.

Changed in light-themes (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
dan the person (dantheperson) wrote :

Sames probs here on a fresh 11.10 install...

And same fix, installing gtk2-engines-pixbuf stops my terminal windows filling up with errors.

Revision history for this message
Karl Brand (brandk) wrote :

Thanks a lot actionparsnip (andrew-woodhead666).

sudo apt-get install gtk2-engines-pixbuf

Eliminated the warnings on my 11.10_64bit install.

Revision history for this message
Pi Delport (pi-delport) wrote :

Same here on Ubuntu 11.10, affecting a number of different programs.

Installing gtk2-engines-pixbuf solved it.

Revision history for this message
Felix Zweig (f.zweig) wrote :

Thank you all for confirming this issue. However, the purpose of this
bug report is to include gtk2-engines-pixbuf in the dependencies and
it's already triaged. Thus, no further confirmation is necessary.

Revision history for this message
Federico Vera (fedevera) wrote :

I have the same issue since a while now, installing 'gtk2-engines-pixbuf' does solve the "problem" of the error lines, but it doesn't fix the theme problem.

For instance, when running a Java app, that uses JInternalFrames (sorry if this is the only example I have but I see it every day), if 'gtk2-engines-pixbuf' is not installed then the inner frames are drawn in the old GTK way (which looks pretty awful when combined with the ambiance theme https://launchpadlibrarian.net/94538299/newimage.png), but, if 'gtk2-engines-pixbuf' is installed it shows a badly drawn frame border as you can see here https://launchpadlibrarian.net/83306890/windowbug.png in Bug #878937

I'm not actually know if that is the old GTK way, but I do remember having a similar theme some 7 years ago...

Changed in light-themes (Ubuntu):
assignee: nobody → Francesco Ruvolo (ruvolof)
Revision history for this message
Francesco Ruvolo (ruvolof) wrote :

I added the dependency.
It builds on precise.
I installed this package and there are no more errors related to this package in .xsession-errors.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "light-themes-0.1.8.29-0ubuntu3.diff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Sebastien Bacher (seb128) wrote :

Ken, could you ave a look?

Changed in light-themes (Ubuntu):
assignee: Francesco Ruvolo (ruvolof) → Ken VanDine (ken-vandine)
Scott Moser (smoser)
Changed in light-themes (Ubuntu):
status: Triaged → In Progress
importance: Undecided → Low
assignee: Ken VanDine (ken-vandine) → Scott Moser (smoser)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package light-themes - 0.1.8.30-0ubuntu3

---------------
light-themes (0.1.8.30-0ubuntu3) precise; urgency=low

  [ Francesco Ruvolo ]
  * Added gtk2-engines-pixbuf to dependencies to fix bug (LP: #762167)
 -- Scott Moser <email address hidden> Wed, 07 Mar 2012 13:41:24 -0500

Changed in light-themes (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Honghe Wu (honghe) wrote :

ubuntu 11.10 x86,
after installed, there is no more warning.
Maybe it is OK now.
(I don't really know what the warning stand for)

Revision history for this message
buchs (buchsk) wrote :

Ubuntu 11.10: I just had the warning given, and I tried the fix here, but apt-get told me I had already installed the latest version. So, the problem persists for me.

Revision history for this message
buchs (buchsk) wrote :

I'd like to remove my last comment - but can't determine how. There was a reference to this bug report from another error message report elsewhere, but I now see it is not the same problem as reported here. So, forget what I say.

Revision history for this message
Jo Vermeulen (jozilla) wrote :

This bug seems to be back in 12.04?

Revision history for this message
Vladimir Scherbaev (zemik) wrote :

Yesterday see this bug at 11.10 with last updates.

Revision history for this message
kapetr (kapetr) wrote :

Yes - it is back in Precise :-/

Revision history for this message
Scott Moser (smoser) wrote :

This is not fixed in 11.10. The fix was made to 12.04 only.
Additionally, it seems it was regressed after it was fixed:
 http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/precise/light-themes/precise/revision/58

The fix I made to debian/control was backed out.

Revision history for this message
Enkouyami (furyhamster) wrote :

Was it supposed to have a comma? " gtk2-engines-pixbuf,"?

Revision history for this message
actionparsnip (andrew-woodhead666) wrote :

sudo apt-get install gtk2-engines-pixbuf

No comma

Revision history for this message
David Tombs (dgtombs) wrote :

Do you think that revert was a mistake, Scott? It's weird that the commit also removed your changelog lines.

Changed in light-themes (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
Scott Moser (smoser) wrote :

David,
  It was accidently regressed. I committed the fix to bzr in lp:ubuntu/precise/light-themes and pushed to that repo.
  Then, Ken did an upload without looking, and regressed it.

Ken, Can you fix this with an upload to quantal?

Revision history for this message
Ken VanDine (ken-vandine) wrote :

Actually after looking closer, this was intentionally removed. version 1.9.1-0ubuntu1 removed the need for gtk2-engines-pixbuf to save CD space. So it actually should no longer be needed.

Revision history for this message
Andrea Cimitan (cimi) wrote :

I second Ken. It's no longer required for light-themes.

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

That was essentially my conclusion in #12, 9 months ago…I guess I should have said so more clearly.

Changed in light-themes (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers