Traceback in logs after uploading a file (OK out of order because of throttling)

Bug #479204 reported by Nicola Larosa on 2009-11-09
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu One storage protocol
High
Facundo Batista
ubuntuone-storage-protocol (Ubuntu)
High
dobey
Karmic
Undecided
Unassigned

Bug Description

After uploading a file, the following traceback appeared in both syncdaemon logs:

2009-11-09 14:51:37,326 - twisted - ERROR - Unhandled Error
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/twisted/python/log.py", line 84, in callWithLogger
    return callWithContext({"system": lp}, func, *args, **kw)
  File "/usr/lib/python2.6/dist-packages/twisted/python/log.py", line 69, in callWithContext
    return context.call({ILogContext: newCtx}, func, *args, **kw)
  File "/usr/lib/python2.6/dist-packages/twisted/python/context.py", line 59, in callWithContext
    return self.currentContext().callWithContext(ctx, func, *args, **kw)
  File "/usr/lib/python2.6/dist-packages/twisted/python/context.py", line 37, in callWithContext
    return func(*args,**kw)
--- <exception caught here> ---
  File "/usr/lib/python2.6/dist-packages/twisted/internet/gtk2reactor.py", line 199, in _doReadOrWrite
    why = source.doRead()
  File "/usr/lib/python2.6/dist-packages/twisted/internet/tcp.py", line 140, in doRead
    return Connection.doRead(self)
  File "/usr/lib/python2.6/dist-packages/twisted/internet/tcp.py", line 463, in doRead
    return self.protocol.dataReceived(data)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1171, in dataReceived
    StorageClient.dataReceived(self, data)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 81, in dataReceived
    request.RequestHandler.dataReceived(self, data)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/request.py", line 172, in dataReceived
    self.buildMessage(data)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/request.py", line 219, in buildMessage
    self.processMessage(message)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/action_queue.py", line 149, in processMessage
    result = ThrottlingStorageClient.processMessage(self, message)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/request.py", line 260, in processMessage
    str(message).replace("\n"," ")))
exceptions.Exception: peer cant handle message 'OK' {id: 161 type: OK }

Version is 1.1+r274, here's the config:

syncdaemon.conf:
[bandwidth_throttling]
on = True
read_limit = 2097152
write_limit = 24576

ubuntuone-client.conf:
[ubuntuone]
connected = True
connect = 0
show_applet = 0
bookmarked = True

Related branches

Nicola Larosa (teknico) wrote :

It happened again. When adding 13 files to a shared directory, only 7 did show up on the web, and 6 tracebacks appeared in syncdaemon-exceptions.log: https://pastebin.canonical.com/24777/ .

Nicola Larosa (teknico) wrote :

[bandwidth_throttling]
read_limit = 61440
write_limit = 24576
on = True

Guillermo Gonzalez (verterok) wrote :

After talking a bit with Nicola, looks like this might be caused by throttling not been aware of message boundaries

Changed in ubuntuone-client:
status: New → Triaged
assignee: nobody → Lucio Torre (lucio.torre)
tags: added: foundations+
tags: added: chicharra-lucid-problems
Changed in ubuntuone-client:
importance: Undecided → High
assignee: Lucio Torre (lucio.torre) → Facundo Batista (facundo)
status: Triaged → In Progress
summary: - Traceback in logs after uploading a file
+ Traceback in logs after uploading a file (OK out of order because of
+ throttling)
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-12-11
affects: ubuntuone-client → ubuntuone-storage-protocol
Changed in ubuntuone-storage-protocol (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: New → In Progress
Changed in ubuntuone-storage-protocol:
status: Fix Committed → Fix Released

Accepted ubuntuone-storage-protocol into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-storage-protocol - 1.0.1-0ubuntu1

---------------
ubuntuone-storage-protocol (1.0.1-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release
    - Avoid extra throttling and bytes message calls (LP: #479204)
    - Correctly raise StorageRequestError on ERROR (LP: #450633)
    - Avoid double connection factory confusion (LP: #457147)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 14:30:00 -0500

Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: Fix Committed → Fix Released
dobey (dobey) on 2010-02-18
Changed in ubuntuone-storage-protocol (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers