ubuntuone-login crashed with DBusException in __new__(): org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-kCtlvHGbi4: Connection refused

Bug #711324 reported by Roland Dreier on 2011-02-01
300
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-3-0
Medium
Unassigned
Stable-4-0
Medium
Unassigned
Stable-4-2
Undecided
Unassigned
Trunk
Medium
dobey
ubuntuone-client (Ubuntu)
Medium
dobey
Precise
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
dobey

Bug Description

Binary package hint: ubuntuone-client

My system turned off (not sure why, I closed the lid and walked away) and on reboot, I got this apport bug.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubuntuone-client 1.5.3-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Tue Feb 1 08:10:20 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/ubuntuone-client/ubuntuone-login
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101206)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-login
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_US.utf8
 PATH=(custom, user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
PythonArgs: ['/usr/lib/ubuntuone-client/ubuntuone-login']
SourcePackage: ubuntuone-client
Title: ubuntuone-login crashed with DBusException in __new__(): org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-kCtlvHGbi4: Connection refused
UbuntuOneSyncdaemonExceptionsLog:

UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Related branches

Roland Dreier (roland.dreier) wrote :
tags: removed: need-duplicate-check
Roman Yepishev (rye) wrote :

Hello,
It does not look like this is Ubuntu One-specific issue. It looks like your machine went to sleep and upon waking up dbus service has either crashed or became unresponsive. Are you able to reproduce this? I.e. can you try suspending your computer and check whether ubuntuone-login crashes when you resume it?

Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Roman Yepishev (rye)
status: New → Incomplete
tags: added: bugpattern-needed
Sebastien Bacher (seb128) wrote :

it could happen on session closing and apport would notify the user on next login, you might want to catch those exception to reduce the launchpad bug spam though

tags: added: precise
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Medium
dobey (dobey) on 2012-10-19
Changed in ubuntuone-client (Ubuntu):
assignee: Roman Yepishev (rye) → nobody
status: Incomplete → Triaged
Changed in ubuntuone-client (Ubuntu Quantal):
status: New → Triaged
milestone: none → quantal-updates
Changed in ubuntuone-client (Ubuntu Precise):
status: New → Triaged
milestone: none → precise-updates
Changed in ubuntuone-client (Ubuntu Quantal):
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu Precise):
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu Raring):
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client (Ubuntu Quantal):
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client (Ubuntu Precise):
assignee: nobody → Rodney Dawes (dobey)
dobey (dobey) on 2012-12-11
information type: Private → Public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 4.1.0-0ubuntu1

---------------
ubuntuone-client (4.1.0-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Trap DBusException on ubuntuone-login startup. (LP: #711324)
    - Remove messaging menu integration. (LP: #820345)
    - Avoid KeyError during an Upload. (LP: #988534)
    - Ignore .lock files from synchronization. (LP: #1042268)
    - Avoid duplicate state tracking for sync menu. (LP: #1053631)
    - Add a separator between recent and current transfers. (LP: #1054259)
    - Search and filtering API for shares tab in control panel. (LP: #1056197)
    - Ensure Upload/Download objects have path attribute. (LP: #1061490)
    - Use correct file size for percentages in sync menu. (LP: #1062729)
    - Open shares tab from sync menu. (LP: #1063786)
    - Open the Ubuntu One folder from sync menu. (LP: #1063788)
    - Use correct glib method to launch control panel. (LP: #1065272)
    - Always use GI bindings in launch and login scripts. (LP: #1066943)
    - Show active downloads in transfers menu as well. (LP: #1067806)
    - Avoid duplicates in transfers menu. (LP: #1069953)
    - Do case-insenstive fuzzy filename matching. (LP: #1073664)
  * debian/watch:
    - Update to use stable-4-2 series for Ubuntu 13.04 releases.
 -- Rodney Dawes <email address hidden> Tue, 11 Dec 2012 17:05:43 -0500

Changed in ubuntuone-client (Ubuntu Raring):
status: Triaged → Fix Released
dobey (dobey) on 2014-01-29
Changed in ubuntuone-client (Ubuntu Precise):
assignee: Rodney Dawes (dobey) → nobody
Changed in ubuntuone-client (Ubuntu Quantal):
assignee: Rodney Dawes (dobey) → nobody
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in ubuntuone-client (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.