Nautilus is not aware of published files

Bug #661292 reported by Matt Griffin on 2010-10-15
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-4
Medium
Unassigned
Trunk
High
Unassigned
ubuntuone-client (Ubuntu)
Undecided
Unassigned
Maverick
Medium
dobey

Bug Description

The right-click option in Nautilus does not show published files. I ran the get_public_files method and Nautilus began to show published files.

----

TEST CASE:
1. Open Places > Ubuntu One
2. Right-click on a file (661292.txt) and select "Ubuntu One > Publish"
3. Restart Ubuntu
4. Right-click on file and select "Ubuntu One" menu

Result: Right-click Ubuntu One menu displays option to: "Publish"

Expected Result: Right-click Ubuntu One menu displays options to: "Stop Publishing" and "Copy Web Link"

----

Related branches

Changed in ubuntuone-client:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Changed in ubuntuone-client:
status: New → In Progress
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2011-02-18
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
milestone: none → maverick-updates
status: New → In Progress
Changed in ubuntuone-client (Ubuntu):
status: New → Invalid

Accepted ubuntuone-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
description: updated
description: updated
tags: added: verification-failed
removed: verification-needed
Joshua Hoover (joshuahoover) wrote :

Failed the test case with ubuntuone-client 1.4.6-0ubuntu1 installed. After restart, published files don't show that they're published according to the context menu.

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

Joshua, is this a regression, or just a failed bug fix? I. e. should we still move this to -updates to release the other fixes and keep this open, or dump the update?

dobey (dobey) wrote :

Martin, I just pushed 1.4.6-0ubuntu2 to maverick-proposed to resolve the issues with testing this.

Vadim Peretokin (vperetokin) wrote :

8 hours later, it still shows: "Maverick-proposed (1.4.6-0ubuntu1): main/net " - I don't think the change is coming through...

Martin Pitt (pitti) wrote :

Accepted ubuntuone-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed

I can confirm that the fix works after using it extensively for a week now
without the previous problems.

Joshua Hoover (joshuahoover) wrote :

Vadim, Thanks for the help! Do you know if you ever restarted Nautilus or it crashed on you? I ask because Nautilus shows the published files properly but only after I killall -9 nautilus.

Vadim Peretokin (vperetokin) wrote :

It hasn't crashed it on me, but I did restart Nautilus after applying the
update and through reboots since then... it knew of published files both
after publishing and after a restart (though I do have to re-publish, but it
seems instant).

Martin Pitt (pitti) on 2011-03-17
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.4.6-0ubuntu2

---------------
ubuntuone-client (1.4.6-0ubuntu2) maverick-proposed; urgency=low

  * 01-get-published-race.path:
    - Fix a race condition with requesting published files (LP: #661292)

ubuntuone-client (1.4.6-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - SD deletes files when local error on partial creation (LP: #657195)
    - Partials fail to be created with "filename too long" (LP: #662660)
    - New shares to me are not downloaded (LP: #664019)
    - Deleting UDF on one computer does not delete elsewhere (LP: #674092)
    - Preferences does not display info properly (LP: #657850)
    - "Out of Space" dialog is broken (LP: #650671)
    - Nautilus allows publishing files in others' shares (LP: #712674)
    - SSO help text does not appear translated (LP: #686647)
    - Nautilus is not aware of published files (LP: #661292)
    - Ubuntu One crashes in scan() (LP: #692496)
    - Volume info with None for free space causes QuotaExceeded (LP: #671023)
    - Settings daemon extension should not request credentials (LP: #702171)
 -- Rodney Dawes <email address hidden> Fri, 04 Mar 2011 12:10:05 -0500

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
Andrea Olivo (andryandrew) wrote :

I can reproduce the very same bug in 11.04 Natty Narwhal. It's just me or there was a regression?

@Andrea Olivo
I have the same thing with Natty Narwhal:
with:
Nautilus (1:2.32.2.1-0ubuntu13)

and

ubuntuone-client (1.6.2-0ubuntu1)

tags: added: testcase
Strange Fox (kero-05h) wrote :

Confirming on Ubuntu 12.04 precise!

3.0.0-0ubuntu1 << Ubuntu One Client
1:3.4.1-0ubuntu1 << nautilus

At first nautilus detects that the files are published and offers to let me copy the link, but later one (perhaps after a reboot?) it looses track! Checking at one.ubuntu.com shows the files are still published, even though nautilus doesn't detect so. (They all seem unpublished!)

How can I help get this thing fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers