ubuntuone-launch fails to start syncdaemon if dbus call times out

Bug #651237 reported by Roman Yepishev on 2010-09-29
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-4
Medium
Roman Yepishev
Trunk
Medium
Roman Yepishev
ubuntuone-client (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned
Natty
Medium
Unassigned

Bug Description

In case syncdaemon startup takes more time than specified in dbus timeout, ubuntuone-launch exits with os._exit(1) instead of waiting for 'READY' signal from syncdaemon.

The fix for this may be to set wait_for_ready as both callback and errback so that we will continue waiting for the signal even if dbus handler calls d.errback.

Related branches

Roman Yepishev (rye) on 2010-09-29
Changed in ubuntuone-client:
assignee: nobody → Roman Yepishev (rye)
John Lenton (chipaca) on 2010-09-29
tags: added: u1-maverick-sru
removed: u1-maverick

Accepted ubuntuone-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Giovanni Mellini (merlos) wrote :

I reported in a different bug with lot of people
 https://bugs.launchpad.net/bugs/584019
and I tested (as suggested from Naty Bidart) the proposed package and this fix the issue of u1 don't connecting at startup.
Now u1 autoconnect at session start.

The only problem I have now is that the nautilus estension for u1 is gone. How I can restore the nautilus integration??

giovanni@whaleshark:~$ dpkg-query -l 'ubuntuone-client'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome Versione Descrizione
+++-=======================================-=======================================-==============================================================================================
ii ubuntuone-client 1.4.5-0ubuntu1 Ubuntu One client
giovanni@whaleshark:~$

Giovanni Mellini (merlos) wrote :

As reported in the other bug installing the proposed package fix the bug issue but uninstall ubuntuone-client-gnome, that broke nautilus integration.

As you can see in 10.10 ubuntu-client-gnome depends from ubuntuone-client (= 1.4.4.1-0ubuntu1), and this is why was uninstalled.

Any suggestion??
tks, Giovanni

giovanni@whaleshark:~$ dpkg-query -p ubuntuone-client-gnome
Package: ubuntuone-client-gnome
Priority: optional
Section: gnome
Installed-Size: 488
Maintainer: Ubuntu Developers <email address hidden>
Architecture: i386
Source: ubuntuone-client
Version: 1.4.4.1-0ubuntu1
Replaces: ubuntuone-client (<= 1.1.1)
Depends: libatk1.0-0 (>= 1.29.3), libc6 (>= 2.3.6-6~), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libebook1.2-9 (>= 2.30.3), libedataserver1.2-13 (>= 2.30.3), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgconf2-4 (>= 2.31.1), libgdk-pixbuf2.0-0 (>= 2.21.6), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.20.0), libnautilus-extension1 (>= 2.30), libpango1.0-0 (>= 1.14.0), libpng12-0 (>= 1.2.13-4), libsoup2.4-1 (>= 2.4.0), libsyncdaemon-1.0-1, libxml2 (>= 2.6.27), python, ubuntuone-client (= 1.4.4.1-0ubuntu1), python-gtk2 (>= 2.10), python-simplejson, gnome-settings-daemon, python-gnomekeyring | python-gnome2-desktop
Suggests: ubuntuone-client-dbg
Breaks: ubuntuone-client (<= 1.1.1)
Size: 92320
Description: Ubuntu One client GNOME integration
 Ubuntu One is a suite of on-line services. This package contains the tray
 applet and Nautilus extension, providing integration with the GNOME desktop.
Homepage: https://one.ubuntu.com
Original-Maintainer: Rick McBride <email address hidden>

Rick McBride (rmcbride) wrote :

Giovanni,

The problem you encountered with some packages being uninstalled because of dependency specifications is due to the fact that installing the maverick-proposed version of ubuntuone-client using aptitude will require that all of the client packages are specified on the install line, this will get them all at the same version. The alternative would be to do a full upgrade to the maverick-proposed repository, and I don't think that's what you want to do.

so:

sudo aptitude install ubuntuone-client/maverick-proposed ubuntuone-client-gnome/maverick-proposed ubuntuone-client-tools/maverick-proposed libsyncdaemon-1.0-1/maverick-proposed ubuntuone-client/maverick-proposed python-ubuntuone-client/maverick-proposed

should get you where you want to be. You'd also want to add 'ubuntuone-client-dbg' to that if you happen to have the debug extensions installed.

Rick McBride (rmcbride) wrote :

My testing of this, including inducing a "heavy metadata activity" state by adding a lot of (>1000) small files and restarting to verify correct starting under those conditions, shows that the version of the client packages in maverick-proposed does indeed fix this issue. Thanks also to Giovanni Mellini, who was affected by this directly and confirmed that the proposed package corrects his problem.

Rick McBride (rmcbride) wrote :

Test Case:
1. Created a state where metadata rescan would re-create the root issue.
2. confirmed that the release client encountered the described behavior on login.
3. Upgraded to the maverick-release package.
4. re-ran the simple file creation script to ensure that metadata would still be in rescan on restart.
5. Restarted, verified that client behavior is now normal in this case.
6. removed client from automatically started applications
7. restarted, verified that client was not started.
8. manually started client, verified that startup and connection occurred correctly.

VERIFICATION DONE.
This bug is fixed in the version of packages in maverick-proposed.

Giovanni Mellini (merlos) wrote :

Rick McBride suggestion fix the problem with nautilus extension, now everything works fine.
tks a lot for the fix

tags: added: verification-done
removed: verification-needed
dobey (dobey) on 2010-12-09
Changed in ubuntuone-client (Ubuntu Natty):
importance: Undecided → Medium
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.4.5-0ubuntu1

---------------
ubuntuone-client (1.4.5-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release:
    - Add Ubuntu One root dir to Nautilus places (Rodrigo Moya) (LP: #641287)
    - Fix translation of SSO help text (Rodrigo Moya) (LP: #647483)
    - Wait for READY signal even if dbus client calls d.errback (Roman Yepishev)
      (LP: #651237)
    - Don't depend on DBus introspection, we don't need it (Rodrigo Moya)
      (LP: #621084)
 -- Rodrigo Moya <email address hidden> Thu, 14 Oct 2010 17:52:03 +0200

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
hanzz (hans-prueller) wrote :

I am still having issues with ubuntuone client not connecting automatically after startup, and I really hoped that the mentioned fix would solve my problem.

yesterday I installed the fix from the proposed sources, ubuntuone-client 1.4.5-0ubuntu1

but I am still having issues. either the problem is not the same as this bug or the fix does not work under all circumstances?

I have running my desktop and am connected to the internet for some hours now (via my 3G umts data modem), u1sdtool -s says:

u1s hansp@smithers:~$ u1sdtool -s

Oops, an error ocurred:
Traceback (most recent call last):
Failure: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
hansp@smithers:~$

As I understood the description of this bug, this is exactly affecting me - obviously the fix doesnt work in my case ! ???

it strange but invoking u1sdtool -s some minutes later again is changes to:

hansp@smithers:~$ u1sdtool -s
State: LOCAL_RESCAN
    connection: Not User With Network
    description: doing local rescan
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING_ON_BOTH

but still is_connected = false, is_online = false ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers