[Freeze Exception] Add instructional text to Ubuntu One Preferences application

Bug #539676 reported by Matt Griffin on 2010-03-16
68
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
John Lenton
Ubuntu Translations
Undecided
Unassigned
ubuntuone-client (Ubuntu)
Medium
John Lenton

Bug Description

Add instructional text to each tab so users know how to use the application's features.

Text for each tab: https://wiki.canonical.com/UbuntuOne/HelpDocs/10.04#Ubuntu%20One%20Preferences

Without this instructional text, the user may not understand how to use the features in ubuntuone-preferences.

Related branches

visibility: public → private
description: updated
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: desktop+ u1-lucid
Changed in ubuntuone-client:
status: New → Confirmed
tags: added: control-panel package
Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → John Lenton (chipaca)
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → John Lenton (chipaca)
Changed in ubuntuone-client:
milestone: none → lucid-beta-2
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
summary: - Add instructional text to Ubuntu One Preferences application
+ [Freeze Exception] Add instructional text to Ubuntu One Preferences
+ application
description: updated
tags: added: freeze-exception
visibility: private → public
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → New
Martin Pitt (pitti) wrote :

This is a bit confusing: The current U1 settings dialog already has instructional text, and the wiki page just has different strings. So is the request really about "change the current explanatory text"?

I'm also subscribing ubuntu-translators, since changing existing text will break translations. How many existing translations would be affected?

Changed in ubuntuone-client (Ubuntu):
status: New → Incomplete
John Lenton (chipaca) wrote :

I'm not sure the term 'instructional text' is correct. The linked wiki page shows both the devices and services tab with a small descriptive text, such as what the devices tab shows now. The devices tab's text should be slightly different, and the services tab needs to have that label too. I'm not sure the omission of such a text on the accounts tab is correct (will check up with the appropriate people, but it doesn't change the essence of this issue).

John Lenton (chipaca) on 2010-03-29
Changed in ubuntuone-client:
status: Confirmed → In Progress
John Lenton (chipaca) on 2010-03-30
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

The Devices tab already has instructional text, which is already translated. So my question was whether you are going to change this (which I would NACK at this point), or just add instructional text to the Services tab, which seems fine to me.

Martin Pitt (pitti) wrote :

> which I would NACK at this point

Or, rather, if you really want to do it, please get in touch with ubuntu-translators first. But I still recommend to not doing it. String changes are expensive!

Joshua Hoover (joshuahoover) wrote :

The text that is changing:

OLD: "The devices connected to with your personal cloud network are listed below"
NEW: "The following devices synchronize with your Ubuntu One account."

Text being added is:

Ubuntu One sync options
Choose services to synchronize with this computer

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.1.90-0ubuntu1

---------------
ubuntuone-client (1.1.90-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - Notify user when approaching and exceeding quota (LP: #540360)
    - Add instructional text to ubuntuone-preferences (LP: #539676)
    - UbuntuOne needs to autostart and connect by defualt (LP: #534707)
    - Impossible to infer status of file synchronization (LP: #526084)
    - Devices and Services tabs functionality and development (LP: #525803)
  * Add debian/source/format.
  * Remove python-httplib2 from the dependencies (LP: #535207)
 -- Rodney Dawes <email address hidden> Wed, 31 Mar 2010 19:47:01 -0400

Changed in ubuntuone-client (Ubuntu):
status: Incomplete → Fix Released
Steve Langasek (vorlon) wrote :

David,

(sorry - I subscribed you to the wrong bug first by mistake; too many ubuntuone freeze exceptions :)

I see that Joshua emailed ubuntu-translators about this a week ago, but received no response on the list. Since the UbuntuOne team still wants to have this change for lucid, can you please review, and determine whether the translator community thinks it's ok to make this change this late in the cycle?

Changed in ubuntuone-client (Ubuntu):
status: Fix Released → In Progress
Milo Casagrande (milo) wrote :

Just a note.
This is the text that I see now in the "Devices" tab:
The devices connected to your pseronal cloud are listed below

There is a typo in "pseronal".

El dj 01 de 04 de 2010 a les 20:58 +0000, en/na Steve Langasek va
escriure:
> David,
>
> (sorry - I subscribed you to the wrong bug first by mistake; too many
> ubuntuone freeze exceptions :)
>
> I see that Joshua emailed ubuntu-translators about this a week ago, but
> received no response on the list. Since the UbuntuOne team still wants
> to have this change for lucid, can you please review, and determine
> whether the translator community thinks it's ok to make this change this
> late in the cycle?
>

I'm trying to keep track of all UI freeze exceptions, those which are
announced and which aren't, but this one seemed to slip through the
cracks (and through the Easter break).

Seeing that the changes have already been applied to the package and
that in the upload there are other string changes which make some
strings translatable whic previously weren't, I think it would be more
work now to revert the changes than to go ahead, so ACK from me.

Thanks Steve for the heads up.

Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
tags: removed: package
Steve Langasek (vorlon) wrote :

This bug was incorrectly marked as "fix released" when the string change has *not* been accepted into the archive. But it is now sitting in the unapproved queue.

The string change described in comment #5 is the one that Martin and I said needed translation team approval.

David, your reply seems to say that this was ok because the change was already applied to the pakage - but it was not. Now, more than a full week has passed and there's even less time for translators to catch up if we make this change. Should this string change be accepted, or not?

Changed in ubuntuone-client (Ubuntu):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
status: Fix Released → In Progress
David Planella (dpm) wrote :

Just commenting with the conversation we had this morning with Steve on #ubuntu-devel:

<slangasek> dpm: I need your input on bug #539676; I think there was some miscommunication about this, the string was *not* changed previously but is now sitting in the unapproved queue
 <ubottu> Launchpad bug 539676 in ubuntuone-client "[Freeze Exception] Add instructional text to Ubuntu One Preferences application" [Medium,In progress] https://launchpad.net/bugs/539676
 --> andreasn (~<email address hidden>) ha entrat a #ubuntu-devel
  slacker_nl slangasek sladen
 <slangasek> dpm: I think the right thing to do here is to ask them to roll back that change and reupload; what do you think?
 <dpm> hi slangasek, sorry for the delay. I agree. It is quite late and the translations imports queue is really slow at the moment. I'm not sure whether there'd be time to import the new template.
 <slangasek> dpm: ok - I'll review for other issues, reject and ask for the revert, thanks
 <dpm> thanks

Ken also tells me that the upload fixes a bunch of RC bugs. Would it be possible to separate the bug fixes from the string changes and only include these on an upload?

David Planella (dpm) wrote :

Just for the record, the discussion on the translators mailing list https://lists.ubuntu.com/archives/ubuntu-translators/2010-April/003576.html, where translators gave a NACK on any string changes, unless they're on an SRU and in synch with a language pack update.

dobey (dobey) on 2010-05-06
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
David Planella (dpm) on 2010-08-02
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers