Ubuntu One stopped syncing, tried reinstall

Bug #518248 reported by Ron Lee on 2010-02-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
Ubuntu One Client Engineering team

Bug Description

I followed the reinstall procedure in FAQ #778. After starting the Ubuntu One client the new Ubuntu One folder is never created. This system used to work just fine and then it started having problems syncing. I tried removing the password key several times but that did not help. So I tried the complete reinstall. Everything looks fine on the web interface.

thanks,
Ron
p.s. there is no syncdaemon.log file. It is not making it that far. ron

ProblemType: Bug
.home.rwlee..cache.ubuntuone.log.oauth.login.log:
 2010-02-06 17:34:23,630:630.265951157 UbuntuOne.Client.Applet Starting Ubuntu One client version 1.1.1
 2010-02-06 17:38:08,932:932.379961014 UbuntuOne.Client.Applet Starting Ubuntu One client version 1.1.1
 2010-02-06 17:38:09,437:437.972068787 ubuntuone-login Starting Ubuntu One login manager version 1.1.1
.home.rwlee..config.ubuntuone.ubuntuone.client.conf:
 [ubuntuone]
 show_applet = 1
 connected = False
 connect = 0
 bookmarked = False
Architecture: i386
CrashDB: ubuntuone
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: ubuntuone-client 1.1.1+r321-0ubuntu1~ppa1~jaunty
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
ThirdParty: True
Uname: Linux 2.6.28-18-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Ron Lee (ronwlee) wrote :
Ron Lee (ronwlee) wrote :

Just tried a reboot and it looks like it is now synching.

Ron

Ron Lee (ronwlee) wrote :

It looks like the files synced with the web however the three folders at the top level still have the cloud with a red X annotation. I will let it sit for awhile longer.

thanks,
Ron

Ron Lee (ronwlee) wrote :

Just tried a simple sync test. I created a small text file and copied it in and out of the Ubuntu One folder and what I do on one machine is replicated on the other machine. The one exception seems to be when I copy in the file on one machine and delete it on another machine. The delete is not replicated. Is that the one it is suppose to work?

Ron Lee (ronwlee) wrote :

Correction, delete does work. Moving the file out of the Ubuntu One folder does not seem to be replicated. Folders still show cloud with red X annotation.

Ron Lee (ronwlee) wrote :

Came back this morning and the Shared with me folder is the only one left with the cloud and red X icon. Since no one shares with me I can't test this. This was my original problem before I tried to fix things. I am just going to ignore it since everything else works fine. Also ran into the Nautilus crashes after upgrading libglib2.0-0=2.20.1-0ubuntu2.1 (see bug https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/515336 for details). I downgraded the libglib package and I am ok now,

thanks,
Ron

Roman Yepishev (rye) wrote :

Hi Ron, thanks for reporting this.

I was not able to reproduce the bug with missing Ubuntu One folder (I hit another issue, bug #518598, which may have caused this symptom).

As per the emblem notes, it looks like this is reported as bug #498136 where the issue with "Shared for Me" files; directory emblems are discussed in bug #440848. Additionally, "Folders still show cloud with red X annotation" is described in bug #495931 which describes the issue that folders do not get remote_hash updated immediately, therefore they show 'unsynchronized' emblem.

I can not make this bug report as a duplicate of a single bug, so I am leaving status unchanged for now.

Rick McBride (rmcbride) on 2010-02-09
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Ron Lee (ronwlee) wrote :

Roman thanks for looking at this. I would say that I probably messed things up by tinkering with Ubuntu One client so the reboot cleaned things up and allowed the Ubuntu One folder to be finally created. The shared with me folder still shows the cloud with red X annotation. It has been two days. I will leave it on all day and see what happens.
 If I was to make a request I would like to ask for more status info. Reading other bug reports and the FAQs I figured out where the log files were. Then I found out where the password key was. Be nice to have some kind of debugging FAQ to tell us where the logs are and how things interact. For awhile I did not have a password key andn then I had two keys. I was able to make a big mess. I finally gave up and went for the reinstall which is what got me here.

thanks,
Ron

Duane Hinnen (duanedesign) wrote :

Ron,
Thanks for the constructive input. It is users like you that help to make Open Source projects so great. I think your idea of a FAQ/debugging check list is a good one. The closest thing to that (currently) is this page:
https://wiki.ubuntu.com/UbuntuOne/Bugs
I will bring this idea up with the Ubuntu Doc Team as well as the U1 Team. Thank you again for filing his bug and providing the regular updates to your situation.

thank you,
duanedesign

Nicola Larosa (teknico) on 2010-02-24
Changed in ubuntuone-client:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers